summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorFernando J. Pereda <ferdy@gentoo.org>2006-10-21 23:09:36 +0000
committerFernando J. Pereda <ferdy@gentoo.org>2006-10-21 23:09:36 +0000
commit4fc8fb438b30026fbc16e33507c75ba72e3812f2 (patch)
tree8e471821b77d5c23e686effaa1ad9a51fe21ad83 /dev-util
parentNot needed inherit removed (diff)
downloadgentoo-2-4fc8fb438b30026fbc16e33507c75ba72e3812f2.tar.gz
gentoo-2-4fc8fb438b30026fbc16e33507c75ba72e3812f2.tar.bz2
gentoo-2-4fc8fb438b30026fbc16e33507c75ba72e3812f2.zip
New upstream version, remove a buggy one.
(Portage version: 2.1.1)
Diffstat (limited to 'dev-util')
-rw-r--r--dev-util/git/ChangeLog8
-rw-r--r--dev-util/git/files/digest-git-1.4.3.19
-rw-r--r--dev-util/git/git-1.4.3.1.ebuild153
3 files changed, 169 insertions, 1 deletions
diff --git a/dev-util/git/ChangeLog b/dev-util/git/ChangeLog
index ee728c106cc3..361035d9ea05 100644
--- a/dev-util/git/ChangeLog
+++ b/dev-util/git/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-util/git
# Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-util/git/ChangeLog,v 1.136 2006/10/21 13:22:09 nixnut Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-util/git/ChangeLog,v 1.137 2006/10/21 23:09:35 ferdy Exp $
+
+*git-1.4.3.1 (21 Oct 2006)
+
+ 21 Oct 2006; Fernando J. Pereda <ferdy@gentoo.org> -git-1.4.3.ebuild,
+ +git-1.4.3.1.ebuild:
+ New upstream version, remove a buggy one.
21 Oct 2006; <nixnut@gentoo.org> git-1.4.2.4.ebuild:
Stable on ppc wrt bug 151669
diff --git a/dev-util/git/files/digest-git-1.4.3.1 b/dev-util/git/files/digest-git-1.4.3.1
new file mode 100644
index 000000000000..f5234281b995
--- /dev/null
+++ b/dev-util/git/files/digest-git-1.4.3.1
@@ -0,0 +1,9 @@
+MD5 8e810337f9ce908acd5cffc31d4dab21 git-1.4.3.1.tar.bz2 859292
+RMD160 0256ba4df5f1ac654ee782b11cf168dcb0308a27 git-1.4.3.1.tar.bz2 859292
+SHA256 47e49261f0d4e8733de3f90d6be8b445fae0634b125a433c8110039bf485349a git-1.4.3.1.tar.bz2 859292
+MD5 0bf4ddade81d032f51c922150b654e16 git-htmldocs-1.4.3.1.tar.bz2 301586
+RMD160 d2e8a93c593f25b73c2bab173163e7364361d8e1 git-htmldocs-1.4.3.1.tar.bz2 301586
+SHA256 f9376688169ee331913b2130134de39972d7aaa47135017112b9abff72304cb3 git-htmldocs-1.4.3.1.tar.bz2 301586
+MD5 733509686ef995671909bc3725b10d8b git-manpages-1.4.3.1.tar.bz2 96649
+RMD160 b1eba204ea72c2a673678ec453ca1eb46f5d5e2e git-manpages-1.4.3.1.tar.bz2 96649
+SHA256 378a698fab917e3bccb1b1f842a11dead60e9201dee7f0cca9b80e19754a9ed2 git-manpages-1.4.3.1.tar.bz2 96649
diff --git a/dev-util/git/git-1.4.3.1.ebuild b/dev-util/git/git-1.4.3.1.ebuild
new file mode 100644
index 000000000000..d5087b971599
--- /dev/null
+++ b/dev-util/git/git-1.4.3.1.ebuild
@@ -0,0 +1,153 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-util/git/git-1.4.3.1.ebuild,v 1.1 2006/10/21 23:09:36 ferdy Exp $
+
+inherit python toolchain-funcs eutils elisp-common perl-module
+
+DOC_VER=${PV}
+
+DESCRIPTION="GIT - the stupid content tracker"
+HOMEPAGE="http://kernel.org/pub/software/scm/git/"
+SRC_URI="mirror://kernel/software/scm/git/${P}.tar.bz2
+ mirror://kernel/software/scm/git/${PN}-manpages-${DOC_VER}.tar.bz2
+ doc? ( mirror://kernel/software/scm/git/${PN}-htmldocs-${DOC_VER}.tar.bz2 )"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd"
+IUSE="curl doc elibc_uclibc emacs gtk mozsha1 ppcsha1 tk webdav"
+
+DEPEND="dev-libs/openssl
+ sys-libs/zlib
+ !app-misc/git
+ curl? ( net-misc/curl )
+ webdav? ( dev-libs/expat )
+ emacs? ( virtual/emacs )"
+RDEPEND="${DEPEND}
+ dev-lang/perl
+ >=dev-lang/python-2.3
+ app-text/rcs
+ tk? ( dev-lang/tk )
+ gtk? ( >=dev-python/pygtk-2.6 )"
+
+# This is needed because for some obscure reasons future calls to make don't
+# pick up these exports if we export them in src_unpack()
+exportmakeopts() {
+ local myopts
+
+ if use mozsha1 ; then
+ myopts="${myopts} MOZILLA_SHA1=YesPlease"
+ elif use ppcsha1 ; then
+ myopts="${myopts} PPC_SHA1=YesPlease"
+ fi
+
+ if use curl ; then
+ use webdav || myopts="${myopts} NO_EXPAT=YesPlease"
+ else
+ myopts="${myopts} NO_CURL=YesPlease"
+ use webdav && ewarn "USE=webdav only matters with USE=curl. Ignoring."
+ fi
+
+ myopts="${myopts} WITH_SEND_EMAIL=YesPlease"
+
+ # Older python versions need own subproccess.py
+ python_version
+ [[ ${PYVER} < 2.4 ]] && myopts="${myopts} WITH_OWN_SUBPROCESS_PY=YesPlease"
+
+ use elibc_uclibc && myopts="${myopts} NO_ICONV=YesPlease"
+
+ export MY_MAKEOPTS=${myopts}
+}
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+
+ sed -i \
+ -e "s:^\(CFLAGS = \).*$:\1${CFLAGS} -Wall:" \
+ -e "s:^\(LDFLAGS = \).*$:\1${LDFLAGS}:" \
+ -e "s:^\(CC = \).*$:\1$(tc-getCC):" \
+ -e "s:^\(AR = \).*$:\1$(tc-getAR):" \
+ Makefile || die "sed failed"
+
+ exportmakeopts
+}
+
+src_compile() {
+ emake ${MY_MAKEOPTS} DESTDIR="${D}" prefix=/usr || die "make failed"
+
+ if use emacs ; then
+ elisp-compile contrib/emacs/{,vc-}git.el || die "emacs modules failed"
+ fi
+}
+
+src_install() {
+ emake ${MY_MAKEOPTS} DESTDIR="${D}" prefix=/usr install || die "make install failed"
+
+ use tk || rm "${D}"/usr/bin/gitk
+
+ doman "${WORKDIR}"/man?/*
+
+ dodoc README COPYING Documentation/SubmittingPatches
+ if use doc ; then
+ dodoc Documentation/technical/*
+ dodir /usr/share/doc/${PF}/html
+ cp -r "${WORKDIR}"/{*.html,howto} "${D}"/usr/share/doc/${PF}/html
+ fi
+
+ if use emacs ; then
+ insinto "${SITELISP}"
+ doins contrib/emacs/{,vc-}git.el*
+ elisp-site-file-install "${FILESDIR}"/70git-gentoo.el
+ fi
+
+ if use gtk ; then
+ dobin contrib/gitview/gitview
+ use doc && dodoc contrib/gitview/gitview.txt
+ fi
+
+ insinto /etc/xinetd.d
+ newins "${FILESDIR}"/git-daemon.xinetd git-daemon
+
+ newinitd "${FILESDIR}"/git-daemon.initd git-daemon
+ newconfd "${FILESDIR}"/git-daemon.confd git-daemon
+
+ fixlocalpod
+}
+
+src_test() {
+ cd "${S}"
+
+ has_version dev-util/subversion || \
+ MY_MAKEOPTS="${MY_MAKEOPTS} NO_SVN_TESTS=YesPlease"
+ emake ${MY_MAKEOPTS} DESTDIR="${D}" prefix=/usr test || die "tests failed"
+}
+
+pkg_postinst() {
+ use emacs && elisp-site-regen
+ einfo
+ einfo "If you want to import arch repositories into git, consider using the"
+ einfo "git-archimport command. You should install dev-util/tla before."
+ einfo
+ einfo "If you want to import cvs repositories into git, consider using the"
+ einfo "git-cvsimport command. You should install >=dev-util/cvsps-2.1 before."
+ einfo
+ einfo "If you want to import svn repositories into git, consider using the"
+ einfo "git-svnimport command. You should install dev-util/subversion before."
+ einfo
+ einfo "If you want to manage subversion repositories using git, consider"
+ einfo "using git-svn. You should install dev-util/subversion and dev-perl/libwww-perl."
+ einfo
+ einfo "If you want to import a quilt series into git, consider using the"
+ einfo "git-quiltimport command. You should install dev-util/quilt before."
+ einfo
+ einfo "If you want to use the included CVS server you will need to install"
+ einfo "dev-perl/DBI and dev-perl/DBD-SQLite."
+ einfo
+}
+
+pkg_postrm() {
+ # regenerate site-gentoo if we are merged USE=emacs and unmerged
+ # USE=-emacs
+ has_version virtual/emacs && elisp-site-regen
+}