summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorFernando J. Pereda <ferdy@gentoo.org>2006-10-17 07:06:48 +0000
committerFernando J. Pereda <ferdy@gentoo.org>2006-10-17 07:06:48 +0000
commit4a51bd45ea4c2870a63d7d6baed120002a1d700e (patch)
treef6207b184528f708aacd1d04a84862bfefb43023 /dev-util
parentAdded ~sparc-fbsd keyword. (diff)
downloadgentoo-2-4a51bd45ea4c2870a63d7d6baed120002a1d700e.tar.gz
gentoo-2-4a51bd45ea4c2870a63d7d6baed120002a1d700e.tar.bz2
gentoo-2-4a51bd45ea4c2870a63d7d6baed120002a1d700e.zip
New upstream version. Remove old (1.4.0-r1) and buggy (1.4.2.3) ones.
(Portage version: 2.1.1)
Diffstat (limited to 'dev-util')
-rw-r--r--dev-util/git/ChangeLog8
-rw-r--r--dev-util/git/files/digest-git-1.4.2.49
-rw-r--r--dev-util/git/git-1.4.2.4.ebuild151
3 files changed, 167 insertions, 1 deletions
diff --git a/dev-util/git/ChangeLog b/dev-util/git/ChangeLog
index 102f767f1e2f..68d8d80130a8 100644
--- a/dev-util/git/ChangeLog
+++ b/dev-util/git/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-util/git
# Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-util/git/ChangeLog,v 1.127 2006/10/04 17:48:13 grobian Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-util/git/ChangeLog,v 1.128 2006/10/17 07:06:47 ferdy Exp $
+
+*git-1.4.2.4 (17 Oct 2006)
+
+ 17 Oct 2006; Fernando J. Pereda <ferdy@gentoo.org> -git-1.4.0-r1.ebuild,
+ -git-1.4.2.3.ebuild, +git-1.4.2.4.ebuild:
+ New upstream version. Remove old (1.4.0-r1) and buggy (1.4.2.3) ones.
04 Oct 2006; Fabian Groffen <grobian@gentoo.org> git-1.4.0-r1.ebuild,
git-1.4.1.1.ebuild, git-1.4.2.3.ebuild:
diff --git a/dev-util/git/files/digest-git-1.4.2.4 b/dev-util/git/files/digest-git-1.4.2.4
new file mode 100644
index 000000000000..d2a4595d7c6d
--- /dev/null
+++ b/dev-util/git/files/digest-git-1.4.2.4
@@ -0,0 +1,9 @@
+MD5 44ecfbf9817f36bd5fdba172b9b58d60 git-1.4.2.4.tar.bz2 787793
+RMD160 03664bb1c98c7d9dc8c6f1dfa56149d807fd5164 git-1.4.2.4.tar.bz2 787793
+SHA256 1efbbee0e3e8704b25ef6fbc9519ba6f94a21aee48a231b986408627a4017632 git-1.4.2.4.tar.bz2 787793
+MD5 c4820612a1643dad246a335847135be8 git-htmldocs-1.4.2.4.tar.bz2 283907
+RMD160 6aaa9e601cc16d4e45176e58fbbc87a332afb243 git-htmldocs-1.4.2.4.tar.bz2 283907
+SHA256 90f3ad4bced74bbadfc6f02a1c3d222a6bcf13d940b9aef368b7cbae083c1f86 git-htmldocs-1.4.2.4.tar.bz2 283907
+MD5 c22ea4eab09808a1783603b5a1d159a5 git-manpages-1.4.2.4.tar.bz2 90375
+RMD160 0b3d486d04a5a64aab273c75823c603f307fcd02 git-manpages-1.4.2.4.tar.bz2 90375
+SHA256 6e0520fd779225e79957871d981ddfc9e93f157374de88f654d4f20958557518 git-manpages-1.4.2.4.tar.bz2 90375
diff --git a/dev-util/git/git-1.4.2.4.ebuild b/dev-util/git/git-1.4.2.4.ebuild
new file mode 100644
index 000000000000..d7e7d6af7e2a
--- /dev/null
+++ b/dev-util/git/git-1.4.2.4.ebuild
@@ -0,0 +1,151 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-util/git/git-1.4.2.4.ebuild,v 1.1 2006/10/17 07:06:47 ferdy Exp $
+
+inherit python toolchain-funcs eutils elisp-common
+
+DOC_VER=${PV}
+
+DESCRIPTION="GIT - the stupid content tracker"
+HOMEPAGE="http://kernel.org/pub/software/scm/git/"
+SRC_URI="mirror://kernel/software/scm/git/${P}.tar.bz2
+ mirror://kernel/software/scm/git/${PN}-manpages-${DOC_VER}.tar.bz2
+ doc? ( mirror://kernel/software/scm/git/${PN}-htmldocs-${DOC_VER}.tar.bz2 )"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd"
+IUSE="curl doc emacs gtk mozsha1 ppcsha1 tk webdav"
+
+DEPEND="dev-libs/openssl
+ sys-libs/zlib
+ !app-misc/git
+ curl? ( net-misc/curl )
+ webdav? ( dev-libs/expat )
+ emacs? ( virtual/emacs )"
+RDEPEND="${DEPEND}
+ dev-lang/perl
+ >=dev-lang/python-2.3
+ app-text/rcs
+ tk? ( dev-lang/tk )
+ gtk? ( >=dev-python/pygtk-2.6 )"
+
+# This is needed because for some obscure reasons future calls to make don't
+# pick up these exports if we export them in src_unpack()
+exportmakeopts() {
+ local myopts
+
+ if use mozsha1 ; then
+ myopts="${myopts} MOZILLA_SHA1=YesPlease"
+ elif use ppcsha1 ; then
+ myopts="${myopts} PPC_SHA1=YesPlease"
+ fi
+
+ if use curl ; then
+ use webdav || myopts="${myopts} NO_EXPAT=YesPlease"
+ else
+ myopts="${myopts} NO_CURL=YesPlease"
+ use webdav && ewarn "USE=webdav only matters with USE=curl. Ignoring."
+ fi
+
+ myopts="${myopts} WITH_SEND_EMAIL=YesPlease"
+
+ # Older python versions need own subproccess.py
+ python_version
+ [[ ${PYVER} < 2.4 ]] && myopts="${myopts} WITH_OWN_SUBPROCESS_PY=YesPlease"
+
+ use elibc_uclibc && myopts="${myopts} NO_ICONV=YesPlease"
+
+ export MY_MAKEOPTS=${myopts}
+}
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+
+ sed -i \
+ -e "s:^\(CFLAGS = \).*$:\1${CFLAGS} -Wall:" \
+ -e "s:^\(LDFLAGS = \).*$:\1${LDFLAGS}:" \
+ -e "s:^\(CC = \).*$:\1$(tc-getCC):" \
+ -e "s:^\(AR = \).*$:\1$(tc-getAR):" \
+ Makefile || die "sed failed"
+
+ exportmakeopts
+}
+
+src_compile() {
+ emake ${MY_MAKEOPTS} DESTDIR="${D}" prefix=/usr || die "make failed"
+
+ if use emacs ; then
+ elisp-compile contrib/emacs/{,vc-}git.el || die "emacs modules failed"
+ fi
+}
+
+src_install() {
+ emake ${MY_MAKEOPTS} DESTDIR="${D}" prefix=/usr install || die "make install failed"
+
+ use tk || rm "${D}"/usr/bin/gitk
+
+ doman "${WORKDIR}"/man?/*
+
+ dodoc README COPYING Documentation/SubmittingPatches
+ if use doc ; then
+ dodoc Documentation/technical/*
+ dodir /usr/share/doc/${PF}/html
+ cp -r "${WORKDIR}"/{*.html,howto} "${D}"/usr/share/doc/${PF}/html
+ fi
+
+ if use emacs ; then
+ insinto "${SITELISP}"
+ doins contrib/emacs/{,vc-}git.el*
+ elisp-site-file-install "${FILESDIR}"/70git-gentoo.el
+ fi
+
+ if use gtk ; then
+ dobin contrib/gitview/gitview
+ use doc && dodoc contrib/gitview/gitview.txt
+ fi
+
+ insinto /etc/xinetd.d
+ newins "${FILESDIR}"/git-daemon.xinetd git-daemon
+
+ newinitd "${FILESDIR}"/git-daemon.initd git-daemon
+ newconfd "${FILESDIR}"/git-daemon.confd git-daemon
+}
+
+src_test() {
+ cd "${S}"
+
+ has_version dev-util/subversion || \
+ MY_MAKEOPTS="${MY_MAKEOPTS} NO_SVN_TESTS=YesPlease"
+ emake ${MY_MAKEOPTS} DESTDIR="${D}" prefix=/usr test || die "tests failed"
+}
+
+pkg_postinst() {
+ use emacs && elisp-site-regen
+ einfo
+ einfo "If you want to import arch repositories into git, consider using the"
+ einfo "git-archimport command. You should install dev-util/tla before."
+ einfo
+ einfo "If you want to import cvs repositories into git, consider using the"
+ einfo "git-cvsimport command. You should install >=dev-util/cvsps-2.1 before."
+ einfo
+ einfo "If you want to import svn repositories into git, consider using the"
+ einfo "git-svnimport command. You should install dev-util/subversion before."
+ einfo
+ einfo "If you want to manage subversion repositories using git, consider"
+ einfo "using git-svn. You should install dev-util/subversion and dev-perl/libwww-perl."
+ einfo
+ einfo "If you want to import a quilt series into git, consider using the"
+ einfo "git-quiltimport command. You should install dev-util/quilt before."
+ einfo
+ einfo "If you want to use the included CVS server you will need to install"
+ einfo "dev-perl/DBI and dev-perl/DBD-SQLite."
+ einfo
+}
+
+pkg_postrm() {
+ # regenerate site-gentoo if we are merged USE=emacs and unmerged
+ # USE=-emacs
+ has_version virtual/emacs && elisp-site-regen
+}