summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJohannes Huber <johu@gentoo.org>2015-05-30 21:00:17 +0000
committerJohannes Huber <johu@gentoo.org>2015-05-30 21:00:17 +0000
commit47486870037bfb5a939448d5d65af10d2bdd7575 (patch)
tree3c3ef86d8665ab88b2917cf14b28ccbad99a4c95 /dev-util
parentarm stable wrt bug #545740 (diff)
downloadgentoo-2-47486870037bfb5a939448d5d65af10d2bdd7575.tar.gz
gentoo-2-47486870037bfb5a939448d5d65af10d2bdd7575.tar.bz2
gentoo-2-47486870037bfb5a939448d5d65af10d2bdd7575.zip
Version bump, bug #550496. Fixes build with gcc-5.1, bug #547662.
(Portage version: 2.2.20/cvs/Linux x86_64, signed Manifest commit with key 0xF3CFD2BD)
Diffstat (limited to 'dev-util')
-rw-r--r--dev-util/cmocka/ChangeLog7
-rw-r--r--dev-util/cmocka/cmocka-1.0.1.ebuild46
2 files changed, 52 insertions, 1 deletions
diff --git a/dev-util/cmocka/ChangeLog b/dev-util/cmocka/ChangeLog
index 4e01a1306034..cb676634a8bf 100644
--- a/dev-util/cmocka/ChangeLog
+++ b/dev-util/cmocka/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-util/cmocka
# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-util/cmocka/ChangeLog,v 1.22 2015/05/30 10:53:05 maekke Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-util/cmocka/ChangeLog,v 1.23 2015/05/30 21:00:17 johu Exp $
+
+*cmocka-1.0.1 (30 May 2015)
+
+ 30 May 2015; Johannes Huber <johu@gentoo.org> +cmocka-1.0.1.ebuild:
+ Version bump, bug #550496. Fixes build with gcc-5.1, bug #547662.
30 May 2015; Markus Meier <maekke@gentoo.org> cmocka-0.4.1.ebuild:
arm stable, bug #538798
diff --git a/dev-util/cmocka/cmocka-1.0.1.ebuild b/dev-util/cmocka/cmocka-1.0.1.ebuild
new file mode 100644
index 000000000000..609f977bdd2b
--- /dev/null
+++ b/dev-util/cmocka/cmocka-1.0.1.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-util/cmocka/cmocka-1.0.1.ebuild,v 1.1 2015/05/30 21:00:17 johu Exp $
+
+EAPI=5
+
+inherit cmake-multilib
+
+DESCRIPTION="A unit testing framework for C"
+HOMEPAGE="http://cmocka.org/"
+SRC_URI="https://cmocka.org/files/1.0/${P}.tar.xz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~s390 ~sparc ~x86 ~x86-fbsd ~amd64-linux ~x86-linux"
+IUSE="doc static-libs test"
+
+DEPEND="
+ doc? ( app-doc/doxygen[latex] )
+"
+RDEPEND=""
+
+DOCS=( AUTHORS ChangeLog README )
+
+multilib_src_configure() {
+ local mycmakeargs=(
+ $(cmake-utils_use_with static-libs STATIC_LIB)
+ $(cmake-utils_use test UNIT_TESTING)
+ $(multilib_is_native_abi && cmake-utils_use_find_package doc Doxygen \
+ || echo -DCMAKE_DISABLE_FIND_PACKAGE_Doxygen=ON)
+ )
+ cmake-utils_src_configure
+}
+
+multilib_src_install() {
+ if multilib_is_native_abi && use doc; then
+ pushd doc || die
+ doxygen Doxyfile || die
+ rm -f html/*.md5 latex/*.md5 latex/Manifest man/man3/_* || die
+ dohtml html/*
+ dodoc latex/*
+ doman man/man3/*.3
+ popd || die
+ fi
+ cmake-utils_src_install
+}