summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2009-11-17 22:07:37 +0000
committerRobin H. Johnson <robbat2@gentoo.org>2009-11-17 22:07:37 +0000
commit46c891b3b3405440bde379ea2db0f8f640f6f92c (patch)
treef99f6a2545315633af94adc51494041ccef07364 /dev-util
parentreplace media-tv herd for MythTV (diff)
downloadgentoo-2-46c891b3b3405440bde379ea2db0f8f640f6f92c.tar.gz
gentoo-2-46c891b3b3405440bde379ea2db0f8f640f6f92c.tar.bz2
gentoo-2-46c891b3b3405440bde379ea2db0f8f640f6f92c.zip
Bug #290465: uclibc needs an additional define to select a codepath that it will compile against.
(Portage version: 2.2_rc49/cvs/Linux x86_64)
Diffstat (limited to 'dev-util')
-rw-r--r--dev-util/git/ChangeLog6
-rw-r--r--dev-util/git/git-1.6.5.3.ebuild7
2 files changed, 11 insertions, 2 deletions
diff --git a/dev-util/git/ChangeLog b/dev-util/git/ChangeLog
index a661f9bb1016..0da60d157874 100644
--- a/dev-util/git/ChangeLog
+++ b/dev-util/git/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for dev-util/git
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-util/git/ChangeLog,v 1.380 2009/11/17 21:53:24 robbat2 Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-util/git/ChangeLog,v 1.381 2009/11/17 22:07:37 robbat2 Exp $
+
+ 17 Nov 2009; Robin H. Johnson <robbat2@gentoo.org> git-1.6.5.3.ebuild:
+ Bug #290465: uclibc needs an additional define to select a codepath that
+ it will compile against.
17 Nov 2009; Robin H. Johnson <robbat2@gentoo.org> git-1.6.5.3.ebuild:
Bug #290131: cpio is only needed for building git-gui now, and nothing
diff --git a/dev-util/git/git-1.6.5.3.ebuild b/dev-util/git/git-1.6.5.3.ebuild
index 5676f58b7775..492553365211 100644
--- a/dev-util/git/git-1.6.5.3.ebuild
+++ b/dev-util/git/git-1.6.5.3.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-util/git/git-1.6.5.3.ebuild,v 1.2 2009/11/17 21:53:24 robbat2 Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-util/git/git-1.6.5.3.ebuild,v 1.3 2009/11/17 22:07:37 robbat2 Exp $
EAPI=2
@@ -129,6 +129,11 @@ exportmakeopts() {
&& myopts="${myopts} ASCIIDOC8=YesPlease"
myopts="${myopts} ASCIIDOC_NO_ROFF=YesPlease"
+ # Bug 290465:
+ # builtin-fetch-pack.c:816: error: 'struct stat' has no member named 'st_mtim'
+ [[ "${CHOST}" == *-uclibc* ]] && \
+ myopts="${myopts} NO_NSEC=YesPlease"
+
export MY_MAKEOPTS="${myopts}"
}