summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTomas Chvatal <scarabeus@gentoo.org>2010-12-16 12:33:20 +0000
committerTomas Chvatal <scarabeus@gentoo.org>2010-12-16 12:33:20 +0000
commit414877480827f8c1e9e9dac5edbc33c44aeb7b76 (patch)
tree4d90580040aaa444dc939ad5d5862eadfd72b5b8 /dev-util
parentMake sure not to look for automake since the package does not use automake to... (diff)
downloadgentoo-2-414877480827f8c1e9e9dac5edbc33c44aeb7b76.tar.gz
gentoo-2-414877480827f8c1e9e9dac5edbc33c44aeb7b76.tar.bz2
gentoo-2-414877480827f8c1e9e9dac5edbc33c44aeb7b76.zip
Version bump. Per bug #344259. Thanks to Arseny Solokha for updated patches.
(Portage version: 2.2.0_alpha8/cvs/Linux x86_64)
Diffstat (limited to 'dev-util')
-rw-r--r--dev-util/cmake/ChangeLog11
-rw-r--r--dev-util/cmake/cmake-2.8.3.ebuild146
-rw-r--r--dev-util/cmake/files/cmake-2.8.3-FindLibArchive.patch12
-rw-r--r--dev-util/cmake/files/cmake-2.8.3-FindPythonInterp.patch11
-rw-r--r--dev-util/cmake/files/cmake-2.8.3-FindPythonLibs.patch13
-rw-r--r--dev-util/cmake/files/cmake-2.8.3-more-no_host_paths.patch109
6 files changed, 301 insertions, 1 deletions
diff --git a/dev-util/cmake/ChangeLog b/dev-util/cmake/ChangeLog
index 1f49862488a8..7eb2a0dd74ae 100644
--- a/dev-util/cmake/ChangeLog
+++ b/dev-util/cmake/ChangeLog
@@ -1,6 +1,15 @@
# ChangeLog for dev-util/cmake
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-util/cmake/ChangeLog,v 1.144 2010/09/11 15:13:49 armin76 Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-util/cmake/ChangeLog,v 1.145 2010/12/16 12:33:20 scarabeus Exp $
+
+*cmake-2.8.3 (16 Dec 2010)
+
+ 16 Dec 2010; Tomáš Chvátal <scarabeus@gentoo.org> +cmake-2.8.3.ebuild,
+ +files/cmake-2.8.3-FindLibArchive.patch,
+ +files/cmake-2.8.3-FindPythonInterp.patch,
+ +files/cmake-2.8.3-FindPythonLibs.patch,
+ +files/cmake-2.8.3-more-no_host_paths.patch:
+ Version bump. Per bug #344259. Thanks to Arseny Solokha for updated patches.
11 Sep 2010; Raúl Porcel <armin76@gentoo.org> cmake-2.8.1-r2.ebuild:
ia64/s390/sh/sparc stable wrt #325845
diff --git a/dev-util/cmake/cmake-2.8.3.ebuild b/dev-util/cmake/cmake-2.8.3.ebuild
new file mode 100644
index 000000000000..b14fe6cde781
--- /dev/null
+++ b/dev-util/cmake/cmake-2.8.3.ebuild
@@ -0,0 +1,146 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header $
+
+EAPI="3"
+
+inherit elisp-common toolchain-funcs eutils versionator flag-o-matic base cmake-utils
+
+MY_P="${PN}-$(replace_version_separator 3 - ${MY_PV})"
+
+DESCRIPTION="Cross platform Make"
+HOMEPAGE="http://www.cmake.org/"
+SRC_URI="http://www.cmake.org/files/v$(get_version_component_range 1-2)/${MY_P}.tar.gz"
+
+LICENSE="CMake"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~ppc-aix ~sparc-fbsd ~x86-fbsd ~hppa-hpux ~ia64-hpux ~x86-interix ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~x64-solaris ~x86-solaris"
+SLOT="0"
+IUSE="emacs ncurses qt4 vim-syntax"
+
+DEPEND="
+ app-arch/libarchive
+ >=net-misc/curl-7.20.0-r1[ssl]
+ >=dev-libs/expat-2.0.1
+ sys-libs/zlib
+ ncurses? ( sys-libs/ncurses )
+ qt4? ( x11-libs/qt-gui:4 )
+"
+RDEPEND="${DEPEND}
+ emacs? ( virtual/emacs )
+ vim-syntax? (
+ || (
+ app-editors/vim
+ app-editors/gvim
+ )
+ )
+"
+
+SITEFILE="50${PN}-gentoo.el"
+VIMFILE="${PN}.vim"
+
+S="${WORKDIR}/${MY_P}"
+
+CMAKE_BINARY="${S}/Bootstrap.cmk/cmake"
+CMAKE_IN_SOURCE_BUILD=1
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-2.6.3-darwin-bundle.patch
+ "${FILESDIR}"/${PN}-2.6.3-no-duplicates-in-rpath.patch
+ "${FILESDIR}"/${PN}-2.6.3-fix_broken_lfs_on_aix.patch
+ "${FILESDIR}"/${PN}-2.8.0-darwin-default-install_name.patch
+ "${FILESDIR}"/${PN}-2.8.0-darwin-no-app-with-qt.patch
+ "${FILESDIR}"/${PN}-2.8.1-FindBoost.patch
+ "${FILESDIR}"/${PN}-2.8.1-libform.patch
+ "${FILESDIR}"/${PN}-2.8.3-FindLibArchive.patch
+ "${FILESDIR}"/${PN}-2.8.3-FindPythonLibs.patch
+ "${FILESDIR}"/${PN}-2.8.3-FindPythonInterp.patch
+ "${FILESDIR}"/${PN}-2.8.3-more-no_host_paths.patch
+)
+_src_bootstrap() {
+ echo ${MAKEOPTS} | egrep -o '(\-j|\-\-jobs)(=?|[[:space:]]*)[[:digit:]]+' > /dev/null
+ if [ $? -eq 0 ]; then
+ par_arg=$(echo ${MAKEOPTS} | egrep -o '(\-j|\-\-jobs)(=?|[[:space:]]*)[[:digit:]]+' | egrep -o '[[:digit:]]+')
+ par_arg="--parallel=${par_arg}"
+ else
+ par_arg="--parallel=1"
+ fi
+
+ tc-export CC CXX LD
+
+ ./bootstrap \
+ --prefix="${T}/cmakestrap/" \
+ ${par_arg} \
+ || die "Bootstrap failed"
+}
+
+src_prepare() {
+ base_src_prepare
+
+ # disable bootstrap cmake and make run, we use eclass for that
+ sed -i \
+ -e '/"${cmake_bootstrap_dir}\/cmake"/s/^/#DONOTRUN /' \
+ bootstrap || die "sed failed"
+
+ # Add gcc libs to the default link paths
+ sed -i \
+ -e "s|@GENTOO_PORTAGE_GCCLIBDIR@|${EPREFIX}/usr/${CHOST}/lib/|g" \
+ -e "s|@GENTOO_PORTAGE_EPREFIX@|${EPREFIX}/|g" \
+ Modules/Platform/{UnixPaths,Darwin}.cmake || die "sed failed"
+
+ _src_bootstrap
+}
+
+src_configure() {
+ # make things work with gentoo java setup
+ # in case java-config cannot be run, the variable just becomes unset
+ # per bug #315229
+ export JAVA_HOME=$(java-config -g JAVA_HOME 2> /dev/null)
+
+ local mycmakeargs=(
+ -DCMAKE_USE_SYSTEM_LIBRARIES=ON
+ -DCMAKE_INSTALL_PREFIX="${EPREFIX}"/usr
+ -DCMAKE_DOC_DIR=/share/doc/${PF}
+ -DCMAKE_MAN_DIR=/share/man
+ -DCMAKE_DATA_DIR=/share/${PN}
+ $(cmake-utils_use_build ncurses CursesDialog)
+ $(cmake-utils_use_build qt4 QtDialog)
+ )
+ cmake-utils_src_configure
+}
+
+src_compile() {
+ cmake-utils_src_compile
+ if use emacs; then
+ elisp-compile Docs/cmake-mode.el || die "elisp compile failed"
+ fi
+}
+
+src_test() {
+ emake test || die "Tests failed"
+}
+
+src_install() {
+ cmake-utils_src_install
+ if use emacs; then
+ elisp-install ${PN} Docs/cmake-mode.el Docs/cmake-mode.elc || die "elisp-install failed"
+ elisp-site-file-install "${FILESDIR}/${SITEFILE}"
+ fi
+ if use vim-syntax; then
+ insinto /usr/share/vim/vimfiles/syntax
+ doins Docs/cmake-syntax.vim || die
+
+ insinto /usr/share/vim/vimfiles/indent
+ doins Docs/cmake-indent.vim || die
+
+ insinto /usr/share/vim/vimfiles/ftdetect
+ doins "${FILESDIR}/${VIMFILE}" || die
+ fi
+}
+
+pkg_postinst() {
+ use emacs && elisp-site-regen
+}
+
+pkg_postrm() {
+ use emacs && elisp-site-regen
+}
diff --git a/dev-util/cmake/files/cmake-2.8.3-FindLibArchive.patch b/dev-util/cmake/files/cmake-2.8.3-FindLibArchive.patch
new file mode 100644
index 000000000000..ede3400f012e
--- /dev/null
+++ b/dev-util/cmake/files/cmake-2.8.3-FindLibArchive.patch
@@ -0,0 +1,12 @@
+diff -ruN cmake-2.8.3.orig/Modules/FindLibArchive.cmake cmake-2.8.3/Modules/FindLibArchive.cmake
+--- cmake-2.8.3.orig/Modules/FindLibArchive.cmake 2010-11-04 02:58:27.000000000 +0700
++++ cmake-2.8.3/Modules/FindLibArchive.cmake 2010-11-05 17:40:53.712001939 +0700
+@@ -50,7 +50,7 @@
+
+ # Handle the QUIETLY and REQUIRED arguments and set LIBARCHIVE_FOUND
+ # to TRUE if all listed variables are TRUE.
+-include("${CMAKE_CURRENT_LIST_DIR}/FindPackageHandleStandardArgs.cmake")
++include("${CMAKE_ROOT}/Modules/FindPackageHandleStandardArgs.cmake")
+ find_package_handle_standard_args(LibArchive DEFAULT_MSG
+ LibArchive_LIBRARY LibArchive_INCLUDE_DIR
+ )
diff --git a/dev-util/cmake/files/cmake-2.8.3-FindPythonInterp.patch b/dev-util/cmake/files/cmake-2.8.3-FindPythonInterp.patch
new file mode 100644
index 000000000000..386457b91427
--- /dev/null
+++ b/dev-util/cmake/files/cmake-2.8.3-FindPythonInterp.patch
@@ -0,0 +1,11 @@
+--- Modules/FindPythonInterp.cmake
++++ Modules/FindPythonInterp.cmake
+@@ -20,7 +20,7 @@
+ # License text for the above reference.)
+
+ FIND_PROGRAM(PYTHON_EXECUTABLE
+- NAMES python2.7 python2.6 python2.5 python2.4 python2.3 python2.2 python2.1 python2.0 python1.6 python1.5 python
++ NAMES python python2.7 python2.6 python2.5 python2.4 python2.3 python2.2 python2.1 python2.0 python1.6 python1.5
+ PATHS
+ [HKEY_LOCAL_MACHINE\\SOFTWARE\\Python\\PythonCore\\2.7\\InstallPath]
+ [HKEY_LOCAL_MACHINE\\SOFTWARE\\Python\\PythonCore\\2.6\\InstallPath]
diff --git a/dev-util/cmake/files/cmake-2.8.3-FindPythonLibs.patch b/dev-util/cmake/files/cmake-2.8.3-FindPythonLibs.patch
new file mode 100644
index 000000000000..c4e5adc16486
--- /dev/null
+++ b/dev-util/cmake/files/cmake-2.8.3-FindPythonLibs.patch
@@ -0,0 +1,13 @@
+--- Modules/FindPythonLibs.cmake
++++ Modules/FindPythonLibs.cmake
+@@ -27,7 +27,9 @@
+ # Search for the python framework on Apple.
+ CMAKE_FIND_FRAMEWORKS(Python)
+
+-FOREACH(_CURRENT_VERSION 2.7 2.6 2.5 2.4 2.3 2.2 2.1 2.0 1.6 1.5)
++EXECUTE_PROCESS(COMMAND python -c "import sys; sys.stdout.write('.'.join([str(x) for x in sys.version_info[:2]]))"
++ OUTPUT_VARIABLE _PYTHON_VERSION)
++FOREACH(_CURRENT_VERSION ${_PYTHON_VERSION})
+ STRING(REPLACE "." "" _CURRENT_VERSION_NO_DOTS ${_CURRENT_VERSION})
+ IF(WIN32)
+ FIND_LIBRARY(PYTHON_DEBUG_LIBRARY
diff --git a/dev-util/cmake/files/cmake-2.8.3-more-no_host_paths.patch b/dev-util/cmake/files/cmake-2.8.3-more-no_host_paths.patch
new file mode 100644
index 000000000000..38bad925c373
--- /dev/null
+++ b/dev-util/cmake/files/cmake-2.8.3-more-no_host_paths.patch
@@ -0,0 +1,109 @@
+Set some proper paths to make cmake find our tools.
+Original patch by Heiko Przybyl
+
+The ebuild now adds an extra / at the end of $EPREFIX so that it is
+never the empty string (so that CMAKE_SYSTEM_PREFIX_PATH remains
+correct)
+
+--- cmake-2.8.3/Modules/Platform/Darwin.cmake
++++ cmake-2.8.3/Modules/Platform/Darwin.cmake
+@@ -217,19 +217,23 @@
+
+
+
+-# default to searching for frameworks first
+-SET(CMAKE_FIND_FRAMEWORK FIRST)
++# default to searching for frameworks last
++SET(CMAKE_FIND_FRAMEWORK LAST)
+ # set up the default search directories for frameworks
+ SET(CMAKE_SYSTEM_FRAMEWORK_PATH
++ @GENTOO_PORTAGE_EPREFIX@Frameworks
++ @GENTOO_PORTAGE_EPREFIX@usr/lib
+ ~/Library/Frameworks
+ /Library/Frameworks
+ /Network/Library/Frameworks
+ /System/Library/Frameworks)
+
+-# default to searching for application bundles first
+-SET(CMAKE_FIND_APPBUNDLE FIRST)
++# default to searching for application bundles last
++SET(CMAKE_FIND_APPBUNDLE LAST)
+ # set up the default search directories for application bundles
+ SET(CMAKE_SYSTEM_APPBUNDLE_PATH
++ @GENTOO_PORTAGE_EPREFIX@Applications
++ @GENTOO_PORTAGE_EPREFIX@usr/bin
+ ~/Applications
+ /Applications
+ /Developer/Applications)
+diff -ruN cmake-2.8.3.orig/Modules/Platform/UnixPaths.cmake cmake-2.8.3/Modules/Platform/UnixPaths.cmake
+--- cmake-2.8.3/Modules/Platform/UnixPaths.cmake
++++ cmake-2.8.3/Modules/Platform/UnixPaths.cmake
+@@ -33,6 +33,7 @@
+ # search types.
+ LIST(APPEND CMAKE_SYSTEM_PREFIX_PATH
+ # Standard
++ @GENTOO_PORTAGE_EPREFIX@usr/local @GENTOO_PORTAGE_EPREFIX@usr @GENTOO_PORTAGE_EPREFIX@
+ /usr/local /usr /
+
+ # CMake install location
+@@ -44,43 +45,39 @@
+
+ # List common include file locations not under the common prefixes.
+ LIST(APPEND CMAKE_SYSTEM_INCLUDE_PATH
+- # Windows API on Cygwin
+- /usr/include/w32api
+-
+- # X11
+- /usr/X11R6/include /usr/include/X11
+-
+- # Other
+- /usr/pkg/include
+- /opt/csw/include /opt/include
+- /usr/openwin/include
++ @GENTOO_PORTAGE_EPREFIX@usr/include
+ )
+
+ LIST(APPEND CMAKE_SYSTEM_LIBRARY_PATH
+- # Windows API on Cygwin
+- /usr/lib/w32api
+-
+- # X11
+- /usr/X11R6/lib /usr/lib/X11
+-
+- # Other
+- /usr/pkg/lib
+- /opt/csw/lib /opt/lib
+- /usr/openwin/lib
++ @GENTOO_PORTAGE_GCCLIBDIR@/gcc
++ @GENTOO_PORTAGE_GCCLIBDIR@
++ @GENTOO_PORTAGE_EPREFIX@usr/lib64
++ @GENTOO_PORTAGE_EPREFIX@usr/lib32
++ @GENTOO_PORTAGE_EPREFIX@usr/lib
++ @GENTOO_PORTAGE_EPREFIX@lib
+ )
+
+ LIST(APPEND CMAKE_SYSTEM_PROGRAM_PATH
+- /usr/pkg/bin
++ @GENTOO_PORTAGE_EPREFIX@usr/bin
++ @GENTOO_PORTAGE_EPREFIX@bin
+ )
+
+ LIST(APPEND CMAKE_PLATFORM_IMPLICIT_LINK_DIRECTORIES
++ @GENTOO_PORTAGE_GCCLIBDIR@/gcc
++ @GENTOO_PORTAGE_GCCLIBDIR@
++ @GENTOO_PORTAGE_EPREFIX@usr/lib64
++ @GENTOO_PORTAGE_EPREFIX@usr/lib32
++ @GENTOO_PORTAGE_EPREFIX@usr/lib
++ @GENTOO_PORTAGE_EPREFIX@lib
+ /lib /usr/lib /usr/lib32 /usr/lib64
+ )
+
+ LIST(APPEND CMAKE_C_IMPLICIT_INCLUDE_DIRECTORIES
++ @GENTOO_PORTAGE_EPREFIX@usr/include
+ /usr/include
+ )
+ LIST(APPEND CMAKE_CXX_IMPLICIT_INCLUDE_DIRECTORIES
++ @GENTOO_PORTAGE_EPREFIX@usr/include
+ /usr/include
+ )
+