summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJesus Rivero <neurogeek@gentoo.org>2009-03-22 16:40:12 +0000
committerJesus Rivero <neurogeek@gentoo.org>2009-03-22 16:40:12 +0000
commit3fe22a2a33aee7c58bdb0677c0e5b3849e877798 (patch)
treee3bc196c5447a6d291bb4697abe7a36454610e7b /dev-util
parentamd64/x86 stable, bug #263145 (diff)
downloadgentoo-2-3fe22a2a33aee7c58bdb0677c0e5b3849e877798.tar.gz
gentoo-2-3fe22a2a33aee7c58bdb0677c0e5b3849e877798.tar.bz2
gentoo-2-3fe22a2a33aee7c58bdb0677c0e5b3849e877798.zip
Version bump. Close bug #262896. Removed old versions
(Portage version: 2.2_rc16/cvs/Linux 2.6.18-gentoo-r3 i686)
Diffstat (limited to 'dev-util')
-rw-r--r--dev-util/buildbot/ChangeLog9
-rw-r--r--dev-util/buildbot/buildbot-0.7.10_p1.ebuild (renamed from dev-util/buildbot/buildbot-0.7.9.ebuild)23
-rw-r--r--dev-util/buildbot/buildbot-0.7.7.ebuild92
-rw-r--r--dev-util/buildbot/buildbot-0.7.8.ebuild93
4 files changed, 23 insertions, 194 deletions
diff --git a/dev-util/buildbot/ChangeLog b/dev-util/buildbot/ChangeLog
index 39705751d412..9391fe7311ec 100644
--- a/dev-util/buildbot/ChangeLog
+++ b/dev-util/buildbot/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for dev-util/buildbot
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-util/buildbot/ChangeLog,v 1.33 2009/03/22 13:00:52 jmbsvicetto Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-util/buildbot/ChangeLog,v 1.34 2009/03/22 16:40:12 neurogeek Exp $
+
+*buildbot-0.7.10_p1 (22 Mar 2009)
+
+ 22 Mar 2009; Jesus Rivero <neurogeek@gentoo.org> -buildbot-0.7.7.ebuild,
+ -buildbot-0.7.8.ebuild, -buildbot-0.7.9.ebuild,
+ +buildbot-0.7.10_p1.ebuild:
+ Version bump. Close bug #262896. Removed old versions
22 Mar 2009; Jorge Manuel B. S. Vicetto <jmbsvicetto@gentoo.org>
metadata.xml:
diff --git a/dev-util/buildbot/buildbot-0.7.9.ebuild b/dev-util/buildbot/buildbot-0.7.10_p1.ebuild
index a935bdf59cad..24ab89e098f1 100644
--- a/dev-util/buildbot/buildbot-0.7.9.ebuild
+++ b/dev-util/buildbot/buildbot-0.7.10_p1.ebuild
@@ -1,30 +1,37 @@
# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-util/buildbot/buildbot-0.7.9.ebuild,v 1.3 2009/02/13 18:50:08 armin76 Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-util/buildbot/buildbot-0.7.10_p1.ebuild,v 1.1 2009/03/22 16:40:12 neurogeek Exp $
-NEED_PYTHON="2.3"
+EAPI=1
+NEED_PYTHON="2.4"
-inherit distutils eutils
+MY_PV="${PV/_p/p}"
+MY_P="${PN}-${MY_PV}"
+
+inherit distutils
DESCRIPTION="A Python system to automate the compile/test cycle to validate code changes"
HOMEPAGE="http://buildbot.net/"
-SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+SRC_URI="mirror://sourceforge/${PN}/${MY_P}.tar.gz"
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86"
-IUSE="doc irc mail manhole test web"
+IUSE="doc irc mail manhole test"
CDEPEND=">=dev-python/twisted-2.0.1"
RDEPEND="${CDEPEND}
mail? ( dev-python/twisted-mail )
manhole? ( dev-python/twisted-conch )
irc? ( dev-python/twisted-words )
- web? ( dev-python/twisted-web )"
+ dev-python/twisted-web
+ dev-python/twisted-mail"
DEPEND="${CDEPEND}
test? ( dev-python/twisted-web
- dev-python/twisted-mail )
+ dev-python/twisted-mail )
doc? ( =dev-python/epydoc-2* )"
+S="${WORKDIR}/${MY_P}"
+
pkg_setup() {
enewuser buildbot
}
@@ -32,7 +39,6 @@ pkg_setup() {
src_unpack() {
unpack ${A}
cd "${S}"
-
epatch "${FILESDIR}/${PN}-0.7.5-root-skip-tests.patch"
}
@@ -58,6 +64,7 @@ src_install() {
dohtml -r docs/buildbot.html docs/images
insinto /usr/share/doc/${PF}
+ doins -r contrib
doins -r docs/examples
use doc && doins -r docs/reference
diff --git a/dev-util/buildbot/buildbot-0.7.7.ebuild b/dev-util/buildbot/buildbot-0.7.7.ebuild
deleted file mode 100644
index 64445439ddbb..000000000000
--- a/dev-util/buildbot/buildbot-0.7.7.ebuild
+++ /dev/null
@@ -1,92 +0,0 @@
-# Copyright 1999-2008 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-util/buildbot/buildbot-0.7.7.ebuild,v 1.2 2008/05/20 17:55:15 cardoe Exp $
-
-NEED_PYTHON="2.3"
-
-inherit distutils eutils
-
-DESCRIPTION="A Python system to automate the compile/test cycle to validate code changes"
-HOMEPAGE="http://buildbot.net/"
-SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86"
-IUSE="doc irc mail test web"
-
-CDEPEND=">=dev-python/twisted-2.0.1"
-RDEPEND="${CDEPEND}
- mail? ( dev-python/twisted-mail )
- irc? ( dev-python/twisted-words )
- web? ( dev-python/twisted-web )"
-DEPEND="${CDEPEND}
- test? ( dev-python/twisted-web
- dev-python/twisted-mail )
- doc? ( =dev-python/epydoc-2* )"
-
-pkg_setup() {
- enewuser buildbot
-}
-
-src_unpack() {
- unpack ${A}
- cd "${S}"
-
- epatch "${FILESDIR}/${PN}-0.7.5-root-skip-tests.patch"
-}
-
-src_compile() {
- distutils_src_compile
- if use doc; then
- PYTHONPATH=. "${python}" docs/epyrun -o docs/reference || \
- die "epyrun failed"
- fi
-}
-
-src_test() {
- local trialopts
- if ! has_version ">=dev-python/twisted-2.2"; then
- trialopts=-R
- fi
- PYTHONPATH=. trial ${trialopts} buildbot || die "tests failed!"
-}
-
-src_install() {
- distutils_src_install
- doinfo docs/buildbot.info
- dohtml -r docs/buildbot.html docs/images
-
- insinto /usr/share/doc/${PF}
- doins -r docs/examples
-
- use doc && doins -r docs/reference
-
- newconfd "${FILESDIR}/buildslave.confd" buildslave
- newinitd "${FILESDIR}/buildbot.initd" buildslave
- newconfd "${FILESDIR}/buildmaster.confd" buildmaster
- newinitd "${FILESDIR}/buildbot.initd" buildmaster
-
- # Make it print the right names when you start/stop the script.
- sed -i -e '/ebegin/s/Starting buildbot/Starting buildslave/' \
- "${D}/etc/init.d/buildslave" || die "buildslave sed failed"
- sed -i -e '/ebegin/s/Starting buildbot/Starting buildmaster/' \
- "${D}/etc/init.d/buildmaster" || die "buildmaster sed failed"
-}
-
-pkg_postinst() {
- elog 'The "buildbot" user and the "buildmaster" and "buildslave" init'
- elog "scripts were added to support starting buildbot through gentoo's"
- elog "init system. To use this set up your build master or build slave"
- elog "following the buildbot documentation, make sure the resulting"
- elog 'directories are owned by the "buildbot" user and point'
- elog "${ROOT}etc/conf.d/buildmaster or ${ROOT}etc/conf.d/buildslave"
- elog "at the right location. The scripts can run as a different user"
- elog "if desired. If you need to run more than one master or slave"
- elog "just copy the scripts."
- elog ""
- elog "Upstream recommends the following when upgrading:"
- elog "Each time you install a new version of Buildbot, you should run the new"
- elog "'buildbot upgrade-master' command on each of your pre-existing buildmasters."
- elog "This will add files and fix (or at least detect) incompatibilities between"
- elog "your old config and the new code."
-}
diff --git a/dev-util/buildbot/buildbot-0.7.8.ebuild b/dev-util/buildbot/buildbot-0.7.8.ebuild
deleted file mode 100644
index 47132b8b27a2..000000000000
--- a/dev-util/buildbot/buildbot-0.7.8.ebuild
+++ /dev/null
@@ -1,93 +0,0 @@
-# Copyright 1999-2008 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-util/buildbot/buildbot-0.7.8.ebuild,v 1.1 2008/08/16 09:26:24 hawking Exp $
-
-NEED_PYTHON="2.3"
-
-inherit distutils eutils
-
-DESCRIPTION="A Python system to automate the compile/test cycle to validate code changes"
-HOMEPAGE="http://buildbot.net/"
-SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="~alpha ~amd64 ~ia64 ~ppc ~ppc64 ~sparc ~x86"
-IUSE="doc irc mail manhole test web"
-
-CDEPEND=">=dev-python/twisted-2.0.1"
-RDEPEND="${CDEPEND}
- mail? ( dev-python/twisted-mail )
- manhole? ( dev-python/twisted-conch )
- irc? ( dev-python/twisted-words )
- web? ( dev-python/twisted-web )"
-DEPEND="${CDEPEND}
- test? ( dev-python/twisted-web
- dev-python/twisted-mail )
- doc? ( =dev-python/epydoc-2* )"
-
-pkg_setup() {
- enewuser buildbot
-}
-
-src_unpack() {
- unpack ${A}
- cd "${S}"
-
- epatch "${FILESDIR}/${PN}-0.7.5-root-skip-tests.patch"
-}
-
-src_compile() {
- distutils_src_compile
- if use doc; then
- PYTHONPATH=. "${python}" docs/epyrun -o docs/reference || \
- die "epyrun failed"
- fi
-}
-
-src_test() {
- local trialopts
- if ! has_version ">=dev-python/twisted-2.2"; then
- trialopts=-R
- fi
- PYTHONPATH=. trial ${trialopts} buildbot || die "tests failed!"
-}
-
-src_install() {
- distutils_src_install
- doinfo docs/buildbot.info
- dohtml -r docs/buildbot.html docs/images
-
- insinto /usr/share/doc/${PF}
- doins -r docs/examples
-
- use doc && doins -r docs/reference
-
- newconfd "${FILESDIR}/buildslave.confd" buildslave
- newinitd "${FILESDIR}/buildbot.initd-r1" buildslave
- newconfd "${FILESDIR}/buildmaster.confd" buildmaster
- newinitd "${FILESDIR}/buildbot.initd-r1" buildmaster
-
- # Make it print the right names when you start/stop the script.
- sed -i -e 's/@buildbot@/buildslave/' \
- "${D}/etc/init.d/buildslave" || die "buildslave sed failed"
- sed -i -e 's/@buildbot@/buildmaster/' \
- "${D}/etc/init.d/buildmaster" || die "buildmaster sed failed"
-}
-
-pkg_postinst() {
- elog 'The "buildbot" user and the "buildmaster" and "buildslave" init'
- elog "scripts were added to support starting buildbot through gentoo's"
- elog "init system. To use this set up your build master or build slave"
- elog "following the buildbot documentation, make sure the resulting"
- elog 'directories are owned by the "buildbot" user and point'
- elog "${ROOT}etc/conf.d/buildmaster or ${ROOT}etc/conf.d/buildslave"
- elog "at the right location. The scripts can run as a different user"
- elog "if desired. If you need to run more than one master or slave"
- elog "just copy the scripts."
- elog ""
- elog "Upstream recommends the following when upgrading:"
- elog "Each time you install a new version of Buildbot, you should run the new"
- elog "'buildbot upgrade-master' command on each of your pre-existing buildmasters."
- elog "This will add files and fix (or at least detect) incompatibilities between"
- elog "your old config and the new code."
-}