summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2010-04-16 21:27:29 +0000
committerMike Frysinger <vapier@gentoo.org>2010-04-16 21:27:29 +0000
commit3fb5c7884263bf2f66279b52c855959b8c68959b (patch)
treed189784b0cbad99a597cc8edfbb0a129bf4e32b3 /dev-util
parentamd64 stable, bug 308521 (diff)
downloadgentoo-2-3fb5c7884263bf2f66279b52c855959b8c68959b.tar.gz
gentoo-2-3fb5c7884263bf2f66279b52c855959b8c68959b.tar.bz2
gentoo-2-3fb5c7884263bf2f66279b52c855959b8c68959b.zip
Version bump.
(Portage version: 2.2_rc67/cvs/Linux x86_64)
Diffstat (limited to 'dev-util')
-rw-r--r--dev-util/strace/ChangeLog7
-rw-r--r--dev-util/strace/strace-4.5.20.ebuild32
2 files changed, 38 insertions, 1 deletions
diff --git a/dev-util/strace/ChangeLog b/dev-util/strace/ChangeLog
index 4079078cc930..af882233b0d3 100644
--- a/dev-util/strace/ChangeLog
+++ b/dev-util/strace/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-util/strace
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-util/strace/ChangeLog,v 1.144 2010/02/25 22:45:59 tcunha Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-util/strace/ChangeLog,v 1.145 2010/04/16 21:27:29 vapier Exp $
+
+*strace-4.5.20 (16 Apr 2010)
+
+ 16 Apr 2010; Mike Frysinger <vapier@gentoo.org> +strace-4.5.20.ebuild:
+ Version bump.
25 Feb 2010; Tiago Cunha <tcunha@gentoo.org> strace-4.5.19.ebuild:
stable sparc, bug 297079
diff --git a/dev-util/strace/strace-4.5.20.ebuild b/dev-util/strace/strace-4.5.20.ebuild
new file mode 100644
index 000000000000..436d02386586
--- /dev/null
+++ b/dev-util/strace/strace-4.5.20.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-util/strace/strace-4.5.20.ebuild,v 1.1 2010/04/16 21:27:29 vapier Exp $
+
+inherit flag-o-matic
+
+DESCRIPTION="A useful diagnostic, instructional, and debugging tool"
+HOMEPAGE="http://sourceforge.net/projects/strace/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.bz2"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-linux ~ia64-linux ~x86-linux"
+IUSE="static aio"
+
+# strace only uses the header from libaio
+DEPEND="aio? ( >=dev-libs/libaio-0.3.106 )"
+RDEPEND=""
+
+src_compile() {
+ filter-lfs-flags # configure handles this sanely
+ use static && append-ldflags -static
+
+ use aio || export ac_cv_header_libaio_h=no #
+ econf || die
+ emake || die
+}
+
+src_install() {
+ emake install DESTDIR="${D}" || die
+ dodoc ChangeLog CREDITS NEWS PORTING README* TODO
+}