summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDiego Elio Pettenò <flameeyes@gentoo.org>2011-10-21 09:26:34 +0000
committerDiego Elio Pettenò <flameeyes@gentoo.org>2011-10-21 09:26:34 +0000
commit3b11f15dd3a9e16871e41aef09b5c10d1fe184e9 (patch)
tree27f14684fc7163348a68e7c152cf4a590b29aa2f /dev-util
parent2.2.0_alpha70 version bump. This includes all of the fixes in (diff)
downloadgentoo-2-3b11f15dd3a9e16871e41aef09b5c10d1fe184e9.tar.gz
gentoo-2-3b11f15dd3a9e16871e41aef09b5c10d1fe184e9.tar.bz2
gentoo-2-3b11f15dd3a9e16871e41aef09b5c10d1fe184e9.zip
Version bump, and fix build with tinyxml[stl], thanks to the proxy maintainer Enrico Tagliavini.
(Portage version: 2.2.0_alpha69/cvs/Linux x86_64)
Diffstat (limited to 'dev-util')
-rw-r--r--dev-util/gource/ChangeLog8
-rw-r--r--dev-util/gource/gource-0.37.ebuild65
2 files changed, 72 insertions, 1 deletions
diff --git a/dev-util/gource/ChangeLog b/dev-util/gource/ChangeLog
index 0533a30e9ea9..0f590bf26172 100644
--- a/dev-util/gource/ChangeLog
+++ b/dev-util/gource/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-util/gource
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-util/gource/ChangeLog,v 1.16 2011/07/17 14:49:21 flameeyes Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-util/gource/ChangeLog,v 1.17 2011/10/21 09:26:34 flameeyes Exp $
+
+*gource-0.37 (21 Oct 2011)
+
+ 21 Oct 2011; Diego E. Pettenò <flameeyes@gentoo.org> +gource-0.37.ebuild:
+ Version bump, and fix build with tinyxml[stl], thanks to the proxy maintainer
+ Enrico Tagliavini.
*gource-0.35 (17 Jul 2011)
diff --git a/dev-util/gource/gource-0.37.ebuild b/dev-util/gource/gource-0.37.ebuild
new file mode 100644
index 000000000000..9bc6a25c7732
--- /dev/null
+++ b/dev-util/gource/gource-0.37.ebuild
@@ -0,0 +1,65 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-util/gource/gource-0.37.ebuild,v 1.1 2011/10/21 09:26:34 flameeyes Exp $
+
+EAPI=2
+
+inherit autotools flag-o-matic versionator
+
+MY_P=${P/_p/-}
+MY_P=${MY_P/_/-}
+MY_DATE=${PV/*_p}
+
+DESCRIPTION="A software version control visualization tool"
+HOMEPAGE="http://code.google.com/p/gource/"
+SRC_URI="http://gource.googlecode.com/files/${MY_P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="
+ >=media-libs/libsdl-1.2.10[opengl,X]
+ >=media-libs/sdl-image-1.2[jpeg,png]
+ dev-libs/libpcre:3
+ >=media-libs/libpng-1.2
+ virtual/jpeg
+ media-libs/mesa
+ media-fonts/freefont-ttf
+ >=media-libs/glew-1.5
+ dev-libs/tinyxml
+ "
+DEPEND="
+ ${RDEPEND}
+ dev-util/pkgconfig
+ media-libs/freetype:2
+ "
+
+case ${PV} in
+ *_beta*)
+ my_v=$(get_version_component_range 1-3)
+ my_v=${my_v//_/-}
+ S="${WORKDIR}/${PN}-${my_v}" ;;
+ *)
+ S="${WORKDIR}/${PN}-$(get_version_component_range 1-2)" ;;
+esac
+
+src_prepare() {
+ eautoreconf
+}
+
+src_configure() {
+ # workaround to fix bug #386525
+ # this enable gource to be compiled against dev-libs/tinyxml[stl]
+ if has_version dev-libs/tinyxml[stl]; then
+ append-cxxflags -DTIXML_USE_STL;
+ fi
+ econf --enable-ttf-font-dir=/usr/share/fonts/freefont-ttf/ \
+ --with-tinyxml
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "Install failed"
+ dodoc README ChangeLog THANKS || die "dodoc failed"
+}