summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDonnie Berkholz <dberkholz@gentoo.org>2008-09-15 23:01:28 +0000
committerDonnie Berkholz <dberkholz@gentoo.org>2008-09-15 23:01:28 +0000
commit3a99cf69004946caae2b50fb53ea4474e817602c (patch)
treeb6ddabd737a4191623e40dcb689516848d671423 /dev-util
parent0.12 release, removed -gtk option (diff)
downloadgentoo-2-3a99cf69004946caae2b50fb53ea4474e817602c.tar.gz
gentoo-2-3a99cf69004946caae2b50fb53ea4474e817602c.tar.bz2
gentoo-2-3a99cf69004946caae2b50fb53ea4474e817602c.zip
New package: shUnit2 is a unit-test framework for Bourne-based shell scripts (Toffanin Mauro, GeCHI overlay).
(Portage version: 2.2_rc8/cvs/Linux 2.6.27-rc6 x86_64)
Diffstat (limited to 'dev-util')
-rw-r--r--dev-util/shunit2/ChangeLog11
-rw-r--r--dev-util/shunit2/Manifest4
-rw-r--r--dev-util/shunit2/metadata.xml15
-rw-r--r--dev-util/shunit2/shunit2-2.1.4.ebuild45
4 files changed, 75 insertions, 0 deletions
diff --git a/dev-util/shunit2/ChangeLog b/dev-util/shunit2/ChangeLog
new file mode 100644
index 000000000000..db13327821ec
--- /dev/null
+++ b/dev-util/shunit2/ChangeLog
@@ -0,0 +1,11 @@
+# ChangeLog for dev-util/shunit2
+# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-util/shunit2/ChangeLog,v 1.1 2008/09/15 23:01:28 dberkholz Exp $
+
+*shunit2-2.1.4 (15 Sep 2008)
+
+ 15 Sep 2008; Donnie Berkholz <dberkholz@gentoo.org>; +metadata.xml,
+ +shunit2-2.1.4.ebuild:
+ New package: shUnit2 is a unit-test framework for Bourne-based shell
+ scripts (Toffanin Mauro, GeCHI overlay).
+
diff --git a/dev-util/shunit2/Manifest b/dev-util/shunit2/Manifest
new file mode 100644
index 000000000000..7b9de6e84245
--- /dev/null
+++ b/dev-util/shunit2/Manifest
@@ -0,0 +1,4 @@
+DIST shunit2-2.1.4.tgz 49698 RMD160 d2d20d60f84c7974795a9b4087edcada6f419b84 SHA1 f6f2788c74ead24ec55bac5bece53f50ffbc95d6 SHA256 7f911f871fefa9513972dedd5be1b406e2f2d49d19103c6229098957c4cced57
+EBUILD shunit2-2.1.4.ebuild 914 RMD160 76d77dc66aaabb00b90c72789341f8ea4bf88aac SHA1 b2781967a718de7fcdfe6c5a4edf4eb8fe9917f2 SHA256 b9a75dba7dbde177ef26a9ad4e0a247db413fe3b31f3420017400580416d0db3
+MISC ChangeLog 357 RMD160 284093f53534414dfdd35c4979e04bb95dec5f12 SHA1 de1416a8110cfe1165dce3a268ad674f6e567ec0 SHA256 cae5e8e9df9035e6f07e866efbccb4ff1bb16562eabe8f6879feeda6c4b07bbb
+MISC metadata.xml 557 RMD160 4b11254c1fa726034d49041b28b24a9c4c0ae04d SHA1 6964040c1cc567c8d72e424e0645126476d60468 SHA256 5958062d7f991b468518d748806c22c74f7f0bf5549f551f402ceebba5ffbd0e
diff --git a/dev-util/shunit2/metadata.xml b/dev-util/shunit2/metadata.xml
new file mode 100644
index 000000000000..0a9a6b04bf14
--- /dev/null
+++ b/dev-util/shunit2/metadata.xml
@@ -0,0 +1,15 @@
+<?xml version='1.0' encoding='UTF-8'?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>no-herd</herd>
+ <maintainer>
+ <email>dberkholz@gentoo.org</email>
+ <name>Donnie Berkholz</name>
+ </maintainer>
+ <longdescription>
+ shUnit2 is a xUnit unit test framework for Bourne based shell scripts, and
+ it is designed to work in a similar manner to JUnit, PyUnit, etc. If you
+ have ever had the desire to write a unit test for a shell script, shUnit2
+ can do the job.
+ </longdescription>
+</pkgmetadata>
diff --git a/dev-util/shunit2/shunit2-2.1.4.ebuild b/dev-util/shunit2/shunit2-2.1.4.ebuild
new file mode 100644
index 000000000000..b9ed9430a63c
--- /dev/null
+++ b/dev-util/shunit2/shunit2-2.1.4.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-util/shunit2/shunit2-2.1.4.ebuild,v 1.1 2008/09/15 23:01:28 dberkholz Exp $
+
+DESCRIPTION="shUnit2 is a unit-test framework for Bourne-based shell scripts."
+HOMEPAGE="http://code.google.com/p/shunit2/wiki/ProjectInfo"
+SRC_URI="http://shunit2.googlecode.com/files/${P}.tgz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc test"
+
+RDEPEND=""
+DEPEND="${RDEPEND}
+ dev-lang/perl
+ net-misc/curl"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ sed -i -e '/^__SHUNIT_SHELL_FLAGS/s:u::' src/shell/shunit2
+}
+
+src_compile() {
+ local myconf="build"
+ use doc && myconf="${myconf} docs"
+ use test && myconf="${myconf} test"
+
+ emake ${myconf} || die
+}
+
+src_install() {
+ if use doc; then
+ for DOC in build/{docbook/*,shunit2.html,shunit2_shelldoc.xml}; do
+ dodoc ${DOC} || die
+ rm ${DOC}
+ done
+ fi
+
+ dodoc doc/*.txt || die
+
+ insinto /usr/share/${PN}
+ doins build/* || die
+}