summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeff Horelick <jdhore@gentoo.org>2012-07-26 02:41:17 +0000
committerJeff Horelick <jdhore@gentoo.org>2012-07-26 02:41:17 +0000
commit38a46ba6b02b5bd6dd9c6f404d3777e7b59b7e5e (patch)
treeb0655c8a78d9714e0a4edecb690bea75d3cc2cd2 /dev-util
parentRemove unused eutils inherit. (diff)
downloadgentoo-2-38a46ba6b02b5bd6dd9c6f404d3777e7b59b7e5e.tar.gz
gentoo-2-38a46ba6b02b5bd6dd9c6f404d3777e7b59b7e5e.tar.bz2
gentoo-2-38a46ba6b02b5bd6dd9c6f404d3777e7b59b7e5e.zip
Version bump
(Portage version: 2.2.0_alpha120/cvs/Linux i686)
Diffstat (limited to 'dev-util')
-rw-r--r--dev-util/pkgconf/ChangeLog7
-rw-r--r--dev-util/pkgconf/pkgconf-0.8.3.ebuild51
2 files changed, 57 insertions, 1 deletions
diff --git a/dev-util/pkgconf/ChangeLog b/dev-util/pkgconf/ChangeLog
index c60c94c53d99..dededeb9a796 100644
--- a/dev-util/pkgconf/ChangeLog
+++ b/dev-util/pkgconf/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-util/pkgconf
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-util/pkgconf/ChangeLog,v 1.33 2012/07/25 01:19:23 jer Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-util/pkgconf/ChangeLog,v 1.34 2012/07/26 02:41:17 jdhore Exp $
+
+*pkgconf-0.8.3 (26 Jul 2012)
+
+ 26 Jul 2012; Jeff Horelick <jdhore@gentoo.org> +pkgconf-0.8.3.ebuild:
+ Version bump
25 Jul 2012; Jeroen Roovers <jer@gentoo.org> pkgconf-0.8.2.ebuild:
Stable for HPPA (bug #427680).
diff --git a/dev-util/pkgconf/pkgconf-0.8.3.ebuild b/dev-util/pkgconf/pkgconf-0.8.3.ebuild
new file mode 100644
index 000000000000..b7b86af67097
--- /dev/null
+++ b/dev-util/pkgconf/pkgconf-0.8.3.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-util/pkgconf/pkgconf-0.8.3.ebuild,v 1.1 2012/07/26 02:41:17 jdhore Exp $
+
+EAPI="4"
+
+if [[ ${PV} == "9999" ]] ; then
+ EGIT_REPO_URI="git://github.com/nenolod/pkgconf.git"
+ inherit autotools git-2
+else
+ #inherit autotools vcs-snapshot
+ inherit eutils
+ #SRC_URI="https://github.com/nenolod/pkgconf/tarball/${P} -> ${P}.tar.gz"
+ SRC_URI="http://nenolod.net/~nenolod/distfiles/${P}.tar.bz2"
+ KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-fbsd ~x86-fbsd"
+fi
+
+DESCRIPTION="pkg-config compatible replacement with no dependencies other than ANSI C89"
+HOMEPAGE="https://github.com/nenolod/pkgconf"
+
+LICENSE="BSD-1"
+SLOT="0"
+IUSE="+pkg-config strict"
+
+DEPEND=""
+RDEPEND="${DEPEND}
+ pkg-config? (
+ !dev-util/pkgconfig
+ !dev-util/pkg-config-lite
+ !dev-util/pkgconfig-openbsd[pkg-config]
+ )"
+
+src_prepare() {
+ [[ -e configure ]] || AT_M4DIR="m4" eautoreconf
+}
+
+src_configure() {
+ econf $(use_enable strict)
+}
+
+src_compile() {
+ emake V=1
+}
+
+src_install() {
+ default
+ use pkg-config \
+ && dosym pkgconf /usr/bin/pkg-config \
+ || rm "${ED}"/usr/share/aclocal/pkg.m4 \
+ || die
+}