summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGilles Dartiguelongue <eva@gentoo.org>2009-03-21 22:13:48 +0000
committerGilles Dartiguelongue <eva@gentoo.org>2009-03-21 22:13:48 +0000
commit373956df3364424add4a27e29dbaa7e372680497 (patch)
tree43234d195bf692381d9b3417bd2dcc99c5aaa492 /dev-util
parentRemove old versions. (diff)
downloadgentoo-2-373956df3364424add4a27e29dbaa7e372680497.tar.gz
gentoo-2-373956df3364424add4a27e29dbaa7e372680497.tar.bz2
gentoo-2-373956df3364424add4a27e29dbaa7e372680497.zip
Bump to 0.21-r1. Allow to build against libxul, bug #250306. Add a warning for gedit plugin, bug #245235.
(Portage version: 2.2_rc25/cvs/Linux x86_64)
Diffstat (limited to 'dev-util')
-rw-r--r--dev-util/devhelp/ChangeLog10
-rw-r--r--dev-util/devhelp/devhelp-0.21-r1.ebuild (renamed from dev-util/devhelp/devhelp-0.20.ebuild)25
-rw-r--r--dev-util/devhelp/files/devhelp-0.21-xulrunner19.patch28
3 files changed, 56 insertions, 7 deletions
diff --git a/dev-util/devhelp/ChangeLog b/dev-util/devhelp/ChangeLog
index f2390fd90ae6..810efa36b2f9 100644
--- a/dev-util/devhelp/ChangeLog
+++ b/dev-util/devhelp/ChangeLog
@@ -1,6 +1,14 @@
# ChangeLog for dev-util/devhelp
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-util/devhelp/ChangeLog,v 1.83 2009/03/15 22:03:46 maekke Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-util/devhelp/ChangeLog,v 1.84 2009/03/21 22:13:48 eva Exp $
+
+*devhelp-0.21-r1 (21 Mar 2009)
+
+ 21 Mar 2009; Gilles Dartiguelongue <eva@gentoo.org>
+ +files/devhelp-0.21-xulrunner19.patch, -devhelp-0.20.ebuild,
+ +devhelp-0.21-r1.ebuild:
+ Bump to 0.21-r1. Allow to build against libxul, bug #250306. Add a warning
+ for gedit plugin, bug #245235.
15 Mar 2009; Markus Meier <maekke@gentoo.org> devhelp-0.21.ebuild:
x86 stable, bug #260063
diff --git a/dev-util/devhelp/devhelp-0.20.ebuild b/dev-util/devhelp/devhelp-0.21-r1.ebuild
index 34326c687b21..20f1ee3281ec 100644
--- a/dev-util/devhelp/devhelp-0.20.ebuild
+++ b/dev-util/devhelp/devhelp-0.21-r1.ebuild
@@ -1,8 +1,11 @@
# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-util/devhelp/devhelp-0.20.ebuild,v 1.2 2009/01/08 16:52:38 armin76 Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-util/devhelp/devhelp-0.21-r1.ebuild,v 1.1 2009/03/21 22:13:48 eva Exp $
-inherit toolchain-funcs gnome2 python
+EAPI="2"
+GCONF_DEBUG="no"
+
+inherit autotools eutils toolchain-funcs gnome2 python
DESCRIPTION="An API documentation browser for GNOME 2"
HOMEPAGE="http://developer.imendio.com/wiki/Devhelp"
@@ -26,17 +29,27 @@ DEPEND="${RDEPEND}
DOCS="AUTHORS ChangeLog NEWS README"
-src_unpack() {
- gnome2_src_unpack
-
+src_prepare() {
# disable pyc compiling
mv py-compile py-compile.orig
ln -s $(type -P true) py-compile
+
+ # Allow to build against libxul, bug #250306
+ epatch "${FILESDIR}/${P}-xulrunner19.patch"
+
+ eautoreconf
}
pkg_setup() {
+ if has_version app-editors/gedit && \
+ ! built_with_use app-editors/gedit python; then
+ # Add warning per bug #245235
+ ewarn "dev-util/devhelp plugin for app-editors/gedit needs python support"
+ fi
+
G2CONF="$(use_with zlib)
- --with-gecko=libxul-embedding"
+ --with-gecko=libxul
+ --with-gecko-home=/usr/$(get_libdir)/xulrunner-1.9"
# ICC is crazy, silence warnings (bug #154010)
if [[ $(tc-getCC) == "icc" ]] ; then
diff --git a/dev-util/devhelp/files/devhelp-0.21-xulrunner19.patch b/dev-util/devhelp/files/devhelp-0.21-xulrunner19.patch
new file mode 100644
index 000000000000..3fcd70fd5fe4
--- /dev/null
+++ b/dev-util/devhelp/files/devhelp-0.21-xulrunner19.patch
@@ -0,0 +1,28 @@
+# https://bugs.gentoo.org/show_bug.cgi?id=250306
+# Allow to build xulrunner with libxul in place of libxul-embedding
+--- a/configure.in 2008-09-22 16:43:15.000000000 +0300
++++ b/configure.in 2009-03-16 20:32:14.000000000 +0200
+@@ -88,13 +88,16 @@
+ *) AC_MSG_ERROR([$gecko_cv_gecko is not supported])
+ esac
+
+-if test $GECKO = libxul-embedding; then
+- GECKO_CFLAGS=`pkg-config --cflags libxul-embedding '>=' $gecko_min_version $gecko_cv_extra_pkg_dependencies`
+- GECKO_LIBS=`pkg-config --libs libxul-embedding '>=' $gecko_min_version $gecko_cv_extra_pkg_dependencies`
+-else
+- GECKO_CFLAGS=`pkg-config --cflags ${GECKO}-xpcom '>=' $gecko_min_version $GECKO_EXTRA_PKG_DEPENDENCIES`
+- GECKO_LIBS=`pkg-config --libs ${GECKO}-xpcom '>=' $gecko_min_version $GECKO_EXTRA_PKG_DEPENDENCIES`
+-fi
++case "$GECKO" in
++libxul*)
++ GECKO_CFLAGS=`pkg-config --cflags ${GECKO} '>=' $gecko_min_version $gecko_cv_extra_pkg_dependencies`;
++ GECKO_LIBS=`pkg-config --libs ${GECKO} '>=' $gecko_min_version $gecko_cv_extra_pkg_dependencies`;
++ ;;
++*)
++ GECKO_CFLAGS=`pkg-config --cflags ${GECKO}-xpcom '>=' $gecko_min_version $GECKO_EXTRA_PKG_DEPENDENCIES`;
++ GECKO_LIBS=`pkg-config --libs ${GECKO}-xpcom '>=' $gecko_min_version $GECKO_EXTRA_PKG_DEPENDENCIES`;
++ ;;
++esac
+
+ AC_SUBST([GECKO_CFLAGS])
+ AC_SUBST([GECKO_LIBS])