summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDiego Elio Pettenò <flameeyes@gentoo.org>2012-11-09 17:25:39 +0000
committerDiego Elio Pettenò <flameeyes@gentoo.org>2012-11-09 17:25:39 +0000
commit3666c03286b81794318b05be0b72abca6a03469f (patch)
tree14a435c4fd80275f7559a5fdb16a2f293123f369 /dev-util
parentAdd a masked revision bump to leverage the layout changes in boost-1.52.0-r1. (diff)
downloadgentoo-2-3666c03286b81794318b05be0b72abca6a03469f.tar.gz
gentoo-2-3666c03286b81794318b05be0b72abca6a03469f.tar.bz2
gentoo-2-3666c03286b81794318b05be0b72abca6a03469f.zip
Add a masked revision bump to leverage the layout changes in boost-1.52.0-r1.
(Portage version: 2.2.0_alpha142/cvs/Linux x86_64, signed Manifest commit with key 1CD13C8AD4301342)
Diffstat (limited to 'dev-util')
-rw-r--r--dev-util/source-highlight/ChangeLog8
-rw-r--r--dev-util/source-highlight/source-highlight-3.1.7-r2.ebuild44
2 files changed, 51 insertions, 1 deletions
diff --git a/dev-util/source-highlight/ChangeLog b/dev-util/source-highlight/ChangeLog
index b8944bc9d1f8..ed7fa1fbf5df 100644
--- a/dev-util/source-highlight/ChangeLog
+++ b/dev-util/source-highlight/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-util/source-highlight
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-util/source-highlight/ChangeLog,v 1.48 2012/07/05 06:41:17 naota Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-util/source-highlight/ChangeLog,v 1.49 2012/11/09 17:25:39 flameeyes Exp $
+
+*source-highlight-3.1.7-r2 (09 Nov 2012)
+
+ 09 Nov 2012; Diego E. Pettenò <flameeyes@gentoo.org>
+ +source-highlight-3.1.7-r2.ebuild:
+ Add a masked revision bump to leverage the layout changes in boost-1.52.0-r1.
05 Jul 2012; Naohiro Aota <naota@gentoo.org> source-highlight-3.1.7-r1.ebuild:
Add ~x86-fbsd. #421039
diff --git a/dev-util/source-highlight/source-highlight-3.1.7-r2.ebuild b/dev-util/source-highlight/source-highlight-3.1.7-r2.ebuild
new file mode 100644
index 000000000000..56ae450e7420
--- /dev/null
+++ b/dev-util/source-highlight/source-highlight-3.1.7-r2.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-util/source-highlight/source-highlight-3.1.7-r2.ebuild,v 1.1 2012/11/09 17:25:39 flameeyes Exp $
+
+EAPI="4"
+
+inherit bash-completion-r1 versionator
+
+DESCRIPTION="Generate highlighted source code as an (x)html document"
+HOMEPAGE="http://www.gnu.org/software/src-highlite/source-highlight.html"
+SRC_URI="mirror://gnu/src-highlite/${P}.tar.gz"
+LICENSE="GPL-3"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos ~sparc-solaris"
+SLOT="0"
+IUSE="doc static-libs"
+
+DEPEND=">=dev-libs/boost-1.52.0-r1[threads]
+ dev-util/ctags"
+RDEPEND="${DEPEND}"
+
+src_configure() {
+ econf \
+ --with-boost-regex="boost_regex" \
+ --without-bash-completion \
+ $(use_enable static-libs static)
+}
+
+src_install () {
+ DOCS="AUTHORS ChangeLog CREDITS NEWS README THANKS TODO.txt"
+ default
+
+ use static-libs || rm -rf "${D}"/usr/lib*/*.la
+
+ dobashcomp completion/source-highlight
+
+ # That's not how we want it
+ rm -fr "${ED}/usr/share"/{aclocal,doc}
+ use doc && dohtml -A java doc/*.{html,css,java}
+}
+
+src_test() {
+ export LD_LIBRARY_PATH="${S}/lib/srchilite/.libs/"
+ default
+}