summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2010-12-30 01:05:25 +0000
committerArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2010-12-30 01:05:25 +0000
commit358b500a4af8971c4572b3a4d814d52fd083635e (patch)
treee7e6988b54a63c3153760a25449b3a3af3af8a76 /dev-util
parentFix building with newer versions of dev-python/sip (bug #332503, bug #349707). (diff)
downloadgentoo-2-358b500a4af8971c4572b3a4d814d52fd083635e.tar.gz
gentoo-2-358b500a4af8971c4572b3a4d814d52fd083635e.tar.bz2
gentoo-2-358b500a4af8971c4572b3a4d814d52fd083635e.zip
Use python_merge_intermediate_installation_images().
(Portage version: 2.2.0_alpha10_p17/cvs/Linux x86_64)
Diffstat (limited to 'dev-util')
-rw-r--r--dev-util/eric/eric-4.4.10.ebuild7
-rw-r--r--dev-util/eric/eric-5.0.4.ebuild7
2 files changed, 10 insertions, 4 deletions
diff --git a/dev-util/eric/eric-4.4.10.ebuild b/dev-util/eric/eric-4.4.10.ebuild
index 423fd2d20088..dd2005b0b069 100644
--- a/dev-util/eric/eric-4.4.10.ebuild
+++ b/dev-util/eric/eric-4.4.10.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-util/eric/eric-4.4.10.ebuild,v 1.1 2010/12/06 18:43:06 arfrever Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-util/eric/eric-4.4.10.ebuild,v 1.2 2010/12/30 01:05:25 arfrever Exp $
EAPI="3"
PYTHON_DEPEND="2:2.6"
@@ -43,6 +43,8 @@ unset L
S="${WORKDIR}/${MY_P}"
+PYTHON_VERSIONED_EXECUTABLES=("/usr/bin/.*")
+
src_prepare() {
epatch "${FILESDIR}/eric-4.4-no-interactive.patch"
epatch "${FILESDIR}/remove_coverage.patch"
@@ -58,11 +60,12 @@ src_install() {
"$(PYTHON)" install.py \
-z \
-b "${EPREFIX}/usr/bin" \
- -i "${D}" \
+ -i "${T}/images/${PYTHON_ABI}" \
-d "${EPREFIX}$(python_get_sitedir)" \
-c
}
python_execute_function installation
+ python_merge_intermediate_installation_images "${T}/images"
doicon eric/icons/default/eric.png || die "doicon failed"
make_desktop_entry "${MY_PN} --nosplash" ${MY_PN} eric "Development;IDE;Qt"
diff --git a/dev-util/eric/eric-5.0.4.ebuild b/dev-util/eric/eric-5.0.4.ebuild
index f631c9e0c7c4..1764413d0e50 100644
--- a/dev-util/eric/eric-5.0.4.ebuild
+++ b/dev-util/eric/eric-5.0.4.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-util/eric/eric-5.0.4.ebuild,v 1.1 2010/12/06 19:09:36 arfrever Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-util/eric/eric-5.0.4.ebuild,v 1.2 2010/12/30 01:05:25 arfrever Exp $
EAPI="3"
PYTHON_DEPEND="3"
@@ -41,6 +41,8 @@ unset L
S="${WORKDIR}/${MY_P}"
+PYTHON_VERSIONED_EXECUTABLES=("/usr/bin/.*")
+
src_prepare() {
epatch "${FILESDIR}/${PN}-5.0.2-remove_coverage.patch"
@@ -62,11 +64,12 @@ src_install() {
"$(PYTHON)" install.py \
-z \
-b "${EPREFIX}/usr/bin" \
- -i "${D}" \
+ -i "${T}/images/${PYTHON_ABI}" \
-d "${EPREFIX}$(python_get_sitedir)" \
-c
}
python_execute_function installation
+ python_merge_intermediate_installation_images "${T}/images"
doicon eric/icons/default/${MY_PN}.png || die "doicon failed"
}