summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Gilbert <floppym@gentoo.org>2011-11-26 17:23:22 +0000
committerMike Gilbert <floppym@gentoo.org>2011-11-26 17:23:22 +0000
commit2d32b4eec6d7c8afa84cc7642d025260364055a1 (patch)
tree474642fba9f8aac1e6745f07ef784ab169da3c33 /dev-util
parentRequire dev-lang/perl at runtime. (diff)
downloadgentoo-2-2d32b4eec6d7c8afa84cc7642d025260364055a1.tar.gz
gentoo-2-2d32b4eec6d7c8afa84cc7642d025260364055a1.tar.bz2
gentoo-2-2d32b4eec6d7c8afa84cc7642d025260364055a1.zip
Python-related improvements by Ian Delaney. Bug 324399.
(Portage version: 2.2.0_alpha78/cvs/Linux x86_64)
Diffstat (limited to 'dev-util')
-rw-r--r--dev-util/ghh/ChangeLog5
-rw-r--r--dev-util/ghh/ghh-9999.ebuild18
2 files changed, 17 insertions, 6 deletions
diff --git a/dev-util/ghh/ChangeLog b/dev-util/ghh/ChangeLog
index 5e71d5e580ee..4a427a123aca 100644
--- a/dev-util/ghh/ChangeLog
+++ b/dev-util/ghh/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for dev-util/ghh
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-util/ghh/ChangeLog,v 1.5 2011/09/20 22:37:13 mgorny Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-util/ghh/ChangeLog,v 1.6 2011/11/26 17:23:22 floppym Exp $
+
+ 26 Nov 2011; Mike Gilbert <floppym@gentoo.org> ghh-9999.ebuild:
+ Python-related improvements by Ian Delaney. Bug 324399.
20 Sep 2011; Michał Górny <mgorny@gentoo.org> ghh-9999.ebuild:
Migrate to git-2, update EGIT_REPO_URI.
diff --git a/dev-util/ghh/ghh-9999.ebuild b/dev-util/ghh/ghh-9999.ebuild
index d3041e0bbb1d..f5bfc4f51c32 100644
--- a/dev-util/ghh/ghh-9999.ebuild
+++ b/dev-util/ghh/ghh-9999.ebuild
@@ -1,9 +1,10 @@
# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-util/ghh/ghh-9999.ebuild,v 1.6 2011/09/20 22:37:13 mgorny Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-util/ghh/ghh-9999.ebuild,v 1.7 2011/11/26 17:23:22 floppym Exp $
EAPI=3
-inherit autotools git-2
+PYTHON_DEPEND="2:2.6"
+inherit autotools git-2 python
DESCRIPTION="a tool to track the history and make backups of your home directory"
HOMEPAGE="http://jean-francois.richard.name/ghh/"
@@ -15,6 +16,7 @@ LICENSE="GPL-2"
SLOT="0"
KEYWORDS=""
IUSE=""
+DOCS=( AUTHORS ChangeLog MAINTAINERS NEWS README TODO )
# probably needs more/less crap listed here ...
RDEPEND="x11-libs/gtk+:2
@@ -22,16 +24,22 @@ RDEPEND="x11-libs/gtk+:2
gnome-base/libgnome
app-text/gnome-doc-utils
>=app-text/asciidoc-8
- dev-vcs/git
- dev-lang/python"
+ dev-python/pygtk:2
+ dev-vcs/git"
DEPEND="${RDEPEND}
dev-util/pkgconfig"
+pkg_setup() {
+ python_set_active_version 2
+ python_pkg_setup
+}
+
src_prepare() {
NOCONFIGURE=yes git_src_prepare
}
src_install() {
emake install DESTDIR="${D}" || die
- dodoc AUTHORS ChangeLog MAINTAINERS NEWS README TODO
+ dodoc ${DOCS[@]}
+ python_convert_shebangs -r 2 "${ED}"
}