summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndrey Grozin <grozin@gentoo.org>2011-11-04 07:12:46 +0000
committerAndrey Grozin <grozin@gentoo.org>2011-11-04 07:12:46 +0000
commit1967860fa5f0c6d35e216c74b8667669b2075884 (patch)
tree0d750737b6618b3ecd51783a7d69e84fd5404381 /dev-util
parentBump to 3.1.0 from the gnome overlay. Move to EAPI4. Changes: recognizes yelp... (diff)
downloadgentoo-2-1967860fa5f0c6d35e216c74b8667669b2075884.tar.gz
gentoo-2-1967860fa5f0c6d35e216c74b8667669b2075884.tar.bz2
gentoo-2-1967860fa5f0c6d35e216c74b8667669b2075884.zip
Version bump
(Portage version: 2.2.0_alpha72/cvs/Linux i686)
Diffstat (limited to 'dev-util')
-rw-r--r--dev-util/diffuse/ChangeLog9
-rw-r--r--dev-util/diffuse/diffuse-0.4.6.ebuild46
2 files changed, 53 insertions, 2 deletions
diff --git a/dev-util/diffuse/ChangeLog b/dev-util/diffuse/ChangeLog
index 4500dfcb84c4..4b14c0c62463 100644
--- a/dev-util/diffuse/ChangeLog
+++ b/dev-util/diffuse/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-util/diffuse
-# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-util/diffuse/ChangeLog,v 1.13 2010/11/03 16:10:32 grozin Exp $
+# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-util/diffuse/ChangeLog,v 1.14 2011/11/04 07:12:46 grozin Exp $
+
+*diffuse-0.4.6 (04 Nov 2011)
+
+ 04 Nov 2011; Andrey Grozin <grozin@gentoo.org> +diffuse-0.4.6.ebuild:
+ Version bump
*diffuse-0.4.4 (03 Nov 2010)
diff --git a/dev-util/diffuse/diffuse-0.4.6.ebuild b/dev-util/diffuse/diffuse-0.4.6.ebuild
new file mode 100644
index 000000000000..226e2d96098c
--- /dev/null
+++ b/dev-util/diffuse/diffuse-0.4.6.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-util/diffuse/diffuse-0.4.6.ebuild,v 1.1 2011/11/04 07:12:46 grozin Exp $
+
+EAPI="2"
+PYTHON_DEPEND="2"
+
+inherit fdo-mime python
+
+DESCRIPTION="A graphical tool to compare and merge text files"
+HOMEPAGE="http://diffuse.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="dev-python/pygtk"
+# file collision, bug #279018
+DEPEND="!sci-chemistry/tinker"
+
+pkg_setup() {
+ python_set_active_version 2
+}
+
+src_prepare() {
+ python_convert_shebangs 2 src/usr/bin/diffuse
+}
+
+src_install() {
+ "$(PYTHON)" install.py \
+ --prefix=/usr \
+ --files-only \
+ --destdir="${D}" \
+ || die "Installation failed"
+ dodoc AUTHORS ChangeLog README
+}
+
+pkg_postinst() {
+ fdo-mime_desktop_database_update
+}
+
+pkg_postrm() {
+ fdo-mime_desktop_database_update
+}