summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJavier Villavicencio <the_paya@gentoo.org>2010-04-15 09:55:18 +0000
committerJavier Villavicencio <the_paya@gentoo.org>2010-04-15 09:55:18 +0000
commit168a330840401f85b2e75a45aa9b381cb681c568 (patch)
treec7402d1eb5cd96c1991de5977d85b5cbf5751553 /dev-util
parentmake use of new python.eclass functions as filed in bug 311663 (diff)
downloadgentoo-2-168a330840401f85b2e75a45aa9b381cb681c568.tar.gz
gentoo-2-168a330840401f85b2e75a45aa9b381cb681c568.tar.bz2
gentoo-2-168a330840401f85b2e75a45aa9b381cb681c568.zip
Fix for bug #314791 with revbump.
(Portage version: 2.2_rc67/cvs/FreeBSD i386)
Diffstat (limited to 'dev-util')
-rw-r--r--dev-util/cvs/ChangeLog8
-rw-r--r--dev-util/cvs/cvs-1.12.12-r8.ebuild82
-rw-r--r--dev-util/cvs/files/cvs-1.12.12-getdelim.patch21
3 files changed, 110 insertions, 1 deletions
diff --git a/dev-util/cvs/ChangeLog b/dev-util/cvs/ChangeLog
index 4eeaa462ada9..32ca8794e4da 100644
--- a/dev-util/cvs/ChangeLog
+++ b/dev-util/cvs/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-util/cvs
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-util/cvs/ChangeLog,v 1.140 2010/03/11 10:32:40 haubi Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-util/cvs/ChangeLog,v 1.141 2010/04/15 09:55:18 the_paya Exp $
+
+*cvs-1.12.12-r8 (15 Apr 2010)
+
+ 15 Apr 2010; Javier Villavicencio <the_paya@gentoo.org>
+ +cvs-1.12.12-r8.ebuild, +files/cvs-1.12.12-getdelim.patch:
+ Fix for bug #314791, with revbump as requested by robbat2.
11 Mar 2010; Michael Haubenwallner <haubi@gentoo.org>
cvs-1.11.22.1-r1.ebuild, +files/cvs-1.11.22.1-hash-nameclash.patch,
diff --git a/dev-util/cvs/cvs-1.12.12-r8.ebuild b/dev-util/cvs/cvs-1.12.12-r8.ebuild
new file mode 100644
index 000000000000..62de2c2e24e3
--- /dev/null
+++ b/dev-util/cvs/cvs-1.12.12-r8.ebuild
@@ -0,0 +1,82 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-util/cvs/cvs-1.12.12-r8.ebuild,v 1.1 2010/04/15 09:55:18 the_paya Exp $
+
+EAPI=3
+
+inherit eutils pam
+
+DESCRIPTION="Concurrent Versions System - source code revision control tools"
+HOMEPAGE="http://www.nongnu.org/cvs/"
+
+SRC_URI="mirror://gnu/non-gnu/cvs/source/feature/${PV}/${P}.tar.bz2
+ doc? ( mirror://gnu/non-gnu/cvs/source/feature/${PV}/cederqvist-${PV}.html.tar.bz2
+ mirror://gnu/non-gnu/cvs/source/feature/${PV}/cederqvist-${PV}.pdf
+ mirror://gnu/non-gnu/cvs/source/feature/${PV}/cederqvist-${PV}.ps )"
+
+LICENSE="GPL-2 LGPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~ppc-aix ~sparc-fbsd ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos ~m68k-mint ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+
+IUSE="crypt doc kerberos nls pam server"
+
+DEPEND=">=sys-libs/zlib-1.1.4
+ kerberos? ( virtual/krb5 )
+ pam? ( virtual/pam )"
+
+src_unpack() {
+ unpack ${P}.tar.bz2
+ use doc && unpack cederqvist-${PV}.html.tar.bz2
+}
+
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-cvsbug-tmpfix.patch
+ epatch "${FILESDIR}"/${P}-openat.patch
+ epatch "${FILESDIR}"/${P}-block-requests.patch
+ epatch "${FILESDIR}"/${P}-cvs-gnulib-vasnprintf.patch
+ epatch "${FILESDIR}"/${P}-install-sh.patch
+ epatch "${FILESDIR}"/${P}-hash-nameclash.patch # for AIX
+ epatch "${FILESDIR}"/${P}-getdelim.patch # 314791
+ elog "If you want any CVS server functionality, you MUST emerge with USE=server!"
+}
+
+src_configure() {
+ econf \
+ --with-external-zlib \
+ --with-tmpdir=/tmp \
+ $(use_enable crypt encryption) \
+ $(use_with kerberos gssapi) \
+ $(use_enable nls) \
+ $(use_enable pam) \
+ $(use_enable server)
+}
+
+src_install() {
+ emake install DESTDIR="${D}" || die
+
+ insinto /etc/xinetd.d
+ newins "${FILESDIR}"/cvspserver.xinetd.d cvspserver || die "newins failed"
+
+ dodoc BUGS ChangeLog* DEVEL* FAQ HACKING \
+ MINOR* NEWS PROJECTS README* TESTS TODO
+
+ # Not installed into emacs site-lisp because it clobbers the normal C
+ # indentations.
+ dodoc cvs-format.el || die "dodoc failed"
+
+ use server && newdoc "${FILESDIR}"/cvs-1.12.12-cvs-custom.c cvs-custom.c
+
+ if use doc; then
+ dodoc "${DISTDIR}"/cederqvist-${PV}.pdf
+ dodoc "${DISTDIR}"/cederqvist-${PV}.ps
+ tar xjf "${DISTDIR}"/cederqvist-${PV}.html.tar.bz2
+ dohtml -r cederqvist-${PV}.html/*
+ dosym cvs.html /usr/share/doc/${PF}/html/index.html
+ fi
+
+ newpamd "${FILESDIR}"/cvs.pam-include-1.12.12 cvs
+}
+
+src_test() {
+ einfo "FEATURES=\"maketest\" has been disabled for dev-util/cvs"
+}
diff --git a/dev-util/cvs/files/cvs-1.12.12-getdelim.patch b/dev-util/cvs/files/cvs-1.12.12-getdelim.patch
new file mode 100644
index 000000000000..d27bcc04a681
--- /dev/null
+++ b/dev-util/cvs/files/cvs-1.12.12-getdelim.patch
@@ -0,0 +1,21 @@
+The function getdelim() behaves slightly different on FreeBSD,
+only appending to the *line buffer if line_size is 0.
+
+See:
+http://savannah.nongnu.org/bugs/?29466
+http://bugs.gentoo.org/314791
+
+Already comitted upstream:
+http://cvs.savannah.gnu.org/viewvc/ccvs/src/myndbm.c?root=cvs&r1=1.38&r2=1.39
+
+--- src/myndbm.c.orig
++++ src/myndbm.c
+@@ -213,7 +213,7 @@
+ mydbm_load_file (FILE *fp, List *list, char *filename)
+ {
+ char *line = NULL;
+- size_t line_size;
++ size_t line_size = 0;
+ char *value;
+ size_t value_allocated;
+ char *cp, *vp;