summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavid Holm <dholm@gentoo.org>2007-03-15 19:35:50 +0000
committerDavid Holm <dholm@gentoo.org>2007-03-15 19:35:50 +0000
commit15f6a2e1c4f26ccae71bf61c956f71d30d5f02ef (patch)
tree2e60378a4ec032ac608dfb009d5c4397f0731a8e /dev-util
parentstable on amd64; bug 171052 (diff)
downloadgentoo-2-15f6a2e1c4f26ccae71bf61c956f71d30d5f02ef.tar.gz
gentoo-2-15f6a2e1c4f26ccae71bf61c956f71d30d5f02ef.tar.bz2
gentoo-2-15f6a2e1c4f26ccae71bf61c956f71d30d5f02ef.zip
Version bumped and added fix from bug #170983
(Portage version: 2.1.2.2)
Diffstat (limited to 'dev-util')
-rw-r--r--dev-util/pmk/ChangeLog8
-rw-r--r--dev-util/pmk/files/digest-pmk-0.10.13
-rw-r--r--dev-util/pmk/pmk-0.10.1.ebuild58
3 files changed, 68 insertions, 1 deletions
diff --git a/dev-util/pmk/ChangeLog b/dev-util/pmk/ChangeLog
index 797e00fee751..ce698fa68f29 100644
--- a/dev-util/pmk/ChangeLog
+++ b/dev-util/pmk/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-util/pmk
# Copyright 2000-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-util/pmk/ChangeLog,v 1.8 2007/02/22 02:23:04 peper Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-util/pmk/ChangeLog,v 1.9 2007/03/15 19:35:50 dholm Exp $
+
+*pmk-0.10.1 (15 Mar 2007)
+
+ 15 Mar 2007; <dholm@gentoo.org> +pmk-0.10.1.ebuild:
+ Version bumped and added fix from James Rowe (jnrowe (at) ukfsn (dot) org).
+ Closes bug #170983.
22 Feb 2007; Piotr Jaroszyński <peper@gentoo.org> ChangeLog:
Transition to Manifest2.
diff --git a/dev-util/pmk/files/digest-pmk-0.10.1 b/dev-util/pmk/files/digest-pmk-0.10.1
new file mode 100644
index 000000000000..768df5483986
--- /dev/null
+++ b/dev-util/pmk/files/digest-pmk-0.10.1
@@ -0,0 +1,3 @@
+MD5 98587c97adda6785bb0615a420815dae pmk-0.10.1.tar.gz 207337
+RMD160 aae6f7d6fa75bd319387eccecc189569b1f0277e pmk-0.10.1.tar.gz 207337
+SHA256 0cdf7abde165eded40e840d90bc7a1fba5afb0e3aed2a36af94600edd3ca67ad pmk-0.10.1.tar.gz 207337
diff --git a/dev-util/pmk/pmk-0.10.1.ebuild b/dev-util/pmk/pmk-0.10.1.ebuild
new file mode 100644
index 000000000000..d449eaa65aa5
--- /dev/null
+++ b/dev-util/pmk/pmk-0.10.1.ebuild
@@ -0,0 +1,58 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-util/pmk/pmk-0.10.1.ebuild,v 1.1 2007/03/15 19:35:50 dholm Exp $
+
+inherit toolchain-funcs
+
+DESCRIPTION="Aims to be an alternative to GNU autoconf"
+HOMEPAGE="http://pmk.sourceforge.net/"
+SRC_URI="mirror://sourceforge/pmk/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~x86 ~ppc"
+IUSE=""
+
+DEPEND=""
+RDEPEND=""
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+
+ # Remove executable stack
+ cp detect_cpu_asm.s detect_cpu_asm.S
+ cat >> detect_cpu_asm.S <<EOF
+#ifdef __ELF__
+.section .note.GNU-stack,"",%progbits
+#endif
+EOF
+}
+
+src_compile() {
+ tc-export CC CPP AS
+ ./pmkcfg.sh -p /usr || die "Config failed"
+ emake || die "Build failed"
+}
+
+src_install () {
+ make DESTDIR="${D}" MANDIR=/usr/share/man install || die
+
+ dodoc BUGS Changelog INSTALL LICENSE README STATUS TODO
+}
+
+pkg_postinst() {
+ if [[ ! -f ${ROOT}etc/pmk/pmk.conf ]] ; then
+ einfo
+ einfo "${ROOT}etc/pmk/pmk.conf doesn't exist."
+ einfo "Running pmksetup to generate an initial pmk.conf."
+ einfo
+ # create one with initial values
+ ${ROOT}usr/bin/pmksetup
+ # run it again to reset PREFIX from /usr/local to /usr
+ ${ROOT}usr/bin/pmksetup -u PREFIX=\"/usr\"
+ # remove the automatically created backup from the extra run
+ rm -f ${ROOT}etc/pmk/pmk.conf.bak
+ fi
+}
+