summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTomas Chvatal <scarabeus@gentoo.org>2010-08-10 12:58:20 +0000
committerTomas Chvatal <scarabeus@gentoo.org>2010-08-10 12:58:20 +0000
commit0ce6585df46e7a65c33ab3f0d5164caa521ef7be (patch)
tree3d02f784996f197ee01bb5e98532a52191c0c99e /dev-util
parentCleanup old stuff. (diff)
downloadgentoo-2-0ce6585df46e7a65c33ab3f0d5164caa521ef7be.tar.gz
gentoo-2-0ce6585df46e7a65c33ab3f0d5164caa521ef7be.tar.bz2
gentoo-2-0ce6585df46e7a65c33ab3f0d5164caa521ef7be.zip
Drop older stuff.
(Portage version: 2.2_rc67/cvs/Linux x86_64)
Diffstat (limited to 'dev-util')
-rw-r--r--dev-util/cmake/ChangeLog7
-rw-r--r--dev-util/cmake/cmake-2.8.1-r1.ebuild157
-rw-r--r--dev-util/cmake/cmake-2.8.1.ebuild155
-rw-r--r--dev-util/cmake/files/cmake-2.8.0-more-no_host_paths.patch108
4 files changed, 6 insertions, 421 deletions
diff --git a/dev-util/cmake/ChangeLog b/dev-util/cmake/ChangeLog
index d1695d9c8664..175856e3b972 100644
--- a/dev-util/cmake/ChangeLog
+++ b/dev-util/cmake/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-util/cmake
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-util/cmake/ChangeLog,v 1.140 2010/08/06 14:26:17 fauli Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-util/cmake/ChangeLog,v 1.141 2010/08/10 12:58:19 scarabeus Exp $
+
+ 10 Aug 2010; Tomáš Chvátal <scarabeus@gentoo.org>
+ -files/cmake-2.8.0-more-no_host_paths.patch, -cmake-2.8.1.ebuild,
+ -cmake-2.8.1-r1.ebuild:
+ Drop older stuff.
06 Aug 2010; Christian Faulhammer <fauli@gentoo.org>
cmake-2.8.1-r2.ebuild:
diff --git a/dev-util/cmake/cmake-2.8.1-r1.ebuild b/dev-util/cmake/cmake-2.8.1-r1.ebuild
deleted file mode 100644
index eba8400356da..000000000000
--- a/dev-util/cmake/cmake-2.8.1-r1.ebuild
+++ /dev/null
@@ -1,157 +0,0 @@
-# Copyright 1999-2010 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header $
-
-EAPI="3"
-
-inherit elisp-common toolchain-funcs eutils versionator flag-o-matic base cmake-utils
-
-MY_P="${PN}-$(replace_version_separator 3 - ${MY_PV})"
-
-DESCRIPTION="Cross platform Make"
-HOMEPAGE="http://www.cmake.org/"
-SRC_URI="http://www.cmake.org/files/v$(get_version_component_range 1-2)/${MY_P}.tar.gz"
-
-LICENSE="CMake"
-KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~ppc-aix ~sparc-fbsd ~x86-fbsd ~hppa-hpux ~ia64-hpux ~x86-interix ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~x64-solaris ~x86-solaris"
-SLOT="0"
-IUSE="emacs ncurses qt4 vim-syntax"
-
-DEPEND="
- >=net-misc/curl-7.20.0-r1[ssl]
- >=dev-libs/expat-2.0.1
- sys-libs/zlib
- ncurses? ( sys-libs/ncurses )
- qt4? ( x11-libs/qt-gui:4 )
-"
-RDEPEND="${DEPEND}
- emacs? ( virtual/emacs )
- vim-syntax? (
- || (
- app-editors/vim
- app-editors/gvim
- )
- )
-"
-
-SITEFILE="50${PN}-gentoo.el"
-VIMFILE="${PN}.vim"
-
-S="${WORKDIR}/${MY_P}"
-
-CMAKE_IN_SOURCE_BUILD=1
-
-PATCHES=(
- "${FILESDIR}"/${PN}-FindPythonLibs.patch
- "${FILESDIR}"/${PN}-FindPythonInterp.patch
- "${FILESDIR}"/${PN}-2.6.0-interix.patch
- "${FILESDIR}"/${PN}-2.6.3-darwin-bundle.patch
- "${FILESDIR}"/${PN}-2.6.3-no-duplicates-in-rpath.patch
- "${FILESDIR}"/${PN}-2.6.3-fix_broken_lfs_on_aix.patch
- "${FILESDIR}"/${PN}-2.8.0-darwin-default-install_name.patch
- "${FILESDIR}"/${PN}-2.8.0-darwin-no-app-with-qt.patch
- "${FILESDIR}"/${PN}-2.8.1-more-no_host_paths.patch
- "${FILESDIR}"/${PN}-2.8.1-FindBoost.patch
- "${FILESDIR}"/${PN}-2.8.1-libform.patch
-)
-
-src_prepare() {
- base_src_prepare
-
- # Add gcc libs to the default link paths
- sed -i \
- -e "s|@GENTOO_PORTAGE_GCCLIBDIR@|${EPREFIX}/usr/${CHOST}/lib|g" \
- -e "s|@GENTOO_PORTAGE_EPREFIX@|${EPREFIX}/|g" \
- Modules/Platform/{UnixPaths,Darwin}.cmake || die "sed failed"
-}
-
-src_configure() {
- if [[ "$(gcc-major-version)" -eq "3" ]] ; then
- append-flags "-fno-stack-protector"
- fi
-
- bootstrap=0
- has_version ">=dev-util/cmake-2.6.1" || bootstrap=1
- if [[ ${bootstrap} = 0 ]]; then
- # Required version of CMake found, now test if it works
- cmake --version &> /dev/null || bootstrap=1
- fi
-
- if [[ ${bootstrap} = 1 ]]; then
- local qt_arg par_arg
- tc-export CC CXX LD
-
- if use qt4; then
- qt_arg="--qt-gui"
- else
- qt_arg="--no-qt-gui"
- fi
-
- echo $MAKEOPTS | egrep -o '(\-j|\-\-jobs)(=?|[[:space:]]*)[[:digit:]]+' > /dev/null
- if [ $? -eq 0 ]; then
- par_arg=$(echo $MAKEOPTS | egrep -o '(\-j|\-\-jobs)(=?|[[:space:]]*)[[:digit:]]+' | egrep -o '[[:digit:]]+')
- par_arg="--parallel=${par_arg}"
- else
- par_arg="--parallel=1"
- fi
-
- ./bootstrap \
- --system-libs \
- --prefix="${EPREFIX}"/usr \
- --docdir=/share/doc/${PF} \
- --datadir=/share/${PN} \
- --mandir=/share/man \
- "$qt_arg" \
- "$par_arg" || die "./bootstrap failed"
- else
- # this is way much faster so we should prefer it if some cmake is
- # around.
- local mycmakeargs=(
- -DCMAKE_USE_SYSTEM_LIBRARIES=ON
- -DCMAKE_INSTALL_PREFIX="${EPREFIX}"/usr
- -DCMAKE_DOC_DIR=/share/doc/${PF}
- -DCMAKE_MAN_DIR=/share/man
- -DCMAKE_DATA_DIR=/share/${PN}
- $(cmake-utils_use_build ncurses CursesDialog)
- $(cmake-utils_use_build qt4 QtDialog)
- )
- cmake-utils_src_configure
- fi
-}
-
-src_compile() {
- cmake-utils_src_compile
- if use emacs; then
- elisp-compile Docs/cmake-mode.el || die "elisp compile failed"
- fi
-}
-
-src_test() {
- emake test || die "Tests failed"
-}
-
-src_install() {
- cmake-utils_src_install
- if use emacs; then
- elisp-install ${PN} Docs/cmake-mode.el Docs/cmake-mode.elc || die "elisp-install failed"
- elisp-site-file-install "${FILESDIR}/${SITEFILE}"
- fi
- if use vim-syntax; then
- insinto /usr/share/vim/vimfiles/syntax
- doins Docs/cmake-syntax.vim
-
- insinto /usr/share/vim/vimfiles/indent
- doins Docs/cmake-indent.vim
-
- insinto /usr/share/vim/vimfiles/ftdetect
- doins "${FILESDIR}/${VIMFILE}"
- fi
-}
-
-pkg_postinst() {
- use emacs && elisp-site-regen
-}
-
-pkg_postrm() {
- use emacs && elisp-site-regen
-}
diff --git a/dev-util/cmake/cmake-2.8.1.ebuild b/dev-util/cmake/cmake-2.8.1.ebuild
deleted file mode 100644
index 35682f7b14f2..000000000000
--- a/dev-util/cmake/cmake-2.8.1.ebuild
+++ /dev/null
@@ -1,155 +0,0 @@
-# Copyright 1999-2010 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-util/cmake/cmake-2.8.1.ebuild,v 1.2 2010/03/17 20:10:25 grobian Exp $
-
-EAPI="3"
-
-inherit elisp-common toolchain-funcs eutils versionator flag-o-matic base cmake-utils
-
-MY_P="${PN}-$(replace_version_separator 3 - ${MY_PV})"
-
-DESCRIPTION="Cross platform Make"
-HOMEPAGE="http://www.cmake.org/"
-SRC_URI="http://www.cmake.org/files/v$(get_version_component_range 1-2)/${MY_P}.tar.gz"
-
-LICENSE="CMake"
-KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~ppc-aix ~sparc-fbsd ~x86-fbsd ~hppa-hpux ~ia64-hpux ~x86-interix ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~x64-solaris ~x86-solaris"
-SLOT="0"
-IUSE="emacs ncurses qt4 vim-syntax"
-
-DEPEND="
- >=net-misc/curl-7.20.0-r1[ssl]
- >=dev-libs/expat-2.0.1
- sys-libs/zlib
- ncurses? ( sys-libs/ncurses )
- qt4? ( x11-libs/qt-gui:4 )
-"
-RDEPEND="${DEPEND}
- emacs? ( virtual/emacs )
- vim-syntax? (
- || (
- app-editors/vim
- app-editors/gvim
- )
- )
-"
-
-SITEFILE="50${PN}-gentoo.el"
-VIMFILE="${PN}.vim"
-
-S="${WORKDIR}/${MY_P}"
-
-CMAKE_IN_SOURCE_BUILD=1
-
-PATCHES=(
- "${FILESDIR}"/${PN}-FindPythonLibs.patch
- "${FILESDIR}"/${PN}-FindPythonInterp.patch
- "${FILESDIR}"/${PN}-2.6.0-interix.patch
- "${FILESDIR}"/${PN}-2.6.3-darwin-bundle.patch
- "${FILESDIR}"/${PN}-2.6.3-no-duplicates-in-rpath.patch
- "${FILESDIR}"/${PN}-2.6.3-fix_broken_lfs_on_aix.patch
- "${FILESDIR}"/${PN}-2.8.0-darwin-default-install_name.patch
- "${FILESDIR}"/${PN}-2.8.0-darwin-no-app-with-qt.patch
- "${FILESDIR}"/${PN}-2.8.1-more-no_host_paths.patch
-)
-
-src_prepare() {
- base_src_prepare
-
- # Add gcc libs to the default link paths
- sed -i \
- -e "s|@GENTOO_PORTAGE_GCCLIBDIR@|${EPREFIX}/usr/${CHOST}/lib|g" \
- -e "s|@GENTOO_PORTAGE_EPREFIX@|${EPREFIX}/|g" \
- Modules/Platform/{UnixPaths,Darwin}.cmake || die "sed failed"
-}
-
-src_configure() {
- if [[ "$(gcc-major-version)" -eq "3" ]] ; then
- append-flags "-fno-stack-protector"
- fi
-
- bootstrap=0
- has_version ">=dev-util/cmake-2.6.1" || bootstrap=1
- if [[ ${bootstrap} = 0 ]]; then
- # Required version of CMake found, now test if it works
- cmake --version &> /dev/null || bootstrap=1
- fi
-
- if [[ ${bootstrap} = 1 ]]; then
- local qt_arg par_arg
- tc-export CC CXX LD
-
- if use qt4; then
- qt_arg="--qt-gui"
- else
- qt_arg="--no-qt-gui"
- fi
-
- echo $MAKEOPTS | egrep -o '(\-j|\-\-jobs)(=?|[[:space:]]*)[[:digit:]]+' > /dev/null
- if [ $? -eq 0 ]; then
- par_arg=$(echo $MAKEOPTS | egrep -o '(\-j|\-\-jobs)(=?|[[:space:]]*)[[:digit:]]+' | egrep -o '[[:digit:]]+')
- par_arg="--parallel=${par_arg}"
- else
- par_arg="--parallel=1"
- fi
-
- ./bootstrap \
- --system-libs \
- --prefix="${EPREFIX}"/usr \
- --docdir=/share/doc/${PF} \
- --datadir=/share/${PN} \
- --mandir=/share/man \
- "$qt_arg" \
- "$par_arg" || die "./bootstrap failed"
- else
- # this is way much faster so we should prefer it if some cmake is
- # around.
- local mycmakeargs=(
- -DCMAKE_USE_SYSTEM_LIBRARIES=ON
- -DCMAKE_INSTALL_PREFIX="${EPREFIX}"/usr
- -DCMAKE_DOC_DIR=/share/doc/${PF}
- -DCMAKE_MAN_DIR=/share/man
- -DCMAKE_DATA_DIR=/share/${PN}
- $(cmake-utils_use_build ncurses CursesDialog)
- $(cmake-utils_use_build qt4 QtDialog)
- )
- cmake-utils_src_configure
- fi
-}
-
-src_compile() {
- cmake-utils_src_compile
- if use emacs; then
- elisp-compile Docs/cmake-mode.el || die "elisp compile failed"
- fi
-}
-
-src_test() {
- emake test || die "Tests failed"
-}
-
-src_install() {
- cmake-utils_src_install
- if use emacs; then
- elisp-install ${PN} Docs/cmake-mode.el Docs/cmake-mode.elc || die "elisp-install failed"
- elisp-site-file-install "${FILESDIR}/${SITEFILE}"
- fi
- if use vim-syntax; then
- insinto /usr/share/vim/vimfiles/syntax
- doins Docs/cmake-syntax.vim
-
- insinto /usr/share/vim/vimfiles/indent
- doins Docs/cmake-indent.vim
-
- insinto /usr/share/vim/vimfiles/ftdetect
- doins "${FILESDIR}/${VIMFILE}"
- fi
-}
-
-pkg_postinst() {
- use emacs && elisp-site-regen
-}
-
-pkg_postrm() {
- use emacs && elisp-site-regen
-}
diff --git a/dev-util/cmake/files/cmake-2.8.0-more-no_host_paths.patch b/dev-util/cmake/files/cmake-2.8.0-more-no_host_paths.patch
deleted file mode 100644
index a4cdf3905a12..000000000000
--- a/dev-util/cmake/files/cmake-2.8.0-more-no_host_paths.patch
+++ /dev/null
@@ -1,108 +0,0 @@
-Set some proper paths to make cmake find our tools.
-Original patch by Heiko Przybyl
-
-The ebuild now adds an extra / at the end of $EPREFIX so that it is
-never the empty string (so that CMAKE_SYSTEM_PREFIX_PATH remains
-correct)
-
---- cmake-2.8.0/Modules/Platform/Darwin.cmake
-+++ cmake-2.8.0/Modules/Platform/Darwin.cmake
-@@ -213,19 +213,23 @@
-
-
-
--# default to searching for frameworks first
--SET(CMAKE_FIND_FRAMEWORK FIRST)
-+# default to searching for frameworks last
-+SET(CMAKE_FIND_FRAMEWORK LAST)
- # set up the default search directories for frameworks
- SET(CMAKE_SYSTEM_FRAMEWORK_PATH
-+ @GENTOO_PORTAGE_EPREFIX@Frameworks
-+ @GENTOO_PORTAGE_EPREFIX@usr/lib
- ~/Library/Frameworks
- /Library/Frameworks
- /Network/Library/Frameworks
- /System/Library/Frameworks)
-
--# default to searching for application bundles first
--SET(CMAKE_FIND_APPBUNDLE FIRST)
-+# default to searching for application bundles last
-+SET(CMAKE_FIND_APPBUNDLE LAST)
- # set up the default search directories for application bundles
- SET(CMAKE_SYSTEM_APPBUNDLE_PATH
-+ @GENTOO_PORTAGE_EPREFIX@Applications
-+ @GENTOO_PORTAGE_EPREFIX@usr/bin
- ~/Applications
- /Applications
- /Developer/Applications)
---- cmake-2.8.0/Modules/Platform/UnixPaths.cmake
-+++ cmake-2.8.0/Modules/Platform/UnixPaths.cmake
-@@ -33,6 +33,7 @@
- # search types.
- LIST(APPEND CMAKE_SYSTEM_PREFIX_PATH
- # Standard
-+ @GENTOO_PORTAGE_EPREFIX@usr/local @GENTOO_PORTAGE_EPREFIX@ @GENTOO_PORTAGE_EPREFIX@usr
- /usr/local / /usr
-
- # CMake install location
-@@ -44,43 +45,39 @@
-
- # List common include file locations not under the common prefixes.
- LIST(APPEND CMAKE_SYSTEM_INCLUDE_PATH
-- # Windows API on Cygwin
-- /usr/include/w32api
--
-- # X11
-- /usr/X11R6/include /usr/include/X11
--
-- # Other
-- /opt/local/include /usr/pkg/include
-- /opt/csw/include /opt/include
-- /usr/openwin/include
-+ @GENTOO_PORTAGE_EPREFIX@usr/include
- )
-
- LIST(APPEND CMAKE_SYSTEM_LIBRARY_PATH
-- # Windows API on Cygwin
-- /usr/lib/w32api
--
-- # X11
-- /usr/X11R6/lib /usr/lib/X11
--
-- # Other
-- /opt/local/lib /usr/pkg/lib
-- /opt/csw/lib /opt/lib
-- /usr/openwin/lib
-+ @GENTOO_PORTAGE_GCCLIBDIR@/gcc
-+ @GENTOO_PORTAGE_GCCLIBDIR@
-+ @GENTOO_PORTAGE_EPREFIX@usr/lib64
-+ @GENTOO_PORTAGE_EPREFIX@usr/lib32
-+ @GENTOO_PORTAGE_EPREFIX@usr/lib
-+ @GENTOO_PORTAGE_EPREFIX@lib
- )
-
- LIST(APPEND CMAKE_SYSTEM_PROGRAM_PATH
-- /usr/pkg/bin
-+ @GENTOO_PORTAGE_EPREFIX@usr/bin
-+ @GENTOO_PORTAGE_EPREFIX@bin
- )
-
- LIST(APPEND CMAKE_PLATFORM_IMPLICIT_LINK_DIRECTORIES
-+ @GENTOO_PORTAGE_GCCLIBDIR@/gcc
-+ @GENTOO_PORTAGE_GCCLIBDIR@
-+ @GENTOO_PORTAGE_EPREFIX@usr/lib64
-+ @GENTOO_PORTAGE_EPREFIX@usr/lib32
-+ @GENTOO_PORTAGE_EPREFIX@usr/lib
-+ @GENTOO_PORTAGE_EPREFIX@lib
- /lib /usr/lib /usr/lib32 /usr/lib64
- )
-
- LIST(APPEND CMAKE_C_IMPLICIT_INCLUDE_DIRECTORIES
-+ @GENTOO_PORTAGE_EPREFIX@usr/include
- /usr/include
- )
- LIST(APPEND CMAKE_CXX_IMPLICIT_INCLUDE_DIRECTORIES
-+ @GENTOO_PORTAGE_EPREFIX@usr/include
- /usr/include
- )
-