summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKarl Trygve Kalleberg <karltk@gentoo.org>2002-04-24 20:29:01 +0000
committerKarl Trygve Kalleberg <karltk@gentoo.org>2002-04-24 20:29:01 +0000
commit097fa77e87dd07f2f6442a94680ff7cd8aaeb2c9 (patch)
treec7f7e672727e3326fb88e7447e68ecdc9a6d54e2 /dev-util
parentFixes #1719. (diff)
downloadgentoo-2-097fa77e87dd07f2f6442a94680ff7cd8aaeb2c9.tar.gz
gentoo-2-097fa77e87dd07f2f6442a94680ff7cd8aaeb2c9.tar.bz2
gentoo-2-097fa77e87dd07f2f6442a94680ff7cd8aaeb2c9.zip
Fixes #1547.
Diffstat (limited to 'dev-util')
-rw-r--r--dev-util/astyle/ChangeLog34
-rw-r--r--dev-util/astyle/astyle-1.15.3.ebuild23
-rw-r--r--dev-util/astyle/files/digest-astyle-1.15.31
3 files changed, 58 insertions, 0 deletions
diff --git a/dev-util/astyle/ChangeLog b/dev-util/astyle/ChangeLog
new file mode 100644
index 000000000000..d9dca5013632
--- /dev/null
+++ b/dev-util/astyle/ChangeLog
@@ -0,0 +1,34 @@
+# ChangeLog for dev-util/astyle
+# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL
+# $Header: /var/cvsroot/gentoo-x86/dev-util/astyle/ChangeLog,v 1.1 2002/04/24 20:29:01 karltk Exp $
+
+*astyle-0.15.3 (24 Apr 2002)
+
+ 24 Apr 2002; Karl Trygve Kalleberg <karltk@gentoo.org> astyle-1.15.3.ebuild files/digest/astyle-1.15.3 :
+
+ Artistic Style is a reindenter and reformatter of C++, C and Java source
+ code.
+
+ When indenting source code, we as programmers have a tendency to use both
+ spaces and tab characters to create the wanted indentation. Moreover, some
+ editors by default insert spaces instead of tabs when pressing the tab key,
+ and other editors (Emacs for example) have the ability to "pretty up" lines
+ by automatically setting up the white space before the code on the line,
+ possibly inserting spaces in a code that up to now used only tabs for
+ indentation.
+
+ Since the NUMBER of space characters showed on screen for each tab character
+ in the source code changes between editors (until the user sets up the
+ number to his liking...), one of the standard problems facing programmers
+ when moving from one source code editor to another is that code containing
+ both spaces and tabs that was up to now perfectly indented, suddenly becomes
+ a mess to look at when changing to another editor. Even if you as a
+ programmer take care to ONLY use spaces or tabs, looking at other peoples
+ source code can still be problematic.
+
+ To address this problem I have created Artistic Style - a series of filters,
+ written in C++, that automatically reindent & reformat C/C++/Java source
+ files. These can be used from a command line, or it can be incorporated as
+ classes in another C++ program.
+
+ Ebuild submitted by <eyez@infinite.fsw.leidenuniv.nl>.
diff --git a/dev-util/astyle/astyle-1.15.3.ebuild b/dev-util/astyle/astyle-1.15.3.ebuild
new file mode 100644
index 000000000000..527030ef8901
--- /dev/null
+++ b/dev-util/astyle/astyle-1.15.3.ebuild
@@ -0,0 +1,23 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Maintainer: Eyez <eyez@infinite.fsw.leidenuniv.nl>
+# $Header: /var/cvsroot/gentoo-x86/dev-util/astyle/astyle-1.15.3.ebuild,v 1.1 2002/04/24 20:29:01 karltk Exp $
+
+ZIP="astyle_${PV}.zip"
+S=${WORKDIR}
+DESCRIPTION="Artistic Style is a reindenter and reformatter of C++, C and Java
+source code."
+SRC_URI="http://prdownloads.sourceforge.net/astyle/${ZIP}"
+HOMEPAGE="http://astyle.sourceforge.net"
+DEPEND=">=app-arch/unzip-5.42"
+
+src_compile() {
+ emake || die
+}
+
+src_install () {
+ into /usr
+ dobin astyle
+ dohtml astyle.html astyle_release_notes.html license.html
+ dodoc INSTALL.TXT
+}
diff --git a/dev-util/astyle/files/digest-astyle-1.15.3 b/dev-util/astyle/files/digest-astyle-1.15.3
new file mode 100644
index 000000000000..ec517fbb7f79
--- /dev/null
+++ b/dev-util/astyle/files/digest-astyle-1.15.3
@@ -0,0 +1 @@
+MD5 4d8adbcd8703aea00fcd2670be090ddd astyle_1.15.3.zip 60880