summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSamuli Suominen <ssuominen@gentoo.org>2014-05-27 12:36:00 +0000
committerSamuli Suominen <ssuominen@gentoo.org>2014-05-27 12:36:00 +0000
commit8177c9642a7e942aacd26a8f5ec70c4ec76d84d9 (patch)
treea219cb2374010fefd7daa6795355fd23a411776b /dev-util/xxdiff
parentFix compilation against giflib-4.2 (bug 504772) (diff)
downloadgentoo-2-8177c9642a7e942aacd26a8f5ec70c4ec76d84d9.tar.gz
gentoo-2-8177c9642a7e942aacd26a8f5ec70c4ec76d84d9.tar.bz2
gentoo-2-8177c9642a7e942aacd26a8f5ec70c4ec76d84d9.zip
Restrict -r0 to <sys-devel/bison-3 and fix building in -r1 wrt #511560 by "zimous"
(Portage version: 2.2.10/cvs/Linux x86_64, signed Manifest commit with key 4868F14D)
Diffstat (limited to 'dev-util/xxdiff')
-rw-r--r--dev-util/xxdiff/ChangeLog12
-rw-r--r--dev-util/xxdiff/files/xxdiff-4.0_beta1_p20110426-bison3.patch100
-rw-r--r--dev-util/xxdiff/xxdiff-4.0_beta1_p20110426-r1.ebuild66
-rw-r--r--dev-util/xxdiff/xxdiff-4.0_beta1_p20110426.ebuild10
4 files changed, 182 insertions, 6 deletions
diff --git a/dev-util/xxdiff/ChangeLog b/dev-util/xxdiff/ChangeLog
index 9b9df2b3cd17..785a7c9a7608 100644
--- a/dev-util/xxdiff/ChangeLog
+++ b/dev-util/xxdiff/ChangeLog
@@ -1,6 +1,14 @@
# ChangeLog for dev-util/xxdiff
-# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-util/xxdiff/ChangeLog,v 1.61 2013/03/03 10:19:04 ssuominen Exp $
+# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-util/xxdiff/ChangeLog,v 1.62 2014/05/27 12:36:00 ssuominen Exp $
+
+*xxdiff-4.0_beta1_p20110426-r1 (27 May 2014)
+
+ 27 May 2014; Samuli Suominen <ssuominen@gentoo.org>
+ +files/xxdiff-4.0_beta1_p20110426-bison3.patch,
+ +xxdiff-4.0_beta1_p20110426-r1.ebuild, xxdiff-4.0_beta1_p20110426.ebuild:
+ Restrict -r0 to <sys-devel/bison-3 and fix building in -r1 wrt #511560 by
+ "zimous"
03 Mar 2013; Samuli Suominen <ssuominen@gentoo.org>
xxdiff-4.0_beta1_p20110426.ebuild:
diff --git a/dev-util/xxdiff/files/xxdiff-4.0_beta1_p20110426-bison3.patch b/dev-util/xxdiff/files/xxdiff-4.0_beta1_p20110426-bison3.patch
new file mode 100644
index 000000000000..fba71996b217
--- /dev/null
+++ b/dev-util/xxdiff/files/xxdiff-4.0_beta1_p20110426-bison3.patch
@@ -0,0 +1,100 @@
+http://bugs.gentoo.org/511560
+
+Description: Fix compilation with Bison 3
+YYPARSE_PARAM was deprecated in Bison 1.875 and removed in Bison 3;
+%parse-param can be used instead. Also fix a warning about %pure_parser
+Author: Florian Schlichting <fsfs@debian.org>
+
+--- a/src/resParser.y
++++ b/src/resParser.y
+@@ -39,12 +39,11 @@
+
+ // The parser input is the resources object to fill in.
+ #define RESOURCES ( static_cast<XxResources*>(resources) )
+-#define YYPARSE_PARAM resources
+
+ // Declare lexer from other compilation unit.
+ int resParserlex( YYSTYPE* yylval );
+
+-void resParsererror( const char* msg );
++void resParsererror( void *resources, const char* msg );
+
+ // Declare some parser functions and data defined in resParser.cpp
+ namespace XxResParserNS {
+@@ -58,6 +57,9 @@
+
+ %}
+
++/* The parser input is the resources object to fill in. */
++%parse-param { void *resources }
++
+ /* generate header file */
+ %defines
+
+@@ -144,7 +146,7 @@
+ %type <num> boolkwd
+
+ %start xxdiffrc
+-%pure_parser
++%pure-parser
+
+ %%
+ xxdiffrc : stmts
+@@ -188,7 +190,7 @@
+ RESOURCES->setPreferredGeometry( geometry );
+ }
+ else {
+- yyerror( "Bad geometry specification." );
++ yyerror( resources, "Bad geometry specification." );
+ // Should never happen, the lexer regexp should be tough
+ // enough.
+ }
+@@ -212,7 +214,7 @@
+ QString err = QString( "Requested style key does not exist." );
+ err += QString( "\nValid styles are: " );
+ err += styles.join( ", " );
+- yyerror( err.toLatin1().constData() );
++ yyerror( resources, err.toLatin1().constData() );
+ }
+ }
+ ;
+@@ -224,7 +226,7 @@
+ char buf[2048];
+ ::snprintf( buf, 2048,
+ "Unrecognized accelerator: %s\n", $5 );
+- yyerror( buf );
++ yyerror( resources, buf );
+ }
+ }
+ ;
+--- a/src/resParser.l
++++ b/src/resParser.l
+@@ -298,7 +298,7 @@
+ QString os;
+ QTextOStream oss( &os );
+ oss << "ignoring char: " << yytext << flush;
+- yyerror( os.latin1() );
++ yyerror( resources, os.latin1() );
+ */
+ }
+ }
+--- a/src/resParser.cpp
++++ b/src/resParser.cpp
+@@ -73,7 +73,7 @@
+
+ //------------------------------------------------------------------------------
+ //
+-void resParsererror( const char* msg )
++void resParsererror( void* resources __attribute__((__unused__)), const char* msg )
+ {
+ // Send errors to stdout so we can filter out the debug info shmeglu while
+ // debugging parser.
+@@ -794,7 +794,7 @@
+ QString os;
+ QTextStream oss( &os );
+ oss << "Unknown " << errmsg << ": " << name << flush;
+- resParsererror( os.toLatin1().constData() );
++ resParsererror( NULL, os.toLatin1().constData() );
+ }
+ num = ERROR_TOKEN;
+ return ERROR_TOKEN;
diff --git a/dev-util/xxdiff/xxdiff-4.0_beta1_p20110426-r1.ebuild b/dev-util/xxdiff/xxdiff-4.0_beta1_p20110426-r1.ebuild
new file mode 100644
index 000000000000..f54a832cbf66
--- /dev/null
+++ b/dev-util/xxdiff/xxdiff-4.0_beta1_p20110426-r1.ebuild
@@ -0,0 +1,66 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-util/xxdiff/xxdiff-4.0_beta1_p20110426-r1.ebuild,v 1.1 2014/05/27 12:36:00 ssuominen Exp $
+
+EAPI=5
+
+PYTHON_COMPAT=( python2_7 )
+
+inherit distutils-r1 eutils qt4-r2
+
+DESCRIPTION="A graphical file and directories comparator and merge tool"
+HOMEPAGE="http://furius.ca/xxdiff/"
+SRC_URI="mirror://gentoo/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="dev-qt/qtgui:4"
+DEPEND="${RDEPEND}
+ virtual/yacc"
+
+src_prepare() {
+ epatch \
+ "${FILESDIR}"/${P}-gcc47.patch \
+ "${FILESDIR}"/${P}-bison3.patch
+
+ pushd src >/dev/null
+ sed -i -e '/qPixmapFromMimeSource/d' *.ui || die #365019
+ qt4-r2_src_prepare
+ popd
+
+ distutils-r1_src_prepare
+}
+
+src_configure() {
+ pushd src >/dev/null
+ qt4-r2_src_configure
+ cat Makefile.extra >> Makefile
+ popd
+
+ distutils-r1_src_configure
+}
+
+src_compile() {
+ pushd src >/dev/null
+ qt4-r2_src_compile
+ popd
+
+ distutils-r1_src_compile
+}
+
+src_install() {
+ dobin bin/xxdiff
+
+ distutils-r1_src_install
+
+ dodoc CHANGES README* TODO doc/*.txt src/doc.txt
+
+ dohtml doc/*.{png,html} src/doc.html
+
+ # example tools, use these to build your own ones
+ insinto /usr/share/doc/${PF}
+ doins -r tools
+}
diff --git a/dev-util/xxdiff/xxdiff-4.0_beta1_p20110426.ebuild b/dev-util/xxdiff/xxdiff-4.0_beta1_p20110426.ebuild
index 1b252ff6b4df..99cdd9b7c849 100644
--- a/dev-util/xxdiff/xxdiff-4.0_beta1_p20110426.ebuild
+++ b/dev-util/xxdiff/xxdiff-4.0_beta1_p20110426.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2013 Gentoo Foundation
+# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-util/xxdiff/xxdiff-4.0_beta1_p20110426.ebuild,v 1.8 2013/03/03 10:19:04 ssuominen Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-util/xxdiff/xxdiff-4.0_beta1_p20110426.ebuild,v 1.9 2014/05/27 12:36:00 ssuominen Exp $
EAPI=5
@@ -17,8 +17,10 @@ SLOT="0"
KEYWORDS="amd64 x86"
IUSE=""
-RDEPEND="dev-qt/qtgui:4"
-DEPEND="${RDEPEND}"
+RDEPEND="dev-qt/qtgui:4
+ !>=sys-devel/bison-3"
+DEPEND="${RDEPEND}
+ virtual/yacc"
src_prepare() {
epatch "${FILESDIR}"/${P}-gcc47.patch