summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorStefan Jones <cretin@gentoo.org>2004-10-25 16:36:02 +0000
committerStefan Jones <cretin@gentoo.org>2004-10-25 16:36:02 +0000
commitd3667c4826e923c2b3543285f33e1cf9d2a8815f (patch)
treed4cd6e62f71f96f2ad9d0e602475ab12d949f6d9 /dev-util/xmingw-w32api
parentstable on alpha (Manifest recommit) (diff)
downloadgentoo-2-d3667c4826e923c2b3543285f33e1cf9d2a8815f.tar.gz
gentoo-2-d3667c4826e923c2b3543285f33e1cf9d2a8815f.tar.bz2
gentoo-2-d3667c4826e923c2b3543285f33e1cf9d2a8815f.zip
fix bootstrap
Diffstat (limited to 'dev-util/xmingw-w32api')
-rw-r--r--dev-util/xmingw-w32api/ChangeLog6
-rw-r--r--dev-util/xmingw-w32api/files/xmingw-w32api-3.1-include.patch15
-rw-r--r--dev-util/xmingw-w32api/xmingw-w32api-3.1.ebuild3
3 files changed, 22 insertions, 2 deletions
diff --git a/dev-util/xmingw-w32api/ChangeLog b/dev-util/xmingw-w32api/ChangeLog
index 9ac24a4fa6b1..ef1c90473a55 100644
--- a/dev-util/xmingw-w32api/ChangeLog
+++ b/dev-util/xmingw-w32api/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for dev-util/xmingw-w32api
# Copyright 2000-2004 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-util/xmingw-w32api/ChangeLog,v 1.7 2004/10/14 16:57:31 cretin Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-util/xmingw-w32api/ChangeLog,v 1.8 2004/10/25 16:36:02 cretin Exp $
+
+ 25 Oct 2004; Stefan Jones <cretin@gentoo.org>
+ +xmingw-w32api-3.1-include.patch :
+ Slight bug in the supplied makefile causing bootstrap to fail.
*xmingw-w32api-3.1 (14 Oct 2004)
diff --git a/dev-util/xmingw-w32api/files/xmingw-w32api-3.1-include.patch b/dev-util/xmingw-w32api/files/xmingw-w32api-3.1-include.patch
new file mode 100644
index 000000000000..a822f009db1a
--- /dev/null
+++ b/dev-util/xmingw-w32api/files/xmingw-w32api-3.1-include.patch
@@ -0,0 +1,15 @@
+--- w32api-3.1/lib/directx/Makefile.in.jj 2004-10-25 09:19:50.005482368 -0700
++++ w32api-3.1/lib/directx/Makefile.in 2004-10-25 09:26:41.038995776 -0700
+@@ -69,10 +69,10 @@
+ EXTRA_INCLUDES = -I$(srcdir)/../../include -I$(srcdir)/../../../newlib/libc/include -I$(srcdir)/../../../newlib/libc/sys/cygwin
+ endif
+ ifeq ($(BUILDENV), mingw)
+-EXTRA_INCLUDES = -I$(srcdir)/../../mingw/include
++EXTRA_INCLUDES = -I$(srcdir)/../../../mingw/include
+ endif
+
+-INCLUDES = -I$(srcdir)/../include -I$(srcdir)/../include/directx $(EXTRA_INCLUDES)
++INCLUDES = -I$(srcdir)/../../include -I$(srcdir)/../../include/directx $(EXTRA_INCLUDES)
+
+ CFLAGS = @CFLAGS@
+ ALL_CFLAGS = $(CFLAGS) $(INCLUDES)
diff --git a/dev-util/xmingw-w32api/xmingw-w32api-3.1.ebuild b/dev-util/xmingw-w32api/xmingw-w32api-3.1.ebuild
index ff378f4694f0..eff4c5b9914f 100644
--- a/dev-util/xmingw-w32api/xmingw-w32api-3.1.ebuild
+++ b/dev-util/xmingw-w32api/xmingw-w32api-3.1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-util/xmingw-w32api/xmingw-w32api-3.1.ebuild,v 1.1 2004/10/14 16:57:31 cretin Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-util/xmingw-w32api/xmingw-w32api-3.1.ebuild,v 1.2 2004/10/25 16:36:02 cretin Exp $
inherit eutils
@@ -26,6 +26,7 @@ src_unpack() {
unpack ${MY_P}-src.tar.gz
ln -s ${MY_P} w32api
ln -s ${RUNTIME} mingw
+ epatch ${FILESDIR}/xmingw-w32api-3.1-include.patch
}
src_compile() {