summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSamuli Suominen <ssuominen@gentoo.org>2012-09-05 16:41:05 +0000
committerSamuli Suominen <ssuominen@gentoo.org>2012-09-05 16:41:05 +0000
commitd1a0f8b3aebb9ca1a2cf823cdf6cc17057fef3ca (patch)
tree5ac72d57d36e4eaf0628151ab14730cf1ef8692d /dev-util/xdelta/xdelta-3.0.4.ebuild
parentVersion bump. (diff)
downloadgentoo-2-d1a0f8b3aebb9ca1a2cf823cdf6cc17057fef3ca.tar.gz
gentoo-2-d1a0f8b3aebb9ca1a2cf823cdf6cc17057fef3ca.tar.bz2
gentoo-2-d1a0f8b3aebb9ca1a2cf823cdf6cc17057fef3ca.zip
Version bump.
(Portage version: 2.2.0_alpha124/cvs/Linux x86_64)
Diffstat (limited to 'dev-util/xdelta/xdelta-3.0.4.ebuild')
-rw-r--r--dev-util/xdelta/xdelta-3.0.4.ebuild47
1 files changed, 47 insertions, 0 deletions
diff --git a/dev-util/xdelta/xdelta-3.0.4.ebuild b/dev-util/xdelta/xdelta-3.0.4.ebuild
new file mode 100644
index 000000000000..d95c5ffb0b95
--- /dev/null
+++ b/dev-util/xdelta/xdelta-3.0.4.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-util/xdelta/xdelta-3.0.4.ebuild,v 1.1 2012/09/05 16:41:05 ssuominen Exp $
+
+EAPI=4
+
+inherit python
+
+MY_P=${PN}${PV%.*.*}-${PV}
+
+DESCRIPTION="a binary diff and differential compression tools. VCDIFF (RFC 3284) delta compression."
+HOMEPAGE="http://xdelta.org/"
+SRC_URI="http://${PN}.googlecode.com/files/${MY_P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="3"
+KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE="examples test"
+
+RDEPEND="app-arch/xz-utils"
+DEPEND="${RDEPEND}
+ test? ( || ( dev-lang/python:2.7 dev-lang/python:2.6 ) )"
+
+S=${WORKDIR}/${MY_P}
+
+pkg_setup() {
+ python_set_active_version 2
+ python_pkg_setup
+}
+
+src_prepare() {
+ >py-compile
+
+ # huh
+ sed -i -e '/python/s:2.6:2:' testing/xdelta3-regtest.py || die
+ sed -i -e '/python/s:2.7:2:' testing/xdelta3-test.py || die
+}
+
+src_test() {
+ ./xdelta3regtest || die
+}
+
+src_install() {
+ emake DESTDIR="${D}" install
+ dodoc draft-korn-vcdiff.txt README
+ use examples && dodoc -r examples
+}