summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRob Cakebread <pythonhead@gentoo.org>2003-11-22 19:52:36 +0000
committerRob Cakebread <pythonhead@gentoo.org>2003-11-22 19:52:36 +0000
commit1157f8c8f2d585f3d1c5c73964a54fd985983f76 (patch)
tree99b96220b9eaad8268bbfa2a5027cc47324983de /dev-util/wxglade/wxglade-0.3.1.ebuild
parentInitial commit (diff)
downloadgentoo-2-1157f8c8f2d585f3d1c5c73964a54fd985983f76.tar.gz
gentoo-2-1157f8c8f2d585f3d1c5c73964a54fd985983f76.tar.bz2
gentoo-2-1157f8c8f2d585f3d1c5c73964a54fd985983f76.zip
Initial commit
Diffstat (limited to 'dev-util/wxglade/wxglade-0.3.1.ebuild')
-rw-r--r--dev-util/wxglade/wxglade-0.3.1.ebuild31
1 files changed, 31 insertions, 0 deletions
diff --git a/dev-util/wxglade/wxglade-0.3.1.ebuild b/dev-util/wxglade/wxglade-0.3.1.ebuild
new file mode 100644
index 000000000000..6235aca2e29e
--- /dev/null
+++ b/dev-util/wxglade/wxglade-0.3.1.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-util/wxglade/wxglade-0.3.1.ebuild,v 1.1 2003/11/22 19:52:29 pythonhead Exp $
+
+S="${WORKDIR}/wxGlade-${PV}"
+DESCRIPTION="Glade-like GUI designer which can generate Python C++ and XRC code"
+HOMEPAGE="http://wxglade.sourceforge.net/"
+SRC_URI="mirror://sourceforge/wxglade/wxGlade-${PV}.tgz"
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~x86"
+IUSE=""
+DEPEND=">=dev-python/wxPython-2.4.2.4"
+
+src_install() {
+ PY_VER=`python -c 'import sys;print sys.version[0:3]'`
+ dodir /usr/lib/python${PY_VER}/site-packages/${PN}
+ dodoc *txt
+ cp credits.txt ${D}/usr/lib/python${PY_VER}/site-packages/${PN}
+ rm *txt
+ dohtml -r docs/*
+ rm -rf docs
+ mv examples ${D}/usr/share/doc/${PF}
+ cp -R * ${D}/usr/lib/python${PY_VER}/site-packages/${PN}
+ echo "#!/bin/bash" > wxglade
+ echo "/usr/lib/python${PY_VER}/site-packages/${PN}/wxglade.py" >> wxglade
+ exeinto /usr/bin
+ doexe wxglade
+
+}
+