summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2004-06-28 20:05:55 +0000
committerMike Frysinger <vapier@gentoo.org>2004-06-28 20:05:55 +0000
commit62d4412177dcb4d41e38ce322c413d8c034ed07c (patch)
tree1869e69a6c3e4aaec70ff4155796c3ca0a4be300 /dev-util/wiggle/wiggle-0.6-r1.ebuild
parent0.7 stable on x86, QA: need-kde, newdepend (diff)
downloadgentoo-2-62d4412177dcb4d41e38ce322c413d8c034ed07c.tar.gz
gentoo-2-62d4412177dcb4d41e38ce322c413d8c034ed07c.tar.bz2
gentoo-2-62d4412177dcb4d41e38ce322c413d8c034ed07c.zip
dont depend on {text,file,sh-}utils
Diffstat (limited to 'dev-util/wiggle/wiggle-0.6-r1.ebuild')
-rw-r--r--dev-util/wiggle/wiggle-0.6-r1.ebuild38
1 files changed, 16 insertions, 22 deletions
diff --git a/dev-util/wiggle/wiggle-0.6-r1.ebuild b/dev-util/wiggle/wiggle-0.6-r1.ebuild
index 308417a1eb74..c3de832b7ad3 100644
--- a/dev-util/wiggle/wiggle-0.6-r1.ebuild
+++ b/dev-util/wiggle/wiggle-0.6-r1.ebuild
@@ -1,42 +1,37 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-util/wiggle/wiggle-0.6-r1.ebuild,v 1.1 2004/06/28 07:07:03 robbat2 Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-util/wiggle/wiggle-0.6-r1.ebuild,v 1.2 2004/06/28 20:05:55 vapier Exp $
inherit eutils
-IUSE=""
-
-S=${WORKDIR}/${P}
-
PATCHDATE=20040627
PATCHBALL=${P}-patches-${PATCHDATE}
-
-DESCRIPTION="Wiggle is a program for applying patches that patch cannot apply because of conflicting changes"
+DESCRIPTION="program for applying patches that patch cannot apply because of conflicting changes"
HOMEPAGE="http://cgi.cse.unsw.edu.au/~neilb/source/wiggle/"
SRC_URI="http://cgi.cse.unsw.edu.au/~neilb/source/wiggle/${P}.tar.gz
mirror://gentoo/${PATCHBALL}.tar.bz2"
-SLOT="0"
LICENSE="GPL-2"
+SLOT="0"
KEYWORDS="~x86"
+IUSE=""
# The 'p' tool does support bitkeeper, but I'm against just dumping it in here
# due to it's size. I've explictly listed every other dependancy here due to
# the nature of the shell program 'p'
RDEPEND="dev-util/diffstat
- dev-util/patchutils
- sys-apps/diffutils
- sys-apps/findutils
- sys-apps/gawk
- sys-apps/grep
- sys-apps/less
- sys-apps/sed
- sys-apps/coreutils
- sys-devel/patch"
-
+ dev-util/patchutils
+ sys-apps/diffutils
+ sys-apps/findutils
+ sys-apps/gawk
+ sys-apps/grep
+ sys-apps/less
+ sys-apps/sed
+ sys-apps/coreutils
+ sys-devel/patch"
DEPEND="${RDEPEND}
- sys-apps/groff
- sys-apps/time"
+ sys-apps/groff
+ sys-apps/time"
PATCHLIST="001NoQuietTime 002SpecFile 003Recommit 004ExtractFix 005Pchanges"
@@ -56,7 +51,6 @@ src_compile() {
src_install() {
make DESTDIR=${D} install || die
- into /usr
dobin p
- dodoc ANNOUNCE COPYING INSTALL TODO DOC/diff.ps p.help notes
+ dodoc ANNOUNCE INSTALL TODO DOC/diff.ps p.help notes
}