summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2008-07-02 21:46:00 +0000
committerMike Frysinger <vapier@gentoo.org>2008-07-02 21:46:00 +0000
commit4b36e1bafbb1e85716643cd7b0998340673e00fc (patch)
tree00b6ec6630f311a2ca104f451c3b710ebfebc6da /dev-util/w32api
parentbump to 2.22.3. Bug fixes and translation updates. (diff)
downloadgentoo-2-4b36e1bafbb1e85716643cd7b0998340673e00fc.tar.gz
gentoo-2-4b36e1bafbb1e85716643cd7b0998340673e00fc.tar.bz2
gentoo-2-4b36e1bafbb1e85716643cd7b0998340673e00fc.zip
old
Diffstat (limited to 'dev-util/w32api')
-rw-r--r--dev-util/w32api/w32api-3.10.ebuild63
-rw-r--r--dev-util/w32api/w32api-3.9.ebuild63
2 files changed, 0 insertions, 126 deletions
diff --git a/dev-util/w32api/w32api-3.10.ebuild b/dev-util/w32api/w32api-3.10.ebuild
deleted file mode 100644
index 0c30c4ec84ec..000000000000
--- a/dev-util/w32api/w32api-3.10.ebuild
+++ /dev/null
@@ -1,63 +0,0 @@
-# Copyright 1999-2007 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-util/w32api/w32api-3.10.ebuild,v 1.1 2007/10/06 22:37:07 vapier Exp $
-
-export CBUILD=${CBUILD:-${CHOST}}
-export CTARGET=${CTARGET:-${CHOST}}
-if [[ ${CTARGET} == ${CHOST} ]] ; then
- if [[ ${CATEGORY/cross-} != ${CATEGORY} ]] ; then
- export CTARGET=${CATEGORY/cross-}
- fi
-fi
-
-inherit eutils flag-o-matic
-
-DESCRIPTION="Free Win32 runtime and import library definitions"
-HOMEPAGE="http://www.mingw.org/"
-SRC_URI="mirror://sourceforge/mingw/${P}-src.tar.gz"
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="~amd64 ~ppc ~sparc ~x86"
-IUSE=""
-RESTRICT="strip"
-
-DEPEND=""
-
-just_headers() {
- use crosscompile_opts_headers-only && [[ ${CHOST} != ${CTARGET} ]]
-}
-
-pkg_setup() {
- if [[ ${CBUILD} == ${CHOST} ]] && [[ ${CHOST} == ${CTARGET} ]] ; then
- die "Invalid configuration; do not emerge this directly"
- fi
-}
-
-src_unpack() {
- unpack ${A}
- cd "${S}"
- epatch "${FILESDIR}"/${PN}-3.7-DESTDIR.patch
-}
-
-src_compile() {
- just_headers && return 0
-
- CHOST=${CTARGET} strip-unsupported-flags
- econf \
- --host=${CTARGET} \
- --prefix=/usr/${CTARGET}/usr \
- || die
- emake || die
-}
-
-src_install() {
- if just_headers ; then
- insinto /usr/${CTARGET}/usr/include
- doins -r include/* || die
- else
- emake install DESTDIR="${D}" || die
- env -uRESTRICT CHOST=${CTARGET} prepallstrip
- dodoc CONTRIBUTIONS ChangeLog README.w32api TODO
- fi
-}
diff --git a/dev-util/w32api/w32api-3.9.ebuild b/dev-util/w32api/w32api-3.9.ebuild
deleted file mode 100644
index 2ef4cc73aaac..000000000000
--- a/dev-util/w32api/w32api-3.9.ebuild
+++ /dev/null
@@ -1,63 +0,0 @@
-# Copyright 1999-2007 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-util/w32api/w32api-3.9.ebuild,v 1.2 2007/05/02 23:14:55 vapier Exp $
-
-export CBUILD=${CBUILD:-${CHOST}}
-export CTARGET=${CTARGET:-${CHOST}}
-if [[ ${CTARGET} == ${CHOST} ]] ; then
- if [[ ${CATEGORY/cross-} != ${CATEGORY} ]] ; then
- export CTARGET=${CATEGORY/cross-}
- fi
-fi
-
-inherit eutils flag-o-matic
-
-DESCRIPTION="Free Win32 runtime and import library definitions"
-HOMEPAGE="http://www.mingw.org/"
-SRC_URI="mirror://sourceforge/mingw/${P}-src.tar.gz"
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="~amd64 ~ppc ~sparc ~x86"
-IUSE=""
-RESTRICT="strip"
-
-DEPEND=""
-
-just_headers() {
- use crosscompile_opts_headers-only && [[ ${CHOST} != ${CTARGET} ]]
-}
-
-pkg_setup() {
- if [[ ${CBUILD} == ${CHOST} ]] && [[ ${CHOST} == ${CTARGET} ]] ; then
- die "Invalid configuration; do not emerge this directly"
- fi
-}
-
-src_unpack() {
- unpack ${A}
- cd "${S}"
- epatch "${FILESDIR}"/${PN}-3.7-DESTDIR.patch
-}
-
-src_compile() {
- just_headers && return 0
-
- CHOST=${CTARGET} strip-unsupported-flags
- econf \
- --host=${CTARGET} \
- --prefix=/usr/${CTARGET}/usr \
- || die
- emake || die
-}
-
-src_install() {
- if just_headers ; then
- insinto /usr/${CTARGET}/usr/include
- doins -r include/* || die
- else
- emake install DESTDIR="${D}" || die
- env -uRESTRICT CHOST=${CTARGET} prepallstrip
- dodoc CONTRIBUTIONS ChangeLog README.w32api TODO
- fi
-}