summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBruce A. Locke <blocke@gentoo.org>2002-10-23 04:31:13 +0000
committerBruce A. Locke <blocke@gentoo.org>2002-10-23 04:31:13 +0000
commit8caa16be5a9dad456c89c446573ef7242d223f57 (patch)
treed63493e1c10a00c19a9cdd6b41feeee7c75a53c3 /dev-util/valgrind
parentUnmasking ebuild for lesstif. (diff)
downloadgentoo-2-8caa16be5a9dad456c89c446573ef7242d223f57.tar.gz
gentoo-2-8caa16be5a9dad456c89c446573ef7242d223f57.tar.bz2
gentoo-2-8caa16be5a9dad456c89c446573ef7242d223f57.zip
valgrind version bump
Diffstat (limited to 'dev-util/valgrind')
-rw-r--r--dev-util/valgrind/ChangeLog7
-rw-r--r--dev-util/valgrind/files/digest-valgrind-1.0.42
-rw-r--r--dev-util/valgrind/valgrind-1.0.4.ebuild33
3 files changed, 41 insertions, 1 deletions
diff --git a/dev-util/valgrind/ChangeLog b/dev-util/valgrind/ChangeLog
index b04f7e4455ea..a502f2f37693 100644
--- a/dev-util/valgrind/ChangeLog
+++ b/dev-util/valgrind/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-util/valgrind
# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-util/valgrind/ChangeLog,v 1.2 2002/09/29 19:47:47 blocke Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-util/valgrind/ChangeLog,v 1.3 2002/10/23 04:31:13 blocke Exp $
+
+*valgrind-1.0.4 (23 Oct 2002)
+
+ 23 Oct 2002; Bruce A. Locke <blocke@shivan.org> valgrind-1.0.4.ebuild:
+ Version bump with gcc 3.1+ fixes mentioned on the upstream website.
*valgrind-1.0.3 (29 Sep 2002)
diff --git a/dev-util/valgrind/files/digest-valgrind-1.0.4 b/dev-util/valgrind/files/digest-valgrind-1.0.4
new file mode 100644
index 000000000000..1a34abc5353c
--- /dev/null
+++ b/dev-util/valgrind/files/digest-valgrind-1.0.4
@@ -0,0 +1,2 @@
+MD5 48d15c066d3deec519f9db2fce8041bf valgrind-1.0.4.tar.bz2 484137
+MD5 ab2b65ea232c5f2566988c6023f80f4e valgrind-1.0.3-gcc3.1-and-above-patch1.txt 1861
diff --git a/dev-util/valgrind/valgrind-1.0.4.ebuild b/dev-util/valgrind/valgrind-1.0.4.ebuild
new file mode 100644
index 000000000000..30b5c445bbdb
--- /dev/null
+++ b/dev-util/valgrind/valgrind-1.0.4.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-util/valgrind/valgrind-1.0.4.ebuild,v 1.1 2002/10/23 04:31:13 blocke Exp $
+
+IUSE="X"
+
+S=${WORKDIR}/${P}
+DESCRIPTION="An open-source memory debugger for x86-GNU/Linux"
+HOMEPAGE="http://developer.kde.org/~sewardj"
+SRC_URI="http://developer.kde.org/~sewardj/${P}.tar.bz2"
+DEPEND="virtual/glibc
+ X? ( virtual/x11 )"
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86 -sparc -sparc64 -ppc -alpha"
+
+src_compile()
+{
+ local myconf
+
+ use X && myconf="--with-x" || myconf="--with-x=no"
+
+ # note: it does not appear safe to play with CFLAGS
+ econf ${myconf} || die
+ emake || die
+}
+
+src_install()
+{
+ einstall docdir="${D}/usr/share/doc/${PF}" || die
+ dodoc README* COPYING ChangeLog TODO ACKNOWLEDGEMENTS AUTHORS NEWS
+}
+