summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBruce A. Locke <blocke@gentoo.org>2002-09-29 19:47:47 +0000
committerBruce A. Locke <blocke@gentoo.org>2002-09-29 19:47:47 +0000
commit8b99d84358199bfb7f363b15fb3910a4259131ee (patch)
tree51589d4ac0de856fdf72cacb102a33a2c86b33f0 /dev-util/valgrind
parentversion bump and placement of example config files into doc directory (diff)
downloadgentoo-2-8b99d84358199bfb7f363b15fb3910a4259131ee.tar.gz
gentoo-2-8b99d84358199bfb7f363b15fb3910a4259131ee.tar.bz2
gentoo-2-8b99d84358199bfb7f363b15fb3910a4259131ee.zip
version bump and possible gcc 3.2 upstream fix
Diffstat (limited to 'dev-util/valgrind')
-rw-r--r--dev-util/valgrind/ChangeLog8
-rw-r--r--dev-util/valgrind/files/digest-valgrind-1.0.32
-rw-r--r--dev-util/valgrind/valgrind-1.0.3.ebuild40
3 files changed, 48 insertions, 2 deletions
diff --git a/dev-util/valgrind/ChangeLog b/dev-util/valgrind/ChangeLog
index 40af088beae7..b04f7e4455ea 100644
--- a/dev-util/valgrind/ChangeLog
+++ b/dev-util/valgrind/ChangeLog
@@ -1,11 +1,15 @@
# ChangeLog for dev-util/valgrind
# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-util/valgrind/ChangeLog,v 1.1 2002/08/03 04:40:34 blocke Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-util/valgrind/ChangeLog,v 1.2 2002/09/29 19:47:47 blocke Exp $
+
+*valgrind-1.0.3 (29 Sep 2002)
+
+ 29 Sep 2002; Bruce A. Locke <blocke@shivan.org> valgrind-1.0.3.ebuild:
+ Version bump and possible upstream gcc 3.2 fix
*valgrind-1.0.0 (03 Aug 2002)
03 Aug 2002; Bruce A. Locke <blocke@shivan.org> valgrind-1.0.0.ebuild, files/digest-valgrind-1.0.0:
-
Initial ebuild based on contribution from mattam@netcourrier.com
(Matthieu Sozeau) and vapier@netzero.com (SpanKY)
diff --git a/dev-util/valgrind/files/digest-valgrind-1.0.3 b/dev-util/valgrind/files/digest-valgrind-1.0.3
new file mode 100644
index 000000000000..838d5bb077fd
--- /dev/null
+++ b/dev-util/valgrind/files/digest-valgrind-1.0.3
@@ -0,0 +1,2 @@
+MD5 30a921ff912ae3d7af27a64879f503e2 valgrind-1.0.3.tar.bz2 478143
+MD5 ab2b65ea232c5f2566988c6023f80f4e valgrind-1.0.3-gcc3.1-and-above-patch1.txt 1861
diff --git a/dev-util/valgrind/valgrind-1.0.3.ebuild b/dev-util/valgrind/valgrind-1.0.3.ebuild
new file mode 100644
index 000000000000..5a6173f1e369
--- /dev/null
+++ b/dev-util/valgrind/valgrind-1.0.3.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# $Header: /var/cvsroot/gentoo-x86/dev-util/valgrind/valgrind-1.0.3.ebuild,v 1.1 2002/09/29 19:47:47 blocke Exp $
+
+S=${WORKDIR}/${P}
+DESCRIPTION="An open-source memory debugger for x86-GNU/Linux"
+HOMEPAGE="http://developer.kde.org/~sewardj"
+SRC_URI="http://developer.kde.org/~sewardj/${P}.tar.bz2
+ http://developer.kde.org/~sewardj/valgrind-1.0.3-gcc3.1-and-above-patch1.txt"
+DEPEND="virtual/glibc
+ X? ( virtual/x11 )"
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="x86 -sparc -sparc64 -ppc -alpha"
+
+src_unpack()
+{
+ unpack ${P}.tar.bz2
+
+ cd ${S}
+ patch -p1 < ${DISTDIR}/valgrind-1.0.3-gcc3.1-and-above-patch1.txt
+}
+
+src_compile()
+{
+ local myconf
+
+ use X && myconf="--with-x" || myconf="--with-x=no"
+
+ # note: it does not appear safe to play with CFLAGS
+ econf ${myconf} || die
+ emake || die
+}
+
+src_install()
+{
+ einstall docdir="${D}/usr/share/doc/${PF}" || die
+ dodoc README* COPYING ChangeLog TODO ACKNOWLEDGEMENTS AUTHORS NEWS
+}
+