summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRyan Phillips <rphillips@gentoo.org>2005-07-06 20:40:46 +0000
committerRyan Phillips <rphillips@gentoo.org>2005-07-06 20:40:46 +0000
commit18f74c581d9a66f33dc1601c71653ca093d3e759 (patch)
tree9ee339c1f2624d9fbf912063282fbd70e6ac7eaf /dev-util/tla/tla-1.3.3-r1.ebuild
parentadd IUSE=doc (diff)
downloadgentoo-2-18f74c581d9a66f33dc1601c71653ca093d3e759.tar.gz
gentoo-2-18f74c581d9a66f33dc1601c71653ca093d3e759.tar.bz2
gentoo-2-18f74c581d9a66f33dc1601c71653ca093d3e759.zip
Added Matteo Settenvini's changes for installing documentation. #94391
(Portage version: 2.0.51.22-r1)
Diffstat (limited to 'dev-util/tla/tla-1.3.3-r1.ebuild')
-rw-r--r--dev-util/tla/tla-1.3.3-r1.ebuild68
1 files changed, 68 insertions, 0 deletions
diff --git a/dev-util/tla/tla-1.3.3-r1.ebuild b/dev-util/tla/tla-1.3.3-r1.ebuild
new file mode 100644
index 000000000000..e955e21bd1e0
--- /dev/null
+++ b/dev-util/tla/tla-1.3.3-r1.ebuild
@@ -0,0 +1,68 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-util/tla/tla-1.3.3-r1.ebuild,v 1.1 2005/07/06 20:40:46 rphillips Exp $
+
+S="${WORKDIR}/${P}/src/=build"
+DESCRIPTION="Revision control system ideal for widely distributed development"
+SRC_URI="mirror://gnu/gnu-arch/${P}.tar.gz
+ http://dev.gentoo.org/~arj/tla.1-2.gz"
+HOMEPAGE="http://savannah.gnu.org/projects/gnu-arch http://wiki.gnuarch.org/ http://arch.quackerhead.com/~lord/"
+
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="~x86 ~alpha ~ppc ~hppa ~sparc ~amd64"
+IUSE="doc"
+
+DEPEND="sys-apps/coreutils
+ sys-apps/diffutils
+ sys-devel/patch
+ sys-apps/findutils
+ sys-apps/gawk
+ app-arch/tar
+ sys-apps/util-linux
+ sys-apps/debianutils
+ sys-devel/make"
+
+src_unpack() {
+ unpack ${P}.tar.gz
+ unpack tla.1-2.gz
+ mkdir "${S}"
+ cd "${WORKDIR}/${P}"
+ sed -i 's:/home/lord/{install}:/usr:g' "${WORKDIR}/${P}/src/tla/=gpg-check.awk"
+}
+
+src_compile() {
+ ../configure \
+ --prefix="/usr" \
+ --with-posix-shell="/bin/bash" || die "configure failed"
+ # parallel make may cause problems with this package
+ make || die "make failed"
+}
+
+src_install () {
+ make install prefix="${D}/usr" \
+ || die "make install failed"
+
+ cd ${S}/..
+ dodoc COPYING
+ dodoc ChangeLog
+
+ if use doc; then
+ cd docs-tla
+ docinto html
+ dohtml -r .
+
+ cd ../docs-hackerlab
+ docinto hackerlab/html
+ dohtml html/*
+ docinto hackerlab/ps
+ dodoc ps/*
+ fi
+
+ cd ${WORKDIR}
+ mv tla.1-2 tla.1
+ doman tla.1
+
+ chmod 755 "${WORKDIR}/${P}/src/tla/=gpg-check.awk"
+ cp -a "${WORKDIR}/${P}/src/tla/=gpg-check.awk" "${D}/usr/bin/tla-gpg-check.awk"
+}