summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarkos Chandras <hwoarang@gentoo.org>2011-02-22 16:58:11 +0000
committerMarkos Chandras <hwoarang@gentoo.org>2011-02-22 16:58:11 +0000
commit4b1d609a72343891d036e9b39b532eb4248a4d29 (patch)
tree5f9ced4dc4c2b0c3a14e00f9c840f7b0fba516c2 /dev-util/ticpp
parentMoved from sunrise overlay. Initial ebuild from Patrick Zimmermann (moHiJ) <p... (diff)
downloadgentoo-2-4b1d609a72343891d036e9b39b532eb4248a4d29.tar.gz
gentoo-2-4b1d609a72343891d036e9b39b532eb4248a4d29.tar.bz2
gentoo-2-4b1d609a72343891d036e9b39b532eb4248a4d29.zip
Moved from sunrise. Initial ebuild from Patrick Zimmermann (moHiJ) <patrick@zakweb.de>. Bug #169802
(Portage version: 2.2.0_alpha24/cvs/Linux x86_64)
Diffstat (limited to 'dev-util/ticpp')
-rw-r--r--dev-util/ticpp/ChangeLog12
-rw-r--r--dev-util/ticpp/metadata.xml12
-rw-r--r--dev-util/ticpp/ticpp-0_p20100924.ebuild51
-rw-r--r--dev-util/ticpp/ticpp-9999.ebuild57
4 files changed, 132 insertions, 0 deletions
diff --git a/dev-util/ticpp/ChangeLog b/dev-util/ticpp/ChangeLog
new file mode 100644
index 000000000000..c26ff6ebf902
--- /dev/null
+++ b/dev-util/ticpp/ChangeLog
@@ -0,0 +1,12 @@
+# ChangeLog for dev-util/ticpp
+# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-util/ticpp/ChangeLog,v 1.1 2011/02/22 16:58:11 hwoarang Exp $
+
+*ticpp-9999 (22 Feb 2011)
+*ticpp-0_p20100924 (22 Feb 2011)
+
+ 22 Feb 2011; Markos Chandras <hwoarang@gentoo.org> +ticpp-0_p20100924.ebuild,
+ +ticpp-9999.ebuild, +metadata.xml:
+ Moved from sunrise. Initial ebuild from Patrick Zimmermann (moHiJ)
+ <patrick@zakweb.de>. Bug #169802
+
diff --git a/dev-util/ticpp/metadata.xml b/dev-util/ticpp/metadata.xml
new file mode 100644
index 000000000000..87afd6e36004
--- /dev/null
+++ b/dev-util/ticpp/metadata.xml
@@ -0,0 +1,12 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>no-herd</herd>
+<maintainer>
+<email>hwoarang@gentoo.org</email>
+<name>Markos Chandras</name>
+</maintainer>
+<longdescription lang="en">
+</longdescription>
+</pkgmetadata>
+
diff --git a/dev-util/ticpp/ticpp-0_p20100924.ebuild b/dev-util/ticpp/ticpp-0_p20100924.ebuild
new file mode 100644
index 000000000000..713900d07227
--- /dev/null
+++ b/dev-util/ticpp/ticpp-0_p20100924.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-util/ticpp/ticpp-0_p20100924.ebuild,v 1.1 2011/02/22 16:58:11 hwoarang Exp $
+
+DESCRIPTION="A completely new interface to TinyXML that uses MANY of the C++ strengths"
+HOMEPAGE="http://code.google.com/p/ticpp/"
+SRC_URI="http://sulmonalug.it/files/mrfree/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+KEYWORDS="~amd64"
+SLOT="0"
+IUSE="debug doc"
+
+DEPEND="dev-util/premake
+ doc? ( app-doc/doxygen sys-apps/sed )"
+RDEPEND=""
+
+src_compile() {
+ local myconf
+
+ premake --target gnu || die "creating Makefile failed"
+
+ if use !debug ; then
+ myconf="CONFIG=Release"
+ fi
+
+ emake ${myconf} || die "emake failed"
+
+ if use doc ; then
+ sed -i -e '/GENERATE_HTMLHELP/s:YES:NO:' dox || die "sed failed"
+ doxygen dox || die "doxygen failed"
+ fi
+}
+
+src_install () {
+ insinto /usr/include/ticpp
+ doins *.h || die "installing headers failed"
+
+ if use debug ; then
+ dolib ../lib/libticppd.a || die "installing library failed"
+ else
+ dolib ../lib/libticpp.a || die "installing library failed"
+ fi
+
+ dodoc {changes,readme,tutorial_gettingStarted,tutorial_ticpp}.txt || \
+ die "dodoc failed"
+
+ if use doc ; then
+ dohtml -r docs/* || die "installing docs failed"
+ fi
+}
diff --git a/dev-util/ticpp/ticpp-9999.ebuild b/dev-util/ticpp/ticpp-9999.ebuild
new file mode 100644
index 000000000000..9c0a4bd5f5e5
--- /dev/null
+++ b/dev-util/ticpp/ticpp-9999.ebuild
@@ -0,0 +1,57 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-util/ticpp/ticpp-9999.ebuild,v 1.1 2011/02/22 16:58:11 hwoarang Exp $
+
+ESVN_REPO_URI="http://ticpp.googlecode.com/svn/trunk/"
+inherit subversion
+
+MY_PV=cvs
+DESCRIPTION="A completely new interface to TinyXML that uses MANY of the C++ strengths"
+HOMEPAGE="http://code.google.com/p/ticpp/"
+SRC_URI=""
+
+LICENSE="GPL-2"
+KEYWORDS=""
+SLOT="0"
+IUSE="debug doc"
+
+DEPEND="dev-util/premake
+ doc? ( app-doc/doxygen sys-apps/sed )"
+RDEPEND=""
+
+S=${WORKDIR}/${PN}
+
+src_compile() {
+ local myconf
+
+ premake --target gnu || die "creating Makefile failed"
+
+ if use !debug ; then
+ myconf="CONFIG=Release"
+ fi
+
+ emake ${myconf} || die "emake failed"
+
+ if use doc ; then
+ sed -i -e '/GENERATE_HTMLHELP/s:YES:NO:' dox || die "sed failed"
+ doxygen dox || die "doxygen failed"
+ fi
+}
+
+src_install () {
+ insinto /usr/include/ticpp
+ doins *.h || die "installing headers failed"
+
+ if use debug ; then
+ dolib libticppd.a || die "installing library failed"
+ else
+ dolib libticpp.a || die "installing library failed"
+ fi
+
+ dodoc {changes,readme,tutorial_gettingStarted,tutorial_ticpp}.txt || \
+ die "dodoc failed"
+
+ if use doc ; then
+ dohtml -r docs/* || die "installing docs failed"
+ fi
+}