summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAaron Walker <ka0ttic@gentoo.org>2005-10-03 12:49:55 +0000
committerAaron Walker <ka0ttic@gentoo.org>2005-10-03 12:49:55 +0000
commit87c3f1b3f176ee5367e09f71229abc93798a26a0 (patch)
tree8c263fd2b56d060d362f68047f463b51b6a61230 /dev-util/svn2cl/svn2cl-0.3.ebuild
parentMark 1.58 stable on ia64 (diff)
downloadgentoo-2-87c3f1b3f176ee5367e09f71229abc93798a26a0.tar.gz
gentoo-2-87c3f1b3f176ee5367e09f71229abc93798a26a0.tar.bz2
gentoo-2-87c3f1b3f176ee5367e09f71229abc93798a26a0.zip
Initial commit.
(Portage version: 2.0.53_rc3)
Diffstat (limited to 'dev-util/svn2cl/svn2cl-0.3.ebuild')
-rw-r--r--dev-util/svn2cl/svn2cl-0.3.ebuild32
1 files changed, 32 insertions, 0 deletions
diff --git a/dev-util/svn2cl/svn2cl-0.3.ebuild b/dev-util/svn2cl/svn2cl-0.3.ebuild
new file mode 100644
index 000000000000..44aff60373e5
--- /dev/null
+++ b/dev-util/svn2cl/svn2cl-0.3.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-util/svn2cl/svn2cl-0.3.ebuild,v 1.1 2005/10/03 12:49:55 ka0ttic Exp $
+
+inherit eutils
+
+DESCRIPTION="Create a GNU-style ChangeLog from subversion's svn log --xml output."
+HOMEPAGE="http://ch.tudelft.nl/~arthur/svn2cl/"
+SRC_URI="${HOMEPAGE}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~x86 ~mips"
+IUSE=""
+
+RDEPEND="dev-libs/libxslt
+ dev-util/subversion"
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+ # the wrapper script looks for the xsl file in the
+ # same directory as the script.
+ epatch ${FILESDIR}/${PN}-no-same-dir-xsl.diff
+}
+
+src_install() {
+ newbin svn2cl.sh svn2cl || die "failed to install wrapper script"
+ insinto /usr/share/svn2cl
+ doins svn2cl.xsl || die "failed to install xsl"
+ dodoc README
+}