summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPaul de Vrieze <pauldv@gentoo.org>2006-03-10 08:55:10 +0000
committerPaul de Vrieze <pauldv@gentoo.org>2006-03-10 08:55:10 +0000
commit8c09213c7cf962eeccf6a8adc976f3f8af0c7808 (patch)
tree42a154b06fb92048758f5e210237aa1fa8200ed8 /dev-util/subversion/files
parentRe-add old USE flags for old version still in the tree for a few more days (diff)
downloadgentoo-2-8c09213c7cf962eeccf6a8adc976f3f8af0c7808.tar.gz
gentoo-2-8c09213c7cf962eeccf6a8adc976f3f8af0c7808.tar.bz2
gentoo-2-8c09213c7cf962eeccf6a8adc976f3f8af0c7808.zip
Don't fail when neon wasn't requested
(Portage version: 2.1_pre5-r4)
Diffstat (limited to 'dev-util/subversion/files')
-rw-r--r--dev-util/subversion/files/subversion-neon-config.patch45
1 files changed, 35 insertions, 10 deletions
diff --git a/dev-util/subversion/files/subversion-neon-config.patch b/dev-util/subversion/files/subversion-neon-config.patch
index 56b7054488b3..bb25adc8528e 100644
--- a/dev-util/subversion/files/subversion-neon-config.patch
+++ b/dev-util/subversion/files/subversion-neon-config.patch
@@ -1,13 +1,3 @@
---- subversion-1.3.0/build/ac-macros/neon.m4.orig 2006-02-21 21:25:07.000000000 +0100
-+++ subversion-1.3.0/build/ac-macros/neon.m4 2006-02-21 21:26:07.000000000 +0100
-@@ -174,6 +174,6 @@
- echo "unpack the archive using tar/gunzip and rename the resulting"
- echo "directory from ./neon-${NEON_LATEST_WORKING_VER}/ to ./neon/"
- echo ""
-- AC_MSG_RESULT([no suitable neon found])
-+ AC_MSG_FAILURE([no suitable neon found])
- svn_lib_neon="no"
- ])
--- subversion-1.3.0/configure.in.orig 2006-02-21 21:51:41.000000000 +0100
+++ subversion-1.3.0/configure.in 2006-02-21 21:52:08.000000000 +0100
@@ -227,8 +227,8 @@
@@ -21,3 +11,38 @@
NEON_URL="http://www.webdav.org/neon/neon-${NEON_LATEST_WORKING_VER}.tar.gz"
dnl You can skip the neon version check only if you know what you are doing
AC_ARG_ENABLE(neon-version-check,
+--- subversion-1.3.0/build/ac-macros/neon.m4.orig 2006-02-27 16:13:32.000000000 +0100
++++ subversion-1.3.0/build/ac-macros/neon.m4 2006-02-27 16:19:34.000000000 +0100
+@@ -142,7 +142,7 @@
+ if test -z $svn_allowed_neon_on_system; then
+ echo "You have neon version $NEON_VERSION,"
+ echo "but Subversion needs neon $NEON_LATEST_WORKING_VER."
+- SVN_DOWNLOAD_NEON()
++ SVN_DOWNLOAD_NEONFAIL()
+ fi
+
+ else
+@@ -177,3 +177,23 @@
+ AC_MSG_RESULT([no suitable neon found])
+ svn_lib_neon="no"
+ ])
++
++dnl SVN_DOWNLOAD_NEONFAIL()
++dnl no neon found, print out a message telling the user what to do
++AC_DEFUN(SVN_DOWNLOAD_NEONFAIL,
++[
++ echo ""
++ echo "An appropriate version of neon could not be found, so libsvn_ra_dav"
++ echo "will not be built. If you want to build libsvn_ra_dav, please either"
++ echo "install neon ${NEON_LATEST_WORKING_VER} on this system"
++ echo ""
++ echo "or"
++ echo ""
++ echo "get neon ${NEON_LATEST_WORKING_VER} from:"
++ echo " ${NEON_URL}"
++ echo "unpack the archive using tar/gunzip and rename the resulting"
++ echo "directory from ./neon-${NEON_LATEST_WORKING_VER}/ to ./neon/"
++ echo ""
++ AC_MSG_FAILURE([no suitable neon found])
++ svn_lib_neon="no"
++])