summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2009-09-19 15:16:56 +0000
committerMike Frysinger <vapier@gentoo.org>2009-09-19 15:16:56 +0000
commitd54705b092f06f61b1d9e0406d85b70521bc1246 (patch)
tree09513e627b0356836094c85445d5ca0b0f823f5b /dev-util/strace
parentamd64/x86 stable, bug #284306 (diff)
downloadgentoo-2-d54705b092f06f61b1d9e0406d85b70521bc1246.tar.gz
gentoo-2-d54705b092f06f61b1d9e0406d85b70521bc1246.tar.bz2
gentoo-2-d54705b092f06f61b1d9e0406d85b70521bc1246.zip
old
(Portage version: 2.2_rc40/cvs/Linux x86_64)
Diffstat (limited to 'dev-util/strace')
-rw-r--r--dev-util/strace/files/strace-4.5.12-quota.patch89
-rw-r--r--dev-util/strace/files/strace-4.5.12-superh-update.patch24
-rw-r--r--dev-util/strace/files/strace-4.5.14-CTL_PROC.patch17
-rw-r--r--dev-util/strace/files/strace-4.5.15-sh-SYS_ipc_subcall.patch15
-rw-r--r--dev-util/strace/files/strace-4.5.8-ia64.patch97
-rw-r--r--dev-util/strace/files/strace-dont-use-REG_SYSCALL-for-sh.patch10
-rw-r--r--dev-util/strace/files/strace-superh-update.patch28
-rw-r--r--dev-util/strace/files/strace-undef-syscall.patch15
-rw-r--r--dev-util/strace/strace-4.5.12.ebuild72
-rw-r--r--dev-util/strace/strace-4.5.16.ebuild46
10 files changed, 0 insertions, 413 deletions
diff --git a/dev-util/strace/files/strace-4.5.12-quota.patch b/dev-util/strace/files/strace-4.5.12-quota.patch
deleted file mode 100644
index 161d0fc45e66..000000000000
--- a/dev-util/strace/files/strace-4.5.12-quota.patch
+++ /dev/null
@@ -1,89 +0,0 @@
-Changes from upstream cvs to fix breakage with newer glibc's
-
-http://bugs.gentoo.org/102080
-
---- strace-4.5.12/configure.ac
-+++ strace-4.5.12/configure.ac
-@@ -216,6 +216,8 @@
-
- AC_CHECK_TYPES([struct user_desc],,, [#include <asm/ldt.h>])
-
-+AC_CHECK_MEMBERS([struct dqblk.dqb_curblocks],,, [#include <sys/quota.h>])
-+
- AC_CHECK_DECLS([sys_errlist])
- AC_CHECK_DECLS([sys_siglist, _sys_siglist],,, [#include <signal.h>])
-
---- strace-4.5.12/resource.c
-+++ strace-4.5.12/resource.c
-@@ -464,6 +464,7 @@
-
- #ifdef LINUX
-
-+#define OLD_CMD(c) ((c)<<8)
- #define NEW_CMD(c) ((0x80<<16)+(c))
- #define XQM_CMD(c) (('X'<<8)+(c))
- #define NEW_COMMAND(c) (( ((c) >> SUBCMDSHIFT) & (0x80 << 16)))
-@@ -471,15 +472,15 @@
- #define OLD_COMMAND(c) (!NEW_COMMAND(c) && !XQM_COMMAND(c))
-
- static const struct xlat quotacmds[] = {
-- { Q_QUOTAON, "Q_QUOTAON" },
-- { Q_QUOTAOFF, "Q_QUOTAOFF" },
-- { Q_GETQUOTA, "Q_GETQUOTA" },
-- { Q_SETQUOTA, "Q_SETQUOTA" },
-- { Q_SETUSE, "Q_SETUSE" },
-- { Q_SYNC, "Q_SYNC" },
-- { Q_SETQLIM, "Q_SETQLIM" },
-- { Q_GETSTATS, "Q_GETSTATS" },
-- { Q_RSQUASH, "Q_RSQUASH" },
-+ { OLD_CMD(0x1), "Q_QUOTAON" },
-+ { OLD_CMD(0x2), "Q_QUOTAOFF" },
-+ { OLD_CMD(0x3), "Q_GETQUOTA" },
-+ { OLD_CMD(0x4), "Q_SETQUOTA" },
-+ { OLD_CMD(0x5), "Q_SETUSE" },
-+ { OLD_CMD(0x6), "Q_SYNC" },
-+ { OLD_CMD(0x7), "Q_SETQLIM" },
-+ { OLD_CMD(0x8), "Q_GETSTATS" },
-+ { OLD_CMD(0x10),"Q_RSQUASH" },
- { NEW_CMD(0x1), "Q_SYNC" },
- { NEW_CMD(0x2), "Q_QUOTAON" },
- { NEW_CMD(0x3), "Q_QUOTAOFF" },
-@@ -528,21 +529,29 @@
-
- if (!tcp->u_arg[3])
- tprintf("NULL");
-- else if (!verbose(tcp) || !OLD_COMMAND(cmd))
-+ else if (!verbose(tcp) ||
-+#ifdef HAVE_STRUCT_DQBLK_DQB_CURBLOCKS
-+ !
-+#endif
-+ OLD_COMMAND(cmd))
- tprintf("%#lx", tcp->u_arg[3]);
- else if (umoven(tcp, tcp->u_arg[3], sizeof(struct dqblk),
- (char *) &dq) < 0)
- tprintf("???");
- else {
- tprintf("{");
-- tprintf("%u, ", dq.dqb_bhardlimit);
-- tprintf("%u, ", dq.dqb_bsoftlimit);
-- tprintf("%u, ", dq.dqb_curblocks);
-- tprintf("%u, ", dq.dqb_ihardlimit);
-- tprintf("%u, ", dq.dqb_isoftlimit);
-- tprintf("%u, ", dq.dqb_curinodes);
-- tprintf("%lu, ", dq.dqb_btime);
-- tprintf("%lu", dq.dqb_itime);
-+ tprintf("%llu, ", (unsigned long long) dq.dqb_bhardlimit);
-+ tprintf("%llu, ", (unsigned long long) dq.dqb_bsoftlimit);
-+#ifdef HAVE_STRUCT_DQBLK_DQB_CURBLOCKS
-+ tprintf("%llu, ", (unsigned long long) dq.dqb_curblocks);
-+#else
-+ tprintf("%llu, ", (unsigned long long) dq.dqb_curspace);
-+#endif
-+ tprintf("%llu, ", (unsigned long long) dq.dqb_ihardlimit);
-+ tprintf("%llu, ", (unsigned long long) dq.dqb_isoftlimit);
-+ tprintf("%llu, ", (unsigned long long) dq.dqb_curinodes);
-+ tprintf("%llu, ", (unsigned long long) dq.dqb_btime);
-+ tprintf("%llu", (unsigned long long) dq.dqb_itime);
- tprintf("}");
- }
-
diff --git a/dev-util/strace/files/strace-4.5.12-superh-update.patch b/dev-util/strace/files/strace-4.5.12-superh-update.patch
deleted file mode 100644
index d402997c1278..000000000000
--- a/dev-util/strace/files/strace-4.5.12-superh-update.patch
+++ /dev/null
@@ -1,24 +0,0 @@
-Fix configure script to work with targets like 'sh4-unknown-linux-gnu'
-
---- configure.ac
-+++ configure.ac
-@@ -91,14 +91,14 @@
- arch=hppa
- AC_DEFINE([HPPA], 1, [Define for the HPPA architecture.])
- ;;
--sh)
-- arch=sh
-- AC_DEFINE([SH], 1, [Define for the SH architecture.])
-- ;;
--sh64)
-+sh64*)
- arch=sh64
- AC_DEFINE([SH64], 1, [Define for the SH64 architecture.])
- ;;
-+sh*)
-+ arch=sh
-+ AC_DEFINE([SH], 1, [Define for the SH architecture.])
-+ ;;
- x86?64*)
- arch=x86_64
- AC_DEFINE([X86_64], 1, [Define for the AMD x86-64 architecture.])
diff --git a/dev-util/strace/files/strace-4.5.14-CTL_PROC.patch b/dev-util/strace/files/strace-4.5.14-CTL_PROC.patch
deleted file mode 100644
index f172917d5ac0..000000000000
--- a/dev-util/strace/files/strace-4.5.14-CTL_PROC.patch
+++ /dev/null
@@ -1,17 +0,0 @@
-fix building with 2.6.18+ headers
-
-http://bugs.gentoo.org/150907
-
---- strace-4.5.14/system.c
-+++ strace-4.5.14/system.c
-@@ -1591,6 +1591,10 @@
- #endif
-
- #ifdef LINUX
-+/* linux-2.6.18+ has dropped this enum */
-+#ifndef CTL_PROC
-+# define CTL_PROC 4
-+#endif
- static const struct xlat sysctl_root[] = {
- { CTL_KERN, "CTL_KERN" },
- { CTL_VM, "CTL_VM" },
diff --git a/dev-util/strace/files/strace-4.5.15-sh-SYS_ipc_subcall.patch b/dev-util/strace/files/strace-4.5.15-sh-SYS_ipc_subcall.patch
deleted file mode 100644
index f6f84178f0c2..000000000000
--- a/dev-util/strace/files/strace-4.5.15-sh-SYS_ipc_subcall.patch
+++ /dev/null
@@ -1,15 +0,0 @@
-remove duplicated SYS_ipc_subcall check ... further in the file, there
-is another #if check to make sure the value is 418
-
---- linux/sh/syscallent.h
-+++ linux/sh/syscallent.h
-@@ -435,9 +435,6 @@
- { 5, 0, printargs, "SYS_398" }, /* 398 */
- { 5, 0, printargs, "SYS_399" }, /* 399 */
-
--#if SYS_ipc_subcall != 400
-- #error fix me
--#endif
- { 8, 0, printargs, "socket_subcall"}, /* 400 */
- { 3, TN, sys_socket, "socket" }, /* 401 */
- { 3, TN, sys_bind, "bind" }, /* 402 */
diff --git a/dev-util/strace/files/strace-4.5.8-ia64.patch b/dev-util/strace/files/strace-4.5.8-ia64.patch
deleted file mode 100644
index 922f62c3c4e3..000000000000
--- a/dev-util/strace/files/strace-4.5.8-ia64.patch
+++ /dev/null
@@ -1,97 +0,0 @@
-Remove some obsolete ia64-related hacks from the strace source
-08 Feb 2005 agriffis@gentoo.org
-
---- strace-4.5.8/process.c
-+++ strace-4.5.8/process.c
-@@ -82,14 +82,10 @@
-
- #ifdef HAVE_LINUX_PTRACE_H
- #undef PTRACE_SYSCALL
--# ifdef HAVE_STRUCT_IA64_FPREG
--# define ia64_fpreg XXX_ia64_fpreg
--# endif
- # ifdef HAVE_STRUCT_PT_ALL_USER_REGS
- # define pt_all_user_regs XXX_pt_all_user_regs
- # endif
- #include <linux/ptrace.h>
--# undef ia64_fpreg
- # undef pt_all_user_regs
- #endif
-
---- strace-4.5.8/signal.c
-+++ strace-4.5.8/signal.c
-@@ -53,14 +53,10 @@
- #endif
- #elif defined(HAVE_LINUX_PTRACE_H)
- #undef PTRACE_SYSCALL
--# ifdef HAVE_STRUCT_IA64_FPREG
--# define ia64_fpreg XXX_ia64_fpreg
--# endif
- # ifdef HAVE_STRUCT_PT_ALL_USER_REGS
- # define pt_all_user_regs XXX_pt_all_user_regs
- # endif
- #include <linux/ptrace.h>
--# undef ia64_fpreg
- # undef pt_all_user_regs
- #endif
-
---- strace-4.5.8/syscall.c
-+++ strace-4.5.8/syscall.c
-@@ -63,14 +63,10 @@
- #endif
- #elif defined(HAVE_LINUX_PTRACE_H)
- #undef PTRACE_SYSCALL
--# ifdef HAVE_STRUCT_IA64_FPREG
--# define ia64_fpreg XXX_ia64_fpreg
--# endif
- # ifdef HAVE_STRUCT_PT_ALL_USER_REGS
- # define pt_all_user_regs XXX_pt_all_user_regs
- # endif
- #include <linux/ptrace.h>
--# undef ia64_fpreg
- # undef pt_all_user_regs
- #endif
-
---- strace-4.5.8/system.c
-+++ strace-4.5.8/system.c
-@@ -32,6 +32,23 @@
-
- #include "defs.h"
-
-+#ifdef HAVE_SYS_REG_H
-+# include <sys/reg.h>
-+# ifndef PTRACE_PEEKUSR
-+# define PTRACE_PEEKUSR PTRACE_PEEKUSER
-+# endif
-+# ifndef PTRACE_POKEUSR
-+# define PTRACE_POKEUSR PTRACE_POKEUSER
-+# endif
-+#elif defined(HAVE_LINUX_PTRACE_H)
-+# undef PTRACE_SYSCALL
-+# ifdef HAVE_STRUCT_PT_ALL_USER_REGS
-+# define pt_all_user_regs XXX_pt_all_user_regs
-+# endif
-+# include <linux/ptrace.h>
-+# undef pt_all_user_regs
-+#endif
-+
- #ifdef LINUX
- #define _LINUX_SOCKET_H
- #define _LINUX_FS_H
---- strace-4.5.8/util.c
-+++ strace-4.5.8/util.c
-@@ -63,14 +63,10 @@
- # define PTRACE_PEEKUSR PTRACE_PEEKUSER
- #elif defined(HAVE_LINUX_PTRACE_H)
- #undef PTRACE_SYSCALL
--# ifdef HAVE_STRUCT_IA64_FPREG
--# define ia64_fpreg XXX_ia64_fpreg
--# endif
- # ifdef HAVE_STRUCT_PT_ALL_USER_REGS
- # define pt_all_user_regs XXX_pt_all_user_regs
- # endif
- #include <linux/ptrace.h>
--# undef ia64_fpreg
- # undef pt_all_user_regs
- #endif
-
diff --git a/dev-util/strace/files/strace-dont-use-REG_SYSCALL-for-sh.patch b/dev-util/strace/files/strace-dont-use-REG_SYSCALL-for-sh.patch
deleted file mode 100644
index 9030ecc36d96..000000000000
--- a/dev-util/strace/files/strace-dont-use-REG_SYSCALL-for-sh.patch
+++ /dev/null
@@ -1,10 +0,0 @@
---- strace/process.c
-+++ strace/process.c
-@@ -2663,7 +2663,6 @@ const struct xlat struct_user_offsets[]
- { 4*REG_GBR, "4*REG_GBR" },
- { 4*REG_MACH, "4*REG_MACH" },
- { 4*REG_MACL, "4*REG_MACL" },
-- { 4*REG_SYSCALL, "4*REG_SYSCALL" },
- { 4*REG_FPUL, "4*REG_FPUL" },
- { 4*REG_FPREG0, "4*REG_FPREG0" },
- { 4*(REG_FPREG0+1), "4*REG_FPREG1" },
diff --git a/dev-util/strace/files/strace-superh-update.patch b/dev-util/strace/files/strace-superh-update.patch
deleted file mode 100644
index ff865a2474ff..000000000000
--- a/dev-util/strace/files/strace-superh-update.patch
+++ /dev/null
@@ -1,28 +0,0 @@
---- strace/configure
-+++ strace/configure
-@@ -1993,19 +1993,19 @@
- _ACEOF
-
- ;;
--sh)
-- arch=sh
-+sh64)
-+ arch=sh64
-
- cat >>confdefs.h <<\_ACEOF
--#define SH 1
-+#define SH64 1
- _ACEOF
-
- ;;
--sh64)
-- arch=sh64
-+sh*)
-+ arch=sh
-
- cat >>confdefs.h <<\_ACEOF
--#define SH64 1
-+#define SH 1
- _ACEOF
-
- ;;
diff --git a/dev-util/strace/files/strace-undef-syscall.patch b/dev-util/strace/files/strace-undef-syscall.patch
deleted file mode 100644
index 410e499d949d..000000000000
--- a/dev-util/strace/files/strace-undef-syscall.patch
+++ /dev/null
@@ -1,15 +0,0 @@
---- strace-4.5.12/linux/syscallent.h.orig 2005-08-09 01:48:54.000000000 -0600
-+++ strace-4.5.12/linux/syscallent.h 2005-08-09 01:50:23.000000000 -0600
-@@ -298,7 +298,11 @@
- { 3, 0, sys_io_cancel, "io_cancel" }, /* 249 */
- { 5, TF, sys_fadvise64, "fadvise64" }, /* 250 */
- { 5, 0, printargs, "SYS_251" }, /* 251 */
-- { 1, TP, sys_exit, "exit_group", __NR_exit_group }, /* 252 */
-+ { 1, TP, sys_exit, "exit_group"
-+#ifdef __NR_exit_group
-+ , __NR_exit_group
-+#endif
-+ }, /* 252 */
- { 4, 0, printargs, "lookup_dcookie"}, /* 253 */
- { 1, 0, sys_epoll_create, "epoll_create" }, /* 254 */
- { 4, 0, sys_epoll_ctl, "epoll_ctl" }, /* 255 */
diff --git a/dev-util/strace/strace-4.5.12.ebuild b/dev-util/strace/strace-4.5.12.ebuild
deleted file mode 100644
index eddfdd6538d8..000000000000
--- a/dev-util/strace/strace-4.5.12.ebuild
+++ /dev/null
@@ -1,72 +0,0 @@
-# Copyright 1999-2007 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-util/strace/strace-4.5.12.ebuild,v 1.20 2007/12/15 16:26:06 vapier Exp $
-
-inherit flag-o-matic autotools
-
-DESCRIPTION="A useful diagnostic, instructional, and debugging tool"
-HOMEPAGE="http://sourceforge.net/projects/strace/"
-SRC_URI="mirror://sourceforge/${PN}/${P}.tar.bz2"
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="alpha amd64 arm hppa ia64 ~mips ppc ppc64 s390 sh sparc x86"
-IUSE="static aio"
-
-DEPEND="aio? ( dev-libs/libaio )"
-
-src_unpack() {
- unpack ${A}
- cd "${S}"
-
- [[ ${CHOST} == *-freebsd* ]] && epatch "${FILESDIR}"/${PN}-4.5.11-fbsd.patch
-
- # Fix support for newer glibc snapshots #102080
- epatch "${FILESDIR}"/${P}-quota.patch
-
- # Fix SuperH support
- epatch "${FILESDIR}"/strace-dont-use-REG_SYSCALL-for-sh.patch
- epatch "${FILESDIR}"/${P}-superh-update.patch
-
- # Fix building on older ARM machines
- epatch "${FILESDIR}"/strace-undef-syscall.patch
- epatch "${FILESDIR}"/strace-fix-arm-bad-syscall.patch
-
- # Fix libaio support #103427
- epatch "${FILESDIR}"/${P}-libaio.patch
-
- # Remove some obsolete ia64-related hacks from the strace source
- # (08 Feb 2005 agriffis)
- epatch "${FILESDIR}"/strace-4.5.8-ia64.patch
-
- epatch "${FILESDIR}"/${PN}-4.5.14-CTL_PROC.patch #150907
-
- eautoreconf
-}
-
-src_compile() {
- # This is ugly but linux26-headers-2.6.8.1-r2 (and other versions) has some
- # issues with definition of s64 and friends. This seems to solve
- # compilation in this case (08 Feb 2005 agriffis)
- use ia64 && append-flags -D_ASM_IA64_PAL_H
-
- # Compile fails with -O3 on sparc but works on x86
- use sparc && replace-flags -O3 -O2
- filter-lfs-flags
-
- use static && append-ldflags -static
-
- econf $(use_enable aio libaio) || die
- emake || die
-}
-
-src_install() {
- # Can't use make install because it is stupid and
- # doesn't make leading directories before trying to
- # install. Thus, one would have to make /usr/bin
- # and /usr/man/man1 (at least).
- # So, we do it by hand.
- doman strace.1
- dobin strace strace-graph || die
- dodoc ChangeLog CREDITS NEWS PORTING README* TODO
-}
diff --git a/dev-util/strace/strace-4.5.16.ebuild b/dev-util/strace/strace-4.5.16.ebuild
deleted file mode 100644
index 8a52ec898772..000000000000
--- a/dev-util/strace/strace-4.5.16.ebuild
+++ /dev/null
@@ -1,46 +0,0 @@
-# Copyright 1999-2009 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-util/strace/strace-4.5.16.ebuild,v 1.12 2009/01/31 08:19:42 vapier Exp $
-
-inherit flag-o-matic autotools
-
-DESCRIPTION="A useful diagnostic, instructional, and debugging tool"
-HOMEPAGE="http://sourceforge.net/projects/strace/"
-SRC_URI="mirror://sourceforge/${PN}/${P}.tar.bz2"
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="alpha amd64 arm hppa ia64 mips ppc ppc64 s390 sh ~sparc x86"
-IUSE="static aio"
-
-DEPEND="aio? ( dev-libs/libaio )"
-
-src_unpack() {
- unpack ${A}
- cd "${S}"
-
- #epatch "${FILESDIR}"/${PN}-4.5.11-fbsd.patch
-
- epatch "${FILESDIR}"/${PN}-4.5.15-invalid-time.patch #186369
- epatch "${FILESDIR}"/strace-dont-use-REG_SYSCALL-for-sh.patch
- epatch "${FILESDIR}"/${PN}-4.5.12-superh-update.patch
- epatch "${FILESDIR}"/${PN}-4.5.15-sh-SYS_ipc_subcall.patch
- epatch "${FILESDIR}"/strace-fix-arm-bad-syscall.patch
- epatch "${FILESDIR}"/${PN}-4.5.12-libaio.patch #103427
-
- eautoreconf
-}
-
-src_compile() {
- filter-lfs-flags
-
- use static && append-ldflags -static
-
- econf $(use_enable aio libaio) || die
- emake || die
-}
-
-src_install() {
- emake install DESTDIR="${D}" || die
- dodoc ChangeLog CREDITS NEWS PORTING README* TODO
-}