summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2012-05-02 21:59:12 +0000
committerMike Frysinger <vapier@gentoo.org>2012-05-02 21:59:12 +0000
commitbcbc4a634853903fcacb530a0bdc50405eb0b4cb (patch)
treed3ccc217b727478fc40dad09051f6dcfc9b0a680 /dev-util/strace
parentdev-util/pkgconfig -> virtual/pkgconfig (diff)
downloadgentoo-2-bcbc4a634853903fcacb530a0bdc50405eb0b4cb.tar.gz
gentoo-2-bcbc4a634853903fcacb530a0bdc50405eb0b4cb.tar.bz2
gentoo-2-bcbc4a634853903fcacb530a0bdc50405eb0b4cb.zip
Version bump.
(Portage version: 2.2.0_alpha100/cvs/Linux x86_64)
Diffstat (limited to 'dev-util/strace')
-rw-r--r--dev-util/strace/ChangeLog8
-rw-r--r--dev-util/strace/strace-4.7.ebuild45
-rw-r--r--dev-util/strace/strace-9999.ebuild6
3 files changed, 55 insertions, 4 deletions
diff --git a/dev-util/strace/ChangeLog b/dev-util/strace/ChangeLog
index 5554f1f8bef1..59bcb60d6945 100644
--- a/dev-util/strace/ChangeLog
+++ b/dev-util/strace/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-util/strace
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-util/strace/ChangeLog,v 1.174 2012/02/14 06:13:45 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-util/strace/ChangeLog,v 1.175 2012/05/02 21:59:12 vapier Exp $
+
+*strace-4.7 (02 May 2012)
+
+ 02 May 2012; Mike Frysinger <vapier@gentoo.org> +strace-4.7.ebuild,
+ strace-9999.ebuild:
+ Version bump.
*strace-9999 (14 Feb 2012)
diff --git a/dev-util/strace/strace-4.7.ebuild b/dev-util/strace/strace-4.7.ebuild
new file mode 100644
index 000000000000..eceadf626634
--- /dev/null
+++ b/dev-util/strace/strace-4.7.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-util/strace/strace-4.7.ebuild,v 1.1 2012/05/02 21:59:12 vapier Exp $
+
+EAPI="4"
+
+inherit flag-o-matic eutils
+
+if [[ ${PV} == "9999" ]] ; then
+ EGIT_REPO_URI="git://strace.git.sourceforge.net/gitroot/strace/strace"
+ inherit git-2 autotools
+else
+ SRC_URI="mirror://sourceforge/${PN}/${P}.tar.xz"
+ KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-linux ~ia64-linux ~x86-linux"
+fi
+
+DESCRIPTION="A useful diagnostic, instructional, and debugging tool"
+HOMEPAGE="http://sourceforge.net/projects/strace/"
+
+LICENSE="BSD"
+SLOT="0"
+IUSE="static aio"
+
+# strace only uses the header from libaio to decode structs
+DEPEND="aio? ( >=dev-libs/libaio-0.3.106 )
+ sys-kernel/linux-headers"
+RDEPEND=""
+
+src_prepare() {
+ if [[ ! -e configure ]] ; then
+ # git generation
+ eautoreconf
+ [[ ! -e CREDITS ]] && cp CREDITS{.in,}
+ fi
+
+ filter-lfs-flags # configure handles this sanely
+ use static && append-ldflags -static
+
+ export ac_cv_header_libaio_h=$(usex aio)
+}
+
+src_install() {
+ default
+ dodoc CREDITS
+}
diff --git a/dev-util/strace/strace-9999.ebuild b/dev-util/strace/strace-9999.ebuild
index fa757c9913dc..aa89f3c6e408 100644
--- a/dev-util/strace/strace-9999.ebuild
+++ b/dev-util/strace/strace-9999.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-util/strace/strace-9999.ebuild,v 1.1 2012/02/14 06:13:45 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-util/strace/strace-9999.ebuild,v 1.2 2012/05/02 21:59:12 vapier Exp $
EAPI="4"
@@ -21,7 +21,7 @@ LICENSE="BSD"
SLOT="0"
IUSE="static aio"
-# strace only uses the header from libaio
+# strace only uses the header from libaio to decode structs
DEPEND="aio? ( >=dev-libs/libaio-0.3.106 )
sys-kernel/linux-headers"
RDEPEND=""
@@ -41,5 +41,5 @@ src_prepare() {
src_install() {
default
- dodoc CREDITS PORTING
+ dodoc CREDITS
}