summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMartin Holzer <mholzer@gentoo.org>2003-04-03 20:06:30 +0000
committerMartin Holzer <mholzer@gentoo.org>2003-04-03 20:06:30 +0000
commit699ed1003c849df25d5405213f32809475b229b2 (patch)
tree48f9c59a48ba100d096773ad971b6c9358f64db3 /dev-util/strace
parentVersion bumped. (diff)
downloadgentoo-2-699ed1003c849df25d5405213f32809475b229b2.tar.gz
gentoo-2-699ed1003c849df25d5405213f32809475b229b2.tar.bz2
gentoo-2-699ed1003c849df25d5405213f32809475b229b2.zip
Version bumped.
Diffstat (limited to 'dev-util/strace')
-rw-r--r--dev-util/strace/files/digest-strace-4.4.942
-rw-r--r--dev-util/strace/strace-4.4.94.ebuild41
2 files changed, 42 insertions, 1 deletions
diff --git a/dev-util/strace/files/digest-strace-4.4.94 b/dev-util/strace/files/digest-strace-4.4.94
index 751937f65d1b..0fa5bc0374ac 100644
--- a/dev-util/strace/files/digest-strace-4.4.94
+++ b/dev-util/strace/files/digest-strace-4.4.94
@@ -1,5 +1,5 @@
MD5 db010dd4d78a0a198a7436df23c654e4 /files/strace-4.4.93-configure.ac.patch 337
MD5 8b3c145c5cbe648c4eceeaedd4ec9d05 /files/strace-4.4-arm-configure.patch 224
MD5 ae0107bf0d9c841b0f0929a88f47844a /files/strace-4.4-arm.patch 7667
-MD5 b13fe3280af58d37145e253733be1776 /strace-4.4.94.ebuild 1269
+MD5 b2dcfe068411f75d5563ceee6301c050 /strace-4.4.94.ebuild 1268
MD5 483890e6ea930f8c09ccae55121ca7ac strace-4.4.94.tar.bz2 361744
diff --git a/dev-util/strace/strace-4.4.94.ebuild b/dev-util/strace/strace-4.4.94.ebuild
new file mode 100644
index 000000000000..b876abf2e689
--- /dev/null
+++ b/dev-util/strace/strace-4.4.94.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-util/strace/strace-4.4.94.ebuild,v 1.1 2003/04/03 20:06:17 mholzer Exp $
+
+S=${WORKDIR}/${P}
+DESCRIPTION="A usefull diagnostic, instructional, and debugging tool"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.bz2"
+HOMEPAGE="http://www.wi.leidenuniv.nl/~wichert/strace/"
+
+SLOT="0"
+LICENSE="as-is"
+KEYWORDS="~x86 ~ppc ~sparc alpha ~hppa mips"
+
+DEPEND="virtual/glibc >=sys-devel/autoconf-2.54"
+
+
+src_compile() {
+ # Compile fails with -O3 on but works on x86, sparc untested
+# if [ "${ARCH}" == "sparc" -o "${ARCH}" == "" ]; then
+# if [ -n "${CFLAGS}" ]; then
+# CFLAGS=`echo ${CFLAGS} | sed -e 's:-O3:-O2:'`
+# fi
+# fi
+ # configure is broken by default for sparc and possibly others, regen
+ # from configure.in
+ autoconf
+ ./configure --prefix=/usr || die
+ emake || die
+}
+
+src_install () {
+ # Can't use make install because it is stupid and
+ # doesn't make leading directories before trying to
+ # install. Thus, one would have to make /usr/bin
+ # and /usr/man/man1 (at least).
+ # So, we do it by hand.
+ doman strace.1
+ dobin strace
+ dobin strace-graph
+ dodoc ChangeLog COPYRIGHT CREDITS NEWS PORTING README* TODO
+}