summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2014-03-24 17:34:28 +0000
committerMichał Górny <mgorny@gentoo.org>2014-03-24 17:34:28 +0000
commit1a69b9f3c6576821061c7c91436f89cef43aad90 (patch)
treebb6c9b26327e23a533a1e1f56ec891c31f68fde8 /dev-util/squashdelta
parentFix bug #505330. Thanks to Bob Johnson for the report. (diff)
downloadgentoo-2-1a69b9f3c6576821061c7c91436f89cef43aad90.tar.gz
gentoo-2-1a69b9f3c6576821061c7c91436f89cef43aad90.tar.bz2
gentoo-2-1a69b9f3c6576821061c7c91436f89cef43aad90.zip
Enable LZO by default since it is going to be used by Gentoo, and require at least one compressor enabled.
(Portage version: 2.2.9-r1/cvs/Linux x86_64, signed Manifest commit with key EFB4464E!)
Diffstat (limited to 'dev-util/squashdelta')
-rw-r--r--dev-util/squashdelta/ChangeLog6
-rw-r--r--dev-util/squashdelta/squashdelta-9999.ebuild7
2 files changed, 10 insertions, 3 deletions
diff --git a/dev-util/squashdelta/ChangeLog b/dev-util/squashdelta/ChangeLog
index 1d7a32701e2b..4026edc06524 100644
--- a/dev-util/squashdelta/ChangeLog
+++ b/dev-util/squashdelta/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for dev-util/squashdelta
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-util/squashdelta/ChangeLog,v 1.1 2014/02/11 19:30:53 mgorny Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-util/squashdelta/ChangeLog,v 1.2 2014/03/24 17:34:28 mgorny Exp $
+
+ 24 Mar 2014; Michał Górny <mgorny@gentoo.org> squashdelta-9999.ebuild:
+ Enable LZO by default since it is going to be used by Gentoo, and require at
+ least one compressor enabled.
*squashdelta-9999 (11 Feb 2014)
diff --git a/dev-util/squashdelta/squashdelta-9999.ebuild b/dev-util/squashdelta/squashdelta-9999.ebuild
index 84332059c1a2..5d347ce8f20c 100644
--- a/dev-util/squashdelta/squashdelta-9999.ebuild
+++ b/dev-util/squashdelta/squashdelta-9999.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-util/squashdelta/squashdelta-9999.ebuild,v 1.1 2014/02/11 19:30:53 mgorny Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-util/squashdelta/squashdelta-9999.ebuild,v 1.2 2014/03/24 17:34:28 mgorny Exp $
EAPI=5
@@ -21,7 +21,7 @@ SRC_URI="mirror://bitbucket/mgorny/${PN}/downloads/${P}.tar.bz2"
LICENSE="BSD public-domain"
SLOT="0"
KEYWORDS="~amd64 ~x86"
-IUSE="lz4 lzo"
+IUSE="lz4 +lzo"
#if LIVE
KEYWORDS=
@@ -35,6 +35,9 @@ RDEPEND="${COMMON_DEPEND}
dev-util/xdelta:3"
DEPEND=${COMMON_DEPEND}
+# SquashDelta does not make much sense without a compression algo.
+REQUIRED_USE="|| ( lz4 lzo )"
+
src_configure() {
local myeconfargs=(
$(use_enable lz4)