summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSteve Arnold <nerdboy@gentoo.org>2006-04-24 02:43:21 +0000
committerSteve Arnold <nerdboy@gentoo.org>2006-04-24 02:43:21 +0000
commitcc0870db3b08606e7569941f63259b5790615691 (patch)
tree22d3926950f8f3fc12b174ffba948fc11c012b38 /dev-util/sourcenav
parentStable on amd64. (diff)
downloadgentoo-2-cc0870db3b08606e7569941f63259b5790615691.tar.gz
gentoo-2-cc0870db3b08606e7569941f63259b5790615691.tar.bz2
gentoo-2-cc0870db3b08606e7569941f63259b5790615691.zip
added debug USE flag, fix for bug 119580, reworked for modular X
(Portage version: 2.1_pre7-r5)
Diffstat (limited to 'dev-util/sourcenav')
-rw-r--r--dev-util/sourcenav/ChangeLog7
-rw-r--r--dev-util/sourcenav/sourcenav-5.2_beta2.ebuild33
2 files changed, 30 insertions, 10 deletions
diff --git a/dev-util/sourcenav/ChangeLog b/dev-util/sourcenav/ChangeLog
index f70b4bc2ab4d..f8c6d88d03f8 100644
--- a/dev-util/sourcenav/ChangeLog
+++ b/dev-util/sourcenav/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for dev-util/sourcenav
-# Copyright 2002-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-util/sourcenav/ChangeLog,v 1.15 2005/11/26 06:04:50 nerdboy Exp $
+# Copyright 2002-2006 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-util/sourcenav/ChangeLog,v 1.16 2006/04/24 02:43:21 nerdboy Exp $
+
+ 24 Apr 2006; Steve Arnold <nerdboy@gentoo.org> sourcenav-5.2_beta2.ebuild:
+ added debug USE flag, fix for bug 119580, reworked for modular X
26 Nov 2005; Steve Arnold <nerdboy@gentoo.org> sourcenav-5.1.1.ebuild,
sourcenav-5.1.4.ebuild, sourcenav-5.2_beta2.ebuild:
diff --git a/dev-util/sourcenav/sourcenav-5.2_beta2.ebuild b/dev-util/sourcenav/sourcenav-5.2_beta2.ebuild
index ce7b1d8acee9..4db44f9e0eb8 100644
--- a/dev-util/sourcenav/sourcenav-5.2_beta2.ebuild
+++ b/dev-util/sourcenav/sourcenav-5.2_beta2.ebuild
@@ -1,10 +1,10 @@
-# Copyright 1999-2005 Gentoo Foundation
+# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-util/sourcenav/sourcenav-5.2_beta2.ebuild,v 1.4 2005/11/26 06:04:50 nerdboy Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-util/sourcenav/sourcenav-5.2_beta2.ebuild,v 1.5 2006/04/24 02:43:21 nerdboy Exp $
inherit eutils
-IUSE=""
+IUSE="debug"
MY_P="5.2b2"
S=${WORKDIR}/sourcenav-${MY_P}
@@ -19,21 +19,37 @@ SLOT="0"
LICENSE="GPL-2 LGPL-2"
KEYWORDS="~x86 ~sparc ~ppc ~amd64"
-RDEPEND="virtual/x11"
-DEPEND=">=sys-libs/glibc-2.2.4
- ${RDEPEND}"
+RDEPEND="|| (
+ ( x11-libs/libXmu
+ x11-libs/libXext
+ x11-libs/libXp
+ x11-libs/libX11
+ x11-libs/libXt
+ x11-libs/libSM
+ x11-libs/libICE
+ x11-libs/libXpm
+ x11-libs/libXaw )
+ virtual/x11
+ )"
+DEPEND="${RDEPEND}
+ || (
+ ( x11-proto/xproto x11-proto/xextproto )
+ virtual/x11
+ )"
src_unpack() {
unpack ${A}
# mkdir ${SB} || die "mkdir build failed"
cd ${S}
epatch ${FILESDIR}/sourcenav_destdir.patch || die "epatch failed"
+ sed -i -e "s/relid'/relid/" tcl/unix/configure
+ sed -i -e "s/relid'/relid/" tk/unix/configure
}
src_compile() {
cd ${S}
# ../sourcenav-${MY_P}/configure \
- ./configure \
+ ./configure ${MY_CONF} \
--host=${CHOST} \
--prefix=${SN} \
--bindir=${SN}/bin \
@@ -41,7 +57,8 @@ src_compile() {
--exec-prefix=${SN} \
--mandir=${SN}/share/man \
--infodir=${SN}/share/info \
- --datadir=${SN}/share || die "configure failed"
+ --datadir=${SN}/share \
+ $(use_enable debug symbols) || die "configure failed"
make || die "make failed"
}