summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSamuli Suominen <ssuominen@gentoo.org>2012-03-13 20:26:01 +0000
committerSamuli Suominen <ssuominen@gentoo.org>2012-03-13 20:26:01 +0000
commit892ff70a131c84b00fd147efbd11b06b0135638c (patch)
tree6dfdf6e7972c1b345b768fb0977ff806b721b372 /dev-util/skipfish
parentEnable USE="dbus" by default to satisfy REQUIRED_USE by Jeremy Olexa. (diff)
downloadgentoo-2-892ff70a131c84b00fd147efbd11b06b0135638c.tar.gz
gentoo-2-892ff70a131c84b00fd147efbd11b06b0135638c.tar.bz2
gentoo-2-892ff70a131c84b00fd147efbd11b06b0135638c.zip
Version bump.
(Portage version: 2.2.0_alpha90/cvs/Linux x86_64)
Diffstat (limited to 'dev-util/skipfish')
-rw-r--r--dev-util/skipfish/ChangeLog10
-rw-r--r--dev-util/skipfish/skipfish-2.05_beta.ebuild56
2 files changed, 64 insertions, 2 deletions
diff --git a/dev-util/skipfish/ChangeLog b/dev-util/skipfish/ChangeLog
index 0e4b5aae7196..50a67e685c92 100644
--- a/dev-util/skipfish/ChangeLog
+++ b/dev-util/skipfish/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-util/skipfish
-# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-util/skipfish/ChangeLog,v 1.7 2011/04/06 22:45:44 xmw Exp $
+# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-util/skipfish/ChangeLog,v 1.8 2012/03/13 20:26:01 ssuominen Exp $
+
+*skipfish-2.05_beta (13 Mar 2012)
+
+ 13 Mar 2012; Samuli Suominen <ssuominen@gentoo.org>
+ +skipfish-2.05_beta.ebuild:
+ Version bump.
*skipfish-1.85_beta (06 Apr 2011)
diff --git a/dev-util/skipfish/skipfish-2.05_beta.ebuild b/dev-util/skipfish/skipfish-2.05_beta.ebuild
new file mode 100644
index 000000000000..8018c6f7a04e
--- /dev/null
+++ b/dev-util/skipfish/skipfish-2.05_beta.ebuild
@@ -0,0 +1,56 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-util/skipfish/skipfish-2.05_beta.ebuild,v 1.1 2012/03/13 20:26:01 ssuominen Exp $
+
+EAPI=4
+inherit toolchain-funcs
+
+MY_P=${P/_beta/b}
+
+DESCRIPTION="A fully automated, active web application security reconnaissance tool"
+HOMEPAGE="http://code.google.com/p/skipfish/"
+SRC_URI="http://${PN}.googlecode.com/files/${MY_P}.tgz"
+
+LICENSE="Apache-2.0 LGPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="debug"
+
+RDEPEND="dev-libs/openssl:0
+ net-dns/libidn
+ sys-libs/zlib"
+DEPEND="${RDEPEND}"
+
+S=${WORKDIR}/${MY_P}
+
+src_prepare() {
+ sed -i \
+ -e '/CFLAGS_GEN/s:-g -ggdb::' \
+ -e '/CFLAGS_OPT/s:-O3::' \
+ Makefile || die
+
+ sed -i \
+ -e "/ASSETS_DIR/s:assets:/usr/share/doc/${PF}/html:" \
+ config.h || die
+}
+
+src_compile() {
+ tc-export CC
+
+ local _debug
+ use debug && _debug=debug
+
+ emake ${_debug} || die
+}
+
+src_install() {
+ dobin ${PN}
+ doman ${PN}.1
+
+ insinto /usr/share/${PN}/dictionaries
+ doins dictionaries/*.wl
+
+ dohtml assets/*
+
+ dodoc ChangeLog dictionaries/README-FIRST README
+}