summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Weber <xmw@gentoo.org>2010-08-30 22:22:02 +0000
committerMichael Weber <xmw@gentoo.org>2010-08-30 22:22:02 +0000
commit0e91addaac3f2917672ed180fde0dde5373b69e5 (patch)
tree937bc1aa5d41a680c40e359ce95ae40fda021519 /dev-util/shc
parentBug #267103 - Add /etc/portage to CONFIG_PROTECT_MASK. (diff)
downloadgentoo-2-0e91addaac3f2917672ed180fde0dde5373b69e5.tar.gz
gentoo-2-0e91addaac3f2917672ed180fde0dde5373b69e5.tar.bz2
gentoo-2-0e91addaac3f2917672ed180fde0dde5373b69e5.zip
Respect LDFLAGS, do not strip by intall -s, fixes bug 335333
(Portage version: 2.1.8.3/cvs/Linux x86_64)
Diffstat (limited to 'dev-util/shc')
-rw-r--r--dev-util/shc/ChangeLog7
-rw-r--r--dev-util/shc/shc-3.8.3.ebuild23
2 files changed, 22 insertions, 8 deletions
diff --git a/dev-util/shc/ChangeLog b/dev-util/shc/ChangeLog
index e65c6e39e724..3ced4740461e 100644
--- a/dev-util/shc/ChangeLog
+++ b/dev-util/shc/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for dev-util/shc
-# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-util/shc/ChangeLog,v 1.15 2009/09/23 17:48:34 patrick Exp $
+# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-util/shc/ChangeLog,v 1.16 2010/08/30 22:22:02 xmw Exp $
+
+ 30 Aug 2010; Michael Weber (xmw) <xmw@gentoo.org> shc-3.8.3.ebuild:
+ Respect LDFLAGS, do not strip by intall -s, fixes bug 335333
23 Sep 2009; Patrick Lauer <patrick@gentoo.org> shc-3.6.ebuild,
shc-3.7.ebuild:
diff --git a/dev-util/shc/shc-3.8.3.ebuild b/dev-util/shc/shc-3.8.3.ebuild
index 0ea4cf1e9353..35044700ed04 100644
--- a/dev-util/shc/shc-3.8.3.ebuild
+++ b/dev-util/shc/shc-3.8.3.ebuild
@@ -1,6 +1,8 @@
-# Copyright 1999-2006 Gentoo Foundation
+# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-util/shc/shc-3.8.3.ebuild,v 1.1 2006/02/19 03:35:02 vanquirius Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-util/shc/shc-3.8.3.ebuild,v 1.2 2010/08/30 22:22:02 xmw Exp $
+
+EAPI=2
inherit toolchain-funcs
@@ -13,16 +15,25 @@ SLOT="0"
KEYWORDS="~alpha ~ppc ~sparc ~x86"
IUSE=""
+RESTRICT="test"
+
+src_prepare() {
+ # respect LDFLAGS
+ sed -i -e 's:$(CC) $(CFLAGS):\0 $(LDFLAGS):' Makefile || die
+ # do not strip by install -s
+ sed -i -e '/install/s: -s : :' Makefile || die
+}
+
src_compile() {
export CC="$(tc-getCC)"
## the "test"-target leads to an access-violation -> so we skip it
## as it's only for demonstration purposes anyway.
- make shc || die
+ emake shc CFLAGS="${CFLAGS}" || die
}
src_install() {
- dobin shc
- doman shc.1
- dodoc shc.README CHANGES
+ dobin shc || die
+ doman shc.1 || die
+ dodoc shc.README CHANGES || die
}