summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAli Polatel <hawking@gentoo.org>2008-07-19 12:31:48 +0000
committerAli Polatel <hawking@gentoo.org>2008-07-19 12:31:48 +0000
commita2bff76fe7f9a0ad174bf679eacf6a6cb9a0fe3a (patch)
treefdb7ff7ae0a2310239e503cdac391171ca389611 /dev-util/scons
parentchanging to maintainer-needed (diff)
downloadgentoo-2-a2bff76fe7f9a0ad174bf679eacf6a6cb9a0fe3a.tar.gz
gentoo-2-a2bff76fe7f9a0ad174bf679eacf6a6cb9a0fe3a.tar.bz2
gentoo-2-a2bff76fe7f9a0ad174bf679eacf6a6cb9a0fe3a.zip
Version bump.
(Portage version: -svn.wrabbit)
Diffstat (limited to 'dev-util/scons')
-rw-r--r--dev-util/scons/ChangeLog7
-rw-r--r--dev-util/scons/scons-0.98.5.ebuild46
2 files changed, 52 insertions, 1 deletions
diff --git a/dev-util/scons/ChangeLog b/dev-util/scons/ChangeLog
index 2c3edc7b4ba2..c35a3e30e0eb 100644
--- a/dev-util/scons/ChangeLog
+++ b/dev-util/scons/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-util/scons
# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-util/scons/ChangeLog,v 1.57 2008/06/14 11:45:06 zmedico Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-util/scons/ChangeLog,v 1.58 2008/07/19 12:31:48 hawking Exp $
+
+*scons-0.98.5 (19 Jul 2008)
+
+ 19 Jul 2008; Ali Polatel <hawking@gentoo.org> +scons-0.98.5.ebuild:
+ Version bump.
14 Jun 2008; Zac Medico <zmedico@gentoo.org> scons-0.97.ebuild,
scons-0.98.3.ebuild, scons-0.98.4.ebuild:
diff --git a/dev-util/scons/scons-0.98.5.ebuild b/dev-util/scons/scons-0.98.5.ebuild
new file mode 100644
index 000000000000..e16e5721df54
--- /dev/null
+++ b/dev-util/scons/scons-0.98.5.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-util/scons/scons-0.98.5.ebuild,v 1.1 2008/07/19 12:31:48 hawking Exp $
+
+NEED_PYTHON="1.5.2"
+
+inherit python distutils multilib
+
+DESCRIPTION="Extensible Python-based build utility"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+HOMEPAGE="http://www.scons.org/"
+
+SLOT="0"
+LICENSE="as-is"
+KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd"
+IUSE=""
+
+DOCS="RELEASE.txt CHANGES.txt LICENSE.txt"
+
+src_install () {
+ distutils_src_install
+ # move man pages from /usr/man to /usr/share/man
+ dodir /usr/share
+ mv "${D}"/usr/man "${D}"/usr/share
+}
+
+pkg_preinst() {
+ has_version "<${CATEGORY}/${PN}-0.96.92-r1"
+ clean_stale_junk=$?
+}
+
+pkg_postinst() {
+ python_mod_optimize /usr/$(get_libdir)/${P}
+ # clean up stale junk left there by old faulty ebuilds
+ # see Bug 118022 and Bug 132448
+ if [[ $clean_stale_junk = 0 ]] ; then
+ einfo "Cleaning up stale orphaned py[co] files..."
+ [[ -d "${ROOT}/usr/$(get_libdir)/scons/SCons" ]] \
+ && rm -rf "${ROOT}/usr/$(get_libdir)/scons/SCons"
+ einfo "Done."
+ fi
+}
+
+pkg_postrm() {
+ python_mod_cleanup /usr/$(get_libdir)/${P}
+}