summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDirkjan Ochtman <djc@gentoo.org>2010-01-04 08:36:30 +0000
committerDirkjan Ochtman <djc@gentoo.org>2010-01-04 08:36:30 +0000
commit9fe10ea56cbb7874c95ec92e2ca3e84ac83f2727 (patch)
treeed0b69eede6d50f83ac47e1debff700268732aa1 /dev-util/scons
parentrevert the change to install VDPAU drivers to /usr/lib/vdpau since libvdpau's... (diff)
downloadgentoo-2-9fe10ea56cbb7874c95ec92e2ca3e84ac83f2727.tar.gz
gentoo-2-9fe10ea56cbb7874c95ec92e2ca3e84ac83f2727.tar.bz2
gentoo-2-9fe10ea56cbb7874c95ec92e2ca3e84ac83f2727.zip
Bump dev-util/scons to 1.2.0_p20091224.
(Portage version: 2.1.6.13/cvs/Linux x86_64)
Diffstat (limited to 'dev-util/scons')
-rw-r--r--dev-util/scons/ChangeLog10
-rw-r--r--dev-util/scons/scons-1.2.0_p20091224.ebuild49
2 files changed, 57 insertions, 2 deletions
diff --git a/dev-util/scons/ChangeLog b/dev-util/scons/ChangeLog
index d07bc85655d4..c78883b342e0 100644
--- a/dev-util/scons/ChangeLog
+++ b/dev-util/scons/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-util/scons
-# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-util/scons/ChangeLog,v 1.73 2009/04/12 18:07:35 ranger Exp $
+# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-util/scons/ChangeLog,v 1.74 2010/01/04 08:36:30 djc Exp $
+
+*scons-1.2.0_p20091224 (04 Jan 2010)
+
+ 04 Jan 2010; Dirkjan Ochtman <djc@gentoo.org>
+ +scons-1.2.0_p20091224.ebuild:
+ Bump to 1.2.0.d20091224. Thanks to Johan Bergstroem for the patch.
12 Apr 2009; Brent Baude <ranger@gentoo.org> scons-1.2.0-r1.ebuild:
stable ppc64, bug 264537
diff --git a/dev-util/scons/scons-1.2.0_p20091224.ebuild b/dev-util/scons/scons-1.2.0_p20091224.ebuild
new file mode 100644
index 000000000000..024883118a14
--- /dev/null
+++ b/dev-util/scons/scons-1.2.0_p20091224.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-util/scons/scons-1.2.0_p20091224.ebuild,v 1.1 2010/01/04 08:36:30 djc Exp $
+
+EAPI=2
+
+inherit distutils
+
+MY_PV=${PV/_p/.d}
+
+DESCRIPTION="Extensible Python-based build utility"
+SRC_URI="mirror://sourceforge/${PN}/${PN}-${MY_PV}.tar.gz
+ doc? ( http://www.scons.org/doc/${MY_PV}/PDF/${PN}-user.pdf -> ${P}-user.pdf
+ http://www.scons.org/doc/${MY_PV}/HTML/${PN}-user.html -> ${P}-user.html )"
+
+HOMEPAGE="http://www.scons.org/"
+
+SLOT="0"
+LICENSE="MIT"
+KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd"
+IUSE="doc"
+DEPEND=">=dev-lang/python-2.5[threads]"
+RDEPEND=${DEPEND}
+DOCS="RELEASE.txt CHANGES.txt"
+
+S=${WORKDIR}/${PN}-${MY_PV}
+
+src_prepare() {
+ epatch "${FILESDIR}"/scons-1.2.0-popen.patch
+}
+
+src_install () {
+ distutils_src_install
+ # move man pages from /usr/man to /usr/share/man
+ dodir /usr/share
+ mv "${D}"/usr/man "${D}"/usr/share
+ if use doc; then
+ insinto /usr/share/doc/${PF}
+ doins "${DISTDIR}"/${P}-user.{pdf,html}
+ fi
+}
+
+pkg_postinst() {
+ python_mod_optimize /usr/$(get_libdir)/${P}
+}
+
+pkg_postrm() {
+ python_mod_cleanup /usr/$(get_libdir)/${P}
+}