summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJonathan Callen <abcd@gentoo.org>2011-01-23 20:18:17 +0000
committerJonathan Callen <abcd@gentoo.org>2011-01-23 20:18:17 +0000
commit9478d03acdc733be93a6de05df1739c56cb1e632 (patch)
tree76e4a0b1cad71643d1a801ea53a3eb1e61258696 /dev-util/schroot
parentChange suggested key binding for emacs users, bug #352063. (diff)
downloadgentoo-2-9478d03acdc733be93a6de05df1739c56cb1e632.tar.gz
gentoo-2-9478d03acdc733be93a6de05df1739c56cb1e632.tar.bz2
gentoo-2-9478d03acdc733be93a6de05df1739c56cb1e632.zip
Add patch to fix build with USE=debug. Debian bug 609067, Gentoo bug 344615
(Portage version: 2.2.0_alpha14_p1/cvs/Linux i686)
Diffstat (limited to 'dev-util/schroot')
-rw-r--r--dev-util/schroot/ChangeLog6
-rw-r--r--dev-util/schroot/files/schroot-1.4.14-debug.patch28
-rw-r--r--dev-util/schroot/schroot-1.4.14.ebuild5
-rw-r--r--dev-util/schroot/schroot-1.4.17.ebuild3
4 files changed, 38 insertions, 4 deletions
diff --git a/dev-util/schroot/ChangeLog b/dev-util/schroot/ChangeLog
index 532a9ec7be5b..82424e5e08aa 100644
--- a/dev-util/schroot/ChangeLog
+++ b/dev-util/schroot/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for dev-util/schroot
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-util/schroot/ChangeLog,v 1.22 2011/01/06 23:41:17 abcd Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-util/schroot/ChangeLog,v 1.23 2011/01/23 20:18:17 abcd Exp $
+
+ 23 Jan 2011; Jonathan Callen <abcd@gentoo.org> schroot-1.4.14.ebuild,
+ +files/schroot-1.4.14-debug.patch, schroot-1.4.17.ebuild:
+ Add patch to fix build with USE=debug. Debian bug 609067, Gentoo bug 344615
*schroot-1.4.17 (06 Jan 2011)
diff --git a/dev-util/schroot/files/schroot-1.4.14-debug.patch b/dev-util/schroot/files/schroot-1.4.14-debug.patch
new file mode 100644
index 000000000000..4b5b954e1bc0
--- /dev/null
+++ b/dev-util/schroot/files/schroot-1.4.14-debug.patch
@@ -0,0 +1,28 @@
+From 741833bdcba4b9aa7e389d389f42e4fa504d7cc7 Mon Sep 17 00:00:00 2001
+From: Jonathan Callen <abcd@gentoo.org>
+Date: Wed, 5 Jan 2011 01:26:26 -0500
+Subject: [PATCH] schroot-base: fix build with --enable-debug
+
+Rename last instance of the variable sbuild::debug_level to
+sbuild::debug_log_level. This appears to have been missed in commit
+04c19bb6c28295a387e60066c48db7f443e5b925.
+---
+ bin/schroot-base/schroot-base-main.cc | 2 +-
+ 1 files changed, 1 insertions(+), 1 deletions(-)
+
+diff --git a/bin/schroot-base/schroot-base-main.cc b/bin/schroot-base/schroot-base-main.cc
+index ac86018..d6cd0b0 100644
+--- a/bin/schroot-base/schroot-base-main.cc
++++ b/bin/schroot-base/schroot-base-main.cc
+@@ -106,7 +106,7 @@ main::run (int argc,
+ this->program_options->parse(argc, argv);
+
+ #ifdef SBUILD_DEBUG
+- sbuild::debug_level = sbuild::DEBUG_CRITICAL;
++ sbuild::debug_log_level = sbuild::DEBUG_CRITICAL;
+ #endif
+
+ if (this->use_syslog)
+--
+1.7.3.3
+
diff --git a/dev-util/schroot/schroot-1.4.14.ebuild b/dev-util/schroot/schroot-1.4.14.ebuild
index 8fc387d881f3..5c75416016b3 100644
--- a/dev-util/schroot/schroot-1.4.14.ebuild
+++ b/dev-util/schroot/schroot-1.4.14.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2010 Gentoo Foundation
+# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-util/schroot/schroot-1.4.14.ebuild,v 1.2 2010/10/19 02:32:52 abcd Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-util/schroot/schroot-1.4.14.ebuild,v 1.3 2011/01/23 20:18:17 abcd Exp $
EAPI="3"
WANT_AUTOMAKE="1.11"
@@ -43,6 +43,7 @@ RDEPEND="${COMMON_DEPEND}
PATCHES=(
"${FILESDIR}/${PN}-1.4.7-tests.patch"
+ "${FILESDIR}/${P}-debug.patch"
)
src_prepare() {
diff --git a/dev-util/schroot/schroot-1.4.17.ebuild b/dev-util/schroot/schroot-1.4.17.ebuild
index 5e77b7c8f3f1..c82f331770c7 100644
--- a/dev-util/schroot/schroot-1.4.17.ebuild
+++ b/dev-util/schroot/schroot-1.4.17.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-util/schroot/schroot-1.4.17.ebuild,v 1.1 2011/01/06 23:41:17 abcd Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-util/schroot/schroot-1.4.17.ebuild,v 1.2 2011/01/23 20:18:17 abcd Exp $
EAPI="3"
WANT_AUTOMAKE="1.11"
@@ -43,6 +43,7 @@ RDEPEND="${COMMON_DEPEND}
PATCHES=(
"${FILESDIR}/${PN}-1.4.7-tests.patch"
+ "${FILESDIR}/${PN}-1.4.14-debug.patch"
)
src_prepare() {