summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSteve Arnold <nerdboy@gentoo.org>2008-04-02 02:33:16 +0000
committerSteve Arnold <nerdboy@gentoo.org>2008-04-02 02:33:16 +0000
commita410e4678eec90228155247b550cb8ab2cb324a7 (patch)
tree52241cb51b5edd0b87ee8b05ab19da65c7623f75 /dev-util/rapidsvn
parentversion bump as per bug #177133 thanks to Remy. Removed old version and fixed... (diff)
downloadgentoo-2-a410e4678eec90228155247b550cb8ab2cb324a7.tar.gz
gentoo-2-a410e4678eec90228155247b550cb8ab2cb324a7.tar.bz2
gentoo-2-a410e4678eec90228155247b550cb8ab2cb324a7.zip
updated to new release and apr prefix
(Portage version: 2.1.4.4)
Diffstat (limited to 'dev-util/rapidsvn')
-rw-r--r--dev-util/rapidsvn/ChangeLog8
-rw-r--r--dev-util/rapidsvn/rapidsvn-0.9.3.ebuild4
-rw-r--r--dev-util/rapidsvn/rapidsvn-0.9.6.ebuild113
3 files changed, 122 insertions, 3 deletions
diff --git a/dev-util/rapidsvn/ChangeLog b/dev-util/rapidsvn/ChangeLog
index 56fbe26f2e7d..bb27b3bafe9e 100644
--- a/dev-util/rapidsvn/ChangeLog
+++ b/dev-util/rapidsvn/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-util/rapidsvn
# Copyright 2000-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-util/rapidsvn/ChangeLog,v 1.54 2008/01/10 18:07:23 hollow Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-util/rapidsvn/ChangeLog,v 1.55 2008/04/02 02:33:16 nerdboy Exp $
+
+*rapidsvn-0.9.6 (02 Apr 2008)
+
+ 02 Apr 2008; Steve Arnold <nerdboy@gentoo.org> +rapidsvn-0.9.6.ebuild:
+ Updated to new release and apr prefix, with contributions from Luca
+ Marturana <lucamarturana@gmail.com>. Smooth as a baby's ...
10 Jan 2008; Benedikt Böhm <hollow@gentoo.org> rapidsvn-0.9.3.ebuild,
rapidsvn-0.9.4.ebuild:
diff --git a/dev-util/rapidsvn/rapidsvn-0.9.3.ebuild b/dev-util/rapidsvn/rapidsvn-0.9.3.ebuild
index 9b7c608f1aeb..a52c218dcacb 100644
--- a/dev-util/rapidsvn/rapidsvn-0.9.3.ebuild
+++ b/dev-util/rapidsvn/rapidsvn-0.9.3.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-util/rapidsvn/rapidsvn-0.9.3.ebuild,v 1.21 2008/01/10 18:07:23 hollow Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-util/rapidsvn/rapidsvn-0.9.3.ebuild,v 1.22 2008/04/02 02:33:16 nerdboy Exp $
inherit eutils libtool autotools wxwidgets flag-o-matic fdo-mime
@@ -23,7 +23,7 @@ DEPEND=">=dev-util/subversion-1.4.0
app-text/docbook-xsl-stylesheets )"
src_unpack() {
- unpack "${A}"
+ unpack ${A}
cd "${S}"
# Apparently we still the --as-needed link patch...
diff --git a/dev-util/rapidsvn/rapidsvn-0.9.6.ebuild b/dev-util/rapidsvn/rapidsvn-0.9.6.ebuild
new file mode 100644
index 000000000000..474276ee6e87
--- /dev/null
+++ b/dev-util/rapidsvn/rapidsvn-0.9.6.ebuild
@@ -0,0 +1,113 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-util/rapidsvn/rapidsvn-0.9.6.ebuild,v 1.1 2008/04/02 02:33:16 nerdboy Exp $
+
+WANT_AUTOCONF="2.5"
+inherit versionator eutils libtool autotools wxwidgets flag-o-matic fdo-mime
+
+DESCRIPTION="Cross-platform GUI front-end for the Subversion revision system."
+HOMEPAGE="http://rapidsvn.tigris.org/"
+SRC_URI="http://www.rapidsvn.org/download/release/${PV}/${P}.tar.gz"
+LICENSE="GPL-2 LGPL-2.1 FDL-1.2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE="doc static"
+
+DEPEND=">=dev-util/subversion-1.4.0
+ >=net-misc/neon-0.26
+ >=x11-libs/wxGTK-2.6
+ >=dev-libs/apr-1.2.10
+ >=dev-libs/apr-util-1.2.10
+ doc? ( dev-libs/libxslt
+ app-text/docbook-sgml-utils
+ app-doc/doxygen
+ app-text/docbook-xsl-stylesheets )"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+
+ # Apparently we still need the --as-needed link patch...
+ epatch "${FILESDIR}/${PN}-svncpp_link.patch"
+ eautoconf
+ elibtoolize
+}
+
+src_compile() {
+ einfo "Checking for subversion compiled with neon support..."
+ if built_with_use dev-util/subversion nowebdav; then
+ ewarn "SVN (dev-util/subversion) must be compiled with neon support."
+ ewarn "Please re-emerge subversion without the nowebdav USE flag."
+ die "SVN merged with nowebdav USE flag"
+ else
+ einfo "Found neon support; continuing..."
+ fi
+
+ # if you compiled subversion without (the) apache2 (flag) and with the
+ # berkdb flag, you will get an error that it can't find the lib db4
+ # Note: this should be fixed in rapidsvn 0.9.3 and later
+ local myconf
+ local xslss_dir
+ local apr_suffix=""
+
+ if has_version ">dev-libs/apr-util-1"; then
+ apr_suffix="-1"
+ fi
+
+ if use doc; then
+ xslss_dir=$(ls -1d /usr/share/sgml/docbook/xsl-stylesheets*|head -n1)
+ myconf="--with-docbook-xsl=$xslss_dir"
+ else
+ myconf="--without-xsltproc --without-docbook-xsl \
+ --without-doxygen --without-dot"
+ fi
+
+ if use static; then
+ myconf="${myconf} --enable-static"
+ else
+ myconf="${myconf} --disable-static --enable-shared"
+ fi
+
+ local INST_WX=$(best_version x11-libs/wxGTK)
+ export WX_GTK_VER=$(get_version_component_range 1-2 \
+ ${INST_WX/x11-libs\/wxGTK})
+
+ need-wxwidgets ansi
+ myconf="${myconf} --with-wx-config=${WX_CONFIG}"
+
+ append-flags $( /usr/bin/apr${apr_suffix}-config --cppflags )
+
+ econf --with-svn-lib=/usr/$(get_libdir) \
+ --with-svn-include=/usr/include \
+ --with-neon-config=/usr/bin/neon-config \
+ --with-apr-config="/usr/bin/apr${apr_suffix}-config" \
+ --with-apu-config="/usr/bin/apu${apr_suffix}-config" \
+ ${myconf} || die "econf failed"
+ emake || die "emake failed"
+}
+
+src_install() {
+ einstall || die "einstall failed"
+
+ doman doc/manpage/rapidsvn.1 || die "doman failed"
+
+ doicon src/res/rapidsvn.ico
+ make_desktop_entry rapidsvn "RapidSVN ${PV}" \
+ "/usr/share/pixmaps/rapidsvn.ico" \
+ "RevisionControl;Development"
+
+ dodoc HACKING.txt TRANSLATIONS
+
+ if use doc ; then
+ dodoc AUTHORS CHANGES NEWS README
+ dohtml "${S}"/doc/svncpp/html/*
+ fi
+}
+
+pkg_postinst() {
+ fdo-mime_desktop_database_update
+}
+
+pkg_postrm() {
+ fdo-mime_desktop_database_update
+}