summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDiego Elio Pettenò <flameeyes@gentoo.org>2009-12-03 20:53:52 +0000
committerDiego Elio Pettenò <flameeyes@gentoo.org>2009-12-03 20:53:52 +0000
commit19fc24039cd364eb2100896d38bbfc3a9165dfd5 (patch)
treef856d1fd43d02e0b98e9da6a68591d112d970e0c /dev-util/ragel
parentstable sparc, bug 295405 (diff)
downloadgentoo-2-19fc24039cd364eb2100896d38bbfc3a9165dfd5.tar.gz
gentoo-2-19fc24039cd364eb2100896d38bbfc3a9165dfd5.tar.bz2
gentoo-2-19fc24039cd364eb2100896d38bbfc3a9165dfd5.zip
Version bump; add a src_test function but restict them, since they need an ebuild that is not in Portage yet.
(Portage version: 2.2_rc55/cvs/Linux x86_64)
Diffstat (limited to 'dev-util/ragel')
-rw-r--r--dev-util/ragel/ChangeLog8
-rw-r--r--dev-util/ragel/ragel-6.6.ebuild38
2 files changed, 45 insertions, 1 deletions
diff --git a/dev-util/ragel/ChangeLog b/dev-util/ragel/ChangeLog
index 03817c23bec4..5c896e90efd3 100644
--- a/dev-util/ragel/ChangeLog
+++ b/dev-util/ragel/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-util/ragel
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-util/ragel/ChangeLog,v 1.29 2009/07/03 16:03:19 flameeyes Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-util/ragel/ChangeLog,v 1.30 2009/12/03 20:53:52 flameeyes Exp $
+
+*ragel-6.6 (03 Dec 2009)
+
+ 03 Dec 2009; Diego E. Pettenò <flameeyes@gentoo.org> +ragel-6.6.ebuild:
+ Version bump; add a src_test function but restict them, since they need an
+ ebuild that is not in Portage yet.
03 Jul 2009; Diego E. Pettenò <flameeyes@gentoo.org> -ragel-6.3.ebuild,
-ragel-6.4.ebuild, -files/ragel-6.4-solaris.patch:
diff --git a/dev-util/ragel/ragel-6.6.ebuild b/dev-util/ragel/ragel-6.6.ebuild
new file mode 100644
index 000000000000..3042ce3df946
--- /dev/null
+++ b/dev-util/ragel/ragel-6.6.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-util/ragel/ragel-6.6.ebuild,v 1.1 2009/12/03 20:53:52 flameeyes Exp $
+
+DESCRIPTION="Compiles finite state machines from regular languages into executable code."
+HOMEPAGE="http://www.complang.org/ragel/"
+SRC_URI="http://www.complang.org/ragel/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd"
+IUSE="vim-syntax"
+
+DEPEND=""
+RDEPEND=""
+
+# We need to get the txl language in Portage to have the tests :(
+RESTRICT=test
+
+src_compile() {
+ econf --docdir=/usr/share/doc/${PF} || die "econf failed"
+ emake || die "emake failed"
+}
+
+src_test() {
+ cd "${S}"/test
+ ./runtests.in || die
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "make install failed"
+ dodoc ChangeLog CREDITS README TODO || die "dodoc failed"
+
+ if use vim-syntax; then
+ insinto /usr/share/vim/vimfiles/syntax
+ doins ragel.vim || die "doins ragel.vim failed"
+ fi
+}