summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Pagano <mpagano@gentoo.org>2012-03-20 19:37:42 +0000
committerMike Pagano <mpagano@gentoo.org>2012-03-20 19:37:42 +0000
commitd77a1cc09ea9975449398b8db247fd8f5f148f70 (patch)
tree2512461453ce43c4b146ae74dabc04a8410b4362 /dev-util/quilt
parentFix 'media-sound/madplay' RDEPEND to be 'media-libs/libmad'. Found by nzqr in... (diff)
downloadgentoo-2-d77a1cc09ea9975449398b8db247fd8f5f148f70.tar.gz
gentoo-2-d77a1cc09ea9975449398b8db247fd8f5f148f70.tar.bz2
gentoo-2-d77a1cc09ea9975449398b8db247fd8f5f148f70.zip
Version bump
(Portage version: 2.2.0_alpha93/cvs/Linux x86_64)
Diffstat (limited to 'dev-util/quilt')
-rw-r--r--dev-util/quilt/ChangeLog8
-rw-r--r--dev-util/quilt/files/quilt-0.60-no-graphviz.patch43
-rw-r--r--dev-util/quilt/quilt-0.60.ebuild59
3 files changed, 109 insertions, 1 deletions
diff --git a/dev-util/quilt/ChangeLog b/dev-util/quilt/ChangeLog
index e6b06aa65ce2..889c28d5a010 100644
--- a/dev-util/quilt/ChangeLog
+++ b/dev-util/quilt/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-util/quilt
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-util/quilt/ChangeLog,v 1.52 2012/03/20 08:26:41 ago Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-util/quilt/ChangeLog,v 1.53 2012/03/20 19:37:42 mpagano Exp $
+
+*quilt-0.60 (20 Mar 2012)
+
+ 20 Mar 2012; Michael Pagano <mpagano@gentoo.org> +quilt-0.60.ebuild,
+ +files/quilt-0.60-no-graphviz.patch:
+ Version bump
20 Mar 2012; Agostino Sarubbo <ago@gentoo.org> quilt-0.50.ebuild:
Stable for amd64, wrt bug #408755
diff --git a/dev-util/quilt/files/quilt-0.60-no-graphviz.patch b/dev-util/quilt/files/quilt-0.60-no-graphviz.patch
new file mode 100644
index 000000000000..7e7409d95c91
--- /dev/null
+++ b/dev-util/quilt/files/quilt-0.60-no-graphviz.patch
@@ -0,0 +1,43 @@
+--- Makefile.in.orig 2012-03-20 14:59:48.308531073 -0400
++++ Makefile.in 2012-03-20 15:03:26.135623522 -0400
+@@ -76,8 +76,7 @@ QUILT := $(QUILT_IN)
+ SRC += $(QUILT_SRC:%=quilt/%)
+ DIRT += $(QUILT_IN:%=quilt/%)
+
+-SCRIPTS_IN := patchfns inspect dependency-graph edmail \
+- remove-trailing-ws backup-files
++SCRIPTS_IN := patchfns inspect edmail remove-trailing-ws backup-files
+
+ SCRIPTS_SRC := $(SCRIPTS_IN:%=%.in)
+ SCRIPTS := $(SCRIPTS_IN)
+--- bash_completion.orig 2012-03-20 15:04:06.994453283 -0400
++++ bash_completion 2012-03-20 15:07:37.335589189 -0400
+@@ -95,7 +95,7 @@ _quilt_completion()
+ prev=${COMP_WORDS[COMP_CWORD-1]}
+
+ # quilt sub commands
+- cmds='add annotate applied delete diff edit files fold fork graph \
++ cmds='add annotate applied delete diff edit files fold fork \
+ grep header import mail new next patches pop previous push refresh \
+ remove rename revert series setup snapshot top unapplied'
+
+@@ -189,19 +189,6 @@ _quilt_completion()
+ ;;
+ esac
+ ;;
+- graph)
+- case $prev in
+- -T)
+- COMPREPLY=( $( compgen -W "ps" -- $cur ) )
+- ;;
+- --edge-labels)
+- COMPREPLY=( $( compgen -W "files" -- $cur ) )
+- ;;
+- *)
+- COMPREPLY=( $( compgen -W "-T -h --all --reduce --lines --edge-labels $(quilt applied 2>/dev/null)" -- $cur ) )
+- ;;
+- esac
+- ;;
+ grep)
+ _longopt grep
+ COMPREPLY=( ${COMPREPLY[@]:-} $( compgen -W "-h" -- $cur ) )
diff --git a/dev-util/quilt/quilt-0.60.ebuild b/dev-util/quilt/quilt-0.60.ebuild
new file mode 100644
index 000000000000..a4442818fed2
--- /dev/null
+++ b/dev-util/quilt/quilt-0.60.ebuild
@@ -0,0 +1,59 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-util/quilt/quilt-0.60.ebuild,v 1.1 2012/03/20 19:37:42 mpagano Exp $
+
+inherit bash-completion-r1 eutils
+
+DESCRIPTION="quilt patch manager"
+HOMEPAGE="http://savannah.nongnu.org/projects/quilt"
+SRC_URI="http://savannah.nongnu.org/download/quilt/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~ppc ~ppc64 ~sparc ~x86"
+IUSE="emacs graphviz"
+
+RDEPEND="sys-apps/ed
+ dev-util/diffstat
+ graphviz? ( media-gfx/graphviz )
+ >=sys-apps/coreutils-8.5"
+
+PDEPEND="emacs? ( app-emacs/quilt-el )"
+
+pkg_setup() {
+ use graphviz && return 0
+ echo
+ elog "If you intend to use the folding functionality (graphical illustration of the"
+ elog "patch stack) then you'll need to remerge this package with USE=graphviz."
+ echo
+ epause 5
+}
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+
+ # Add support for USE=graphviz
+ use graphviz || epatch "${FILESDIR}/${P}-no-graphviz.patch"
+
+ # Some tests are somewhat broken while being run from within portage, work
+ # fine if you run them manually
+ rm "${S}"/test/delete.test "${S}"/test/mail.test
+}
+
+src_install() {
+ emake BUILD_ROOT="${D}" install || die "make install failed"
+
+ rm -rf "${D}"/usr/share/doc/${P}
+ dodoc AUTHORS TODO quilt.changes doc/README doc/README.MAIL \
+ doc/quilt.pdf
+
+ rm -rf "${D}"/etc/bash_completion.d
+ newbashcomp bash_completion ${PN}
+
+ # Remove the compat symlinks
+ rm -rf "${D}"/usr/share/quilt/compat
+
+ # Remove Emacs mode; newer version is in app-emacs/quilt-el, bug 247500
+ rm -rf "${D}"/usr/share/emacs
+}