summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJohannes Huber <johu@gentoo.org>2012-02-02 15:37:39 +0000
committerJohannes Huber <johu@gentoo.org>2012-02-02 15:37:39 +0000
commit0179c6511597961383728f263150eeb6ec0d2afd (patch)
treecf541a231540b9bbb3a6779ea3575cfb4f890812 /dev-util/qdevelop/qdevelop-0.28.ebuild
parentppc64 stable wrt #393553 (diff)
downloadgentoo-2-0179c6511597961383728f263150eeb6ec0d2afd.tar.gz
gentoo-2-0179c6511597961383728f263150eeb6ec0d2afd.tar.bz2
gentoo-2-0179c6511597961383728f263150eeb6ec0d2afd.zip
Fix build with multilib-strictm thanks ago.
(Portage version: 2.2.0_alpha84/cvs/Linux x86_64)
Diffstat (limited to 'dev-util/qdevelop/qdevelop-0.28.ebuild')
-rw-r--r--dev-util/qdevelop/qdevelop-0.28.ebuild7
1 files changed, 6 insertions, 1 deletions
diff --git a/dev-util/qdevelop/qdevelop-0.28.ebuild b/dev-util/qdevelop/qdevelop-0.28.ebuild
index e1f02e0a3714..798eaa0a548b 100644
--- a/dev-util/qdevelop/qdevelop-0.28.ebuild
+++ b/dev-util/qdevelop/qdevelop-0.28.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-util/qdevelop/qdevelop-0.28.ebuild,v 1.3 2012/02/02 14:12:36 johu Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-util/qdevelop/qdevelop-0.28.ebuild,v 1.4 2012/02/02 15:37:39 johu Exp $
EAPI=4
@@ -26,6 +26,11 @@ PATCHES=( "${FILESDIR}"/${P}-qt-4.7_fix.patch )
src_configure() {
mycmakeargs=( "-DAUTOPLUGINS=$(use plugins && echo 1 || echo 0)" )
+
+ sed -e "s#/lib/pkgconfig#/$(get_libdir)/pkgconfig#" \
+ -e "s#DESTINATION lib#DESTINATION $(get_libdir)#" \
+ -i CMakeLists.txt || die "sed fixing multilib failed"
+
cmake-utils_src_configure
}