summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2004-09-19 01:18:30 +0000
committerRobin H. Johnson <robbat2@gentoo.org>2004-09-19 01:18:30 +0000
commite626417b9418a484956215ceb91d0ed8987c5ad8 (patch)
treee9b04898151fa23cb3810cf1622bb3bf4788a942 /dev-util/pscan/pscan-20000721.ebuild
parentx11-base/xfree -> virtual/x11 (Manifest recommit) (diff)
downloadgentoo-2-e626417b9418a484956215ceb91d0ed8987c5ad8.tar.gz
gentoo-2-e626417b9418a484956215ceb91d0ed8987c5ad8.tar.bz2
gentoo-2-e626417b9418a484956215ceb91d0ed8987c5ad8.zip
Initial commit. Ebuild by Robin H. Johnson <robbat2@gentoo.org>.
Diffstat (limited to 'dev-util/pscan/pscan-20000721.ebuild')
-rw-r--r--dev-util/pscan/pscan-20000721.ebuild25
1 files changed, 25 insertions, 0 deletions
diff --git a/dev-util/pscan/pscan-20000721.ebuild b/dev-util/pscan/pscan-20000721.ebuild
new file mode 100644
index 000000000000..b2122295d333
--- /dev/null
+++ b/dev-util/pscan/pscan-20000721.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2004 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-util/pscan/pscan-20000721.ebuild,v 1.1 2004/09/19 01:18:30 robbat2 Exp $
+
+DESCRIPTION="PScan: A limited problem scanner for C source files"
+HOMEPAGE="http://www.striker.ottawa.on.ca/~aland/pscan/"
+# I wish upstream would version their files, even if it's only with a date
+SRC_URI="http://www.striker.ottawa.on.ca/~aland/pscan/pscan.tar.gz"
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86"
+IUSE=""
+RDEPEND="virtual/libc"
+DEPEND="${RDEPEND} sys-devel/gcc sys-devel/flex"
+S="${WORKDIR}/${PN}"
+
+src_compile() {
+ emake CC="gcc ${CFLAGS}"
+}
+
+src_install() {
+ into /usr
+ dobin pscan
+ dodoc COPYING README find_formats.sh test.c wu-ftpd.pscan
+}