summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMikael Hallendal <hallski@gentoo.org>2002-01-10 13:52:53 +0000
committerMikael Hallendal <hallski@gentoo.org>2002-01-10 13:52:53 +0000
commit0281b00cf155c62c9a877aa7d6cfd51317b19182 (patch)
tree075814868133b89c3018f29997b6ace2d692b64e /dev-util/poedit
parentupdated Numeric with ebuild from Tod (diff)
downloadgentoo-2-0281b00cf155c62c9a877aa7d6cfd51317b19182.tar.gz
gentoo-2-0281b00cf155c62c9a877aa7d6cfd51317b19182.tar.bz2
gentoo-2-0281b00cf155c62c9a877aa7d6cfd51317b19182.zip
commiting, masking for now
Diffstat (limited to 'dev-util/poedit')
-rw-r--r--dev-util/poedit/files/digest-poedit-1.1.51
-rw-r--r--dev-util/poedit/poedit-1.1.5.ebuild38
2 files changed, 39 insertions, 0 deletions
diff --git a/dev-util/poedit/files/digest-poedit-1.1.5 b/dev-util/poedit/files/digest-poedit-1.1.5
new file mode 100644
index 000000000000..a951bdbf1d20
--- /dev/null
+++ b/dev-util/poedit/files/digest-poedit-1.1.5
@@ -0,0 +1 @@
+MD5 25fa4aaf2ce17702993a63266edb94ae poedit-1.1.5.tar.bz2 335872
diff --git a/dev-util/poedit/poedit-1.1.5.ebuild b/dev-util/poedit/poedit-1.1.5.ebuild
new file mode 100644
index 000000000000..95474d78db41
--- /dev/null
+++ b/dev-util/poedit/poedit-1.1.5.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2001 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Author Tod Neidt <tneidt@fidnet.com>
+# $Header: /var/cvsroot/gentoo-x86/dev-util/poedit/poedit-1.1.5.ebuild,v 1.1 2002/01/10 13:52:53 hallski Exp $
+
+S=${WORKDIR}/${P}
+
+DESCRIPTION="Cross-platform gettext catalogs (.po files) editor."
+
+SRC_URI="http://prdownloads.sourceforge.net/poedit/${P}.tar.bz2"
+
+HOMEPAGE="http://poedit.sourceforge.net/"
+
+DEPEND=">=x11-libs/wxGTK-2.3.2
+ >=sys-libs/db-3"
+
+src_compile() {
+
+ ./configure --host=${CHOST} \
+ --prefix=/usr \
+ --mandir=/usr/share/man \
+ --infodir=/usr/share/info \
+ --datadir=/usr/share
+ assert
+
+ emake || die
+}
+
+src_install () {
+ make prefix=${D}/usr \
+ mandir=${D}/usr/share/man \
+ infodir=${D}/usr/share/info \
+ datadir=${D}/usr/share \
+ GNOME_DATA_DIR=${D}/usr/share \
+ install || die
+
+ dodoc AUTHORS LICENSE NEWS README TODO
+}