summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTimothy Redaelli <drizzt@gentoo.org>2006-12-09 21:31:39 +0000
committerTimothy Redaelli <drizzt@gentoo.org>2006-12-09 21:31:39 +0000
commit65250a7809e4c48db2c0e7b99e9c225f42577ea2 (patch)
tree46748bd58ff98fb5683873fdbd0a50c5a21d6721 /dev-util/pmk
parentStable on Alpha. (diff)
downloadgentoo-2-65250a7809e4c48db2c0e7b99e9c225f42577ea2.tar.gz
gentoo-2-65250a7809e4c48db2c0e7b99e9c225f42577ea2.tar.bz2
gentoo-2-65250a7809e4c48db2c0e7b99e9c225f42577ea2.zip
Version bump, removed executable stack.
(Portage version: 2.1.2_rc2-r4)
Diffstat (limited to 'dev-util/pmk')
-rw-r--r--dev-util/pmk/ChangeLog9
-rw-r--r--dev-util/pmk/files/digest-pmk-0.10.03
-rw-r--r--dev-util/pmk/pmk-0.10.0.ebuild56
3 files changed, 66 insertions, 2 deletions
diff --git a/dev-util/pmk/ChangeLog b/dev-util/pmk/ChangeLog
index 48310910382a..8f3d6585d83e 100644
--- a/dev-util/pmk/ChangeLog
+++ b/dev-util/pmk/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-util/pmk
-# Copyright 2000-2004 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-util/pmk/ChangeLog,v 1.6 2006/12/08 22:25:38 masterdriverz Exp $
+# Copyright 2000-2006 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-util/pmk/ChangeLog,v 1.7 2006/12/09 21:31:39 drizzt Exp $
+
+*pmk-0.10.0 (09 Dec 2006)
+
+ 09 Dec 2006; Timothy Redaelli <drizzt@gentoo.org> +pmk-0.10.0.ebuild:
+ Version bump, removed executable stack.
*pmk-0.8.1-r1 (08 Dec 2006)
diff --git a/dev-util/pmk/files/digest-pmk-0.10.0 b/dev-util/pmk/files/digest-pmk-0.10.0
new file mode 100644
index 000000000000..a1157d9acc1f
--- /dev/null
+++ b/dev-util/pmk/files/digest-pmk-0.10.0
@@ -0,0 +1,3 @@
+MD5 90716ac2a1dd8fc4c1b8f5462b6d5656 pmk-0.10.0.tar.gz 207424
+RMD160 e102e28edc225fbf6508cd0aff188691658874e9 pmk-0.10.0.tar.gz 207424
+SHA256 4c6c7a45917a930c67c8c313c99b2f56beacb0b0ae70b6083592c13cb371f754 pmk-0.10.0.tar.gz 207424
diff --git a/dev-util/pmk/pmk-0.10.0.ebuild b/dev-util/pmk/pmk-0.10.0.ebuild
new file mode 100644
index 000000000000..f0df9be961e8
--- /dev/null
+++ b/dev-util/pmk/pmk-0.10.0.ebuild
@@ -0,0 +1,56 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-util/pmk/pmk-0.10.0.ebuild,v 1.1 2006/12/09 21:31:39 drizzt Exp $
+
+inherit toolchain-funcs
+
+DESCRIPTION="Aims to be an alternative to GNU autoconf"
+HOMEPAGE="http://pmk.sourceforge.net/"
+SRC_URI="mirror://sourceforge/pmk/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~x86 ~ppc"
+IUSE=""
+
+DEPEND=""
+RDEPEND=""
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+
+ # Remove executable stack
+ cp detect_cpu_asm.s detect_cpu_asm.S
+ cat >> detect_cpu_asm.S <<EOF
+#ifdef __ELF__
+.section .note.GNU-stack,"",%progbits
+#endif
+EOF
+}
+
+src_compile() {
+ tc-export CC CPP AS
+ ./pmkcfg.sh -p /usr || die "Config failed"
+ emake || die "Build failed"
+}
+
+src_install () {
+ make DESTDIR="${D}" MANDIR=/usr/share/man install || die
+
+ dodoc BUGS Changelog INSTALL LICENSE README STATUS TODO
+}
+
+pkg_postinst() {
+ if [[ ! -f ${ROOT}etc/pmk/pmk.conf ]] ; then
+ einfo
+ einfo "${ROOT}etc/pmk/pmk.conf doesn't exist."
+ einfo "Running pmksetup to generate an initial pmk.conf."
+ einfo
+ # create one with initial values
+ ${ROOT}usr/bin/pmksetup
+ # run it again to reset PREFIX from /usr/local to /usr
+ ${ROOT}usr/bin/pmksetup -u PREFIX="/usr" &>/dev/null
+ fi
+}
+