summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexandre Rostovtsev <tetromino@gentoo.org>2015-05-27 04:35:41 +0000
committerAlexandre Rostovtsev <tetromino@gentoo.org>2015-05-27 04:35:41 +0000
commit3047dc6f215a09e39ac151d5198508f7a7163d1a (patch)
treed4fba8167fe3462c1825bd29aaa81af4cfb5ad39 /dev-util/pkgconfig
parentAdded ~mips. (diff)
downloadgentoo-2-3047dc6f215a09e39ac151d5198508f7a7163d1a.tar.gz
gentoo-2-3047dc6f215a09e39ac151d5198508f7a7163d1a.tar.bz2
gentoo-2-3047dc6f215a09e39ac151d5198508f7a7163d1a.zip
Fix LFS support on 32-bit (bug #550508, thanks to Zac Medico and vapier). Update to git-r3.eclass.
(Portage version: 2.2.20/cvs/Linux x86_64, signed Manifest commit with key 0x18E5B6F2D8D5EC8D)
Diffstat (limited to 'dev-util/pkgconfig')
-rw-r--r--dev-util/pkgconfig/ChangeLog10
-rw-r--r--dev-util/pkgconfig/files/pkgconfig-0.28-lfs.patch29
-rw-r--r--dev-util/pkgconfig/pkgconfig-0.28-r3.ebuild100
-rw-r--r--dev-util/pkgconfig/pkgconfig-9999.ebuild7
4 files changed, 142 insertions, 4 deletions
diff --git a/dev-util/pkgconfig/ChangeLog b/dev-util/pkgconfig/ChangeLog
index 027156984d50..ef9d8e432582 100644
--- a/dev-util/pkgconfig/ChangeLog
+++ b/dev-util/pkgconfig/ChangeLog
@@ -1,6 +1,14 @@
# ChangeLog for dev-util/pkgconfig
# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-util/pkgconfig/ChangeLog,v 1.166 2015/04/30 04:41:02 jer Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-util/pkgconfig/ChangeLog,v 1.167 2015/05/27 04:35:41 tetromino Exp $
+
+*pkgconfig-0.28-r3 (27 May 2015)
+
+ 27 May 2015; Alexandre Rostovtsev <tetromino@gentoo.org>
+ +pkgconfig-0.28-r3.ebuild, pkgconfig-9999.ebuild,
+ +files/pkgconfig-0.28-lfs.patch:
+ Fix LFS support on 32-bit (bug #550508, thanks to Zac Medico and vapier).
+ Update to git-r3.eclass.
30 Apr 2015; Jeroen Roovers <jer@gentoo.org> pkgconfig-0.28-r2.ebuild:
Stable for PPC64 (bug #545848).
diff --git a/dev-util/pkgconfig/files/pkgconfig-0.28-lfs.patch b/dev-util/pkgconfig/files/pkgconfig-0.28-lfs.patch
new file mode 100644
index 000000000000..0741ec85178a
--- /dev/null
+++ b/dev-util/pkgconfig/files/pkgconfig-0.28-lfs.patch
@@ -0,0 +1,29 @@
+From 40342dd0ead05d457a2a4e692cf865f50033a709 Mon Sep 17 00:00:00 2001
+From: Peter Jones <pjones@redhat.com>
+Date: Wed, 15 Apr 2015 12:25:29 -0400
+Subject: [PATCH] Enable large file support
+
+https://bugs.freedesktop.org/show_bug.cgi?id=90078
+
+Signed-off-by: Peter Jones <pjones@redhat.com>
+---
+ configure.ac | 3 +++
+ 1 file changed, 3 insertions(+)
+
+diff --git a/configure.ac b/configure.ac
+index b807251..388c013 100644
+--- a/configure.ac
++++ b/configure.ac
+@@ -29,6 +29,9 @@ dnl by either passing --disable-silent-rules to configure or passing V=1
+ dnl to make
+ m4_ifdef([AM_SILENT_RULES], [AM_SILENT_RULES([yes])])
+
++dnl Enable large file support
++AC_SYS_LARGEFILE
++
+ dnl Check for programs
+ AC_PROG_CC
+ AC_CHECK_PROG([LN], [ln], [ln], [cp -Rp])
+--
+2.4.1
+
diff --git a/dev-util/pkgconfig/pkgconfig-0.28-r3.ebuild b/dev-util/pkgconfig/pkgconfig-0.28-r3.ebuild
new file mode 100644
index 000000000000..3a34face18a8
--- /dev/null
+++ b/dev-util/pkgconfig/pkgconfig-0.28-r3.ebuild
@@ -0,0 +1,100 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-util/pkgconfig/pkgconfig-0.28-r3.ebuild,v 1.1 2015/05/27 04:35:41 tetromino Exp $
+
+EAPI=5
+
+inherit autotools eutils flag-o-matic libtool multilib multilib-minimal
+
+MY_P=pkg-config-${PV}
+
+if [[ ${PV} == *9999* ]]; then
+ EGIT_REPO_URI="git://anongit.freedesktop.org/pkg-config"
+ EGIT_CHECKOUT_DIR=${WORKDIR}/${MY_P}
+ inherit autotools git-r3
+else
+ KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~ppc-aix ~amd64-fbsd ~sparc-fbsd ~x86-fbsd ~x64-freebsd ~x86-freebsd ~hppa-hpux ~ia64-hpux ~x86-interix ~amd64-linux ~arm-linux ~ia64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~m68k-mint ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+ SRC_URI="http://pkgconfig.freedesktop.org/releases/${MY_P}.tar.gz"
+fi
+
+DESCRIPTION="Package config system that manages compile/link flags"
+HOMEPAGE="http://pkgconfig.freedesktop.org/wiki/"
+
+LICENSE="GPL-2"
+SLOT="0"
+IUSE="elibc_FreeBSD elibc_glibc hardened internal-glib"
+
+RDEPEND="!internal-glib? ( >=dev-libs/glib-2.34.3[${MULTILIB_USEDEP}] )
+ !dev-util/pkgconf[pkg-config]
+ !dev-util/pkg-config-lite
+ !dev-util/pkgconfig-openbsd[pkg-config]"
+DEPEND="${RDEPEND}"
+
+S=${WORKDIR}/${MY_P}
+
+DOCS=( AUTHORS NEWS README )
+
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-strip_system_library_dirs_reliably.patch
+
+ sed -i -e "s|^prefix=/usr\$|prefix=${EPREFIX}/usr|" check/simple.pc || die #434320
+
+ # Large file support, fixed in git; requires eautoreconf; bug #550508
+ epatch "${FILESDIR}"/${P}-lfs.patch
+
+ epatch_user
+
+ #if [[ ${PV} == *9999* ]]; then
+ eautoreconf
+ #else
+ # elibtoolize # Required for FreeMiNT wrt #333429
+ #fi
+}
+
+multilib_src_configure() {
+ local myconf
+
+ if use internal-glib; then
+ myconf+=' --with-internal-glib'
+ # non-glibc platforms use GNU libiconv, but configure needs to
+ # know about that not to get confused when it finds something
+ # outside the prefix too
+ if use prefix && use !elibc_glibc ; then
+ myconf+=" --with-libiconv=gnu"
+ # add the libdir for libtool, otherwise it'll make love with system
+ # installed libiconv
+ append-ldflags "-L${EPREFIX}/usr/$(get_libdir)"
+ fi
+ else
+ if ! has_version dev-util/pkgconfig; then
+ export GLIB_CFLAGS="-I${EPREFIX}/usr/include/glib-2.0 -I${EPREFIX}/usr/$(get_libdir)/glib-2.0/include"
+ export GLIB_LIBS="-lglib-2.0"
+ fi
+ fi
+
+ use ppc64 && use hardened && replace-flags -O[2-3] -O1
+
+ # Force using all the requirements when linking, so that needed -pthread
+ # lines are inherited between libraries
+ use elibc_FreeBSD && myconf+=' --enable-indirect-deps'
+
+ [[ ${PV} == *9999* ]] && myconf+=' --enable-maintainer-mode'
+
+ ECONF_SOURCE=${S} \
+ econf \
+ --docdir="${EPREFIX}"/usr/share/doc/${PF}/html \
+ --with-system-include-path="${EPREFIX}"/usr/include \
+ --with-system-library-path="${EPREFIX}"/usr/$(get_libdir) \
+ ${myconf}
+}
+
+multilib_src_install() {
+ emake DESTDIR="${D}" install
+
+ if use prefix; then
+ # Add an explicit reference to $EPREFIX to PKG_CONFIG_PATH to
+ # simplify cross-prefix builds
+ echo "PKG_CONFIG_PATH=${EPREFIX}/usr/$(get_libdir)/pkgconfig:${EPREFIX}/usr/share/pkgconfig" >> "${T}"/99${PN}
+ doenvd "${T}"/99${PN}
+ fi
+}
diff --git a/dev-util/pkgconfig/pkgconfig-9999.ebuild b/dev-util/pkgconfig/pkgconfig-9999.ebuild
index 4b8fda17a171..f70a1a0ebc3b 100644
--- a/dev-util/pkgconfig/pkgconfig-9999.ebuild
+++ b/dev-util/pkgconfig/pkgconfig-9999.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2014 Gentoo Foundation
+# Copyright 1999-2015 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-util/pkgconfig/pkgconfig-9999.ebuild,v 1.14 2014/07/29 07:58:43 ssuominen Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-util/pkgconfig/pkgconfig-9999.ebuild,v 1.15 2015/05/27 04:35:41 tetromino Exp $
EAPI=5
@@ -10,7 +10,8 @@ MY_P=pkg-config-${PV}
if [[ ${PV} == *9999* ]]; then
EGIT_REPO_URI="git://anongit.freedesktop.org/pkg-config"
- inherit autotools git-2
+ EGIT_CHECKOUT_DIR=${WORKDIR}/${MY_P}
+ inherit autotools git-r3
else
KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~ppc-aix ~amd64-fbsd ~sparc-fbsd ~x86-fbsd ~x64-freebsd ~x86-freebsd ~hppa-hpux ~ia64-hpux ~x86-interix ~amd64-linux ~arm-linux ~ia64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~m68k-mint ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
SRC_URI="http://pkgconfig.freedesktop.org/releases/${MY_P}.tar.gz"