summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSamuli Suominen <ssuominen@gentoo.org>2012-07-10 16:40:04 +0000
committerSamuli Suominen <ssuominen@gentoo.org>2012-07-10 16:40:04 +0000
commit37c84c21833b1cb7e6fcb04d771f58b29f417fbb (patch)
tree05f48b46ed2bc036f15f0aee3b4a8d8be74a182b /dev-util/pkgconfig-openbsd
parentFix build with boost-1.50, wrt bug #425478. (diff)
downloadgentoo-2-37c84c21833b1cb7e6fcb04d771f58b29f417fbb.tar.gz
gentoo-2-37c84c21833b1cb7e6fcb04d771f58b29f417fbb.tar.bz2
gentoo-2-37c84c21833b1cb7e6fcb04d771f58b29f417fbb.zip
New snapshot after upstream restructure.
(Portage version: 2.2.0_alpha116/cvs/Linux x86_64)
Diffstat (limited to 'dev-util/pkgconfig-openbsd')
-rw-r--r--dev-util/pkgconfig-openbsd/ChangeLog8
-rw-r--r--dev-util/pkgconfig-openbsd/pkgconfig-openbsd-20120710.ebuild59
2 files changed, 66 insertions, 1 deletions
diff --git a/dev-util/pkgconfig-openbsd/ChangeLog b/dev-util/pkgconfig-openbsd/ChangeLog
index 95de9182a3d3..a03c55c6a908 100644
--- a/dev-util/pkgconfig-openbsd/ChangeLog
+++ b/dev-util/pkgconfig-openbsd/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-util/pkgconfig-openbsd
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-util/pkgconfig-openbsd/ChangeLog,v 1.6 2012/05/04 16:16:16 ssuominen Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-util/pkgconfig-openbsd/ChangeLog,v 1.7 2012/07/10 16:40:04 ssuominen Exp $
+
+*pkgconfig-openbsd-20120710 (10 Jul 2012)
+
+ 10 Jul 2012; Samuli Suominen <ssuominen@gentoo.org>
+ +pkgconfig-openbsd-20120710.ebuild:
+ New snapshot after upstream restructure.
04 May 2012; Samuli Suominen <ssuominen@gentoo.org>
pkgconfig-openbsd-20120504.ebuild:
diff --git a/dev-util/pkgconfig-openbsd/pkgconfig-openbsd-20120710.ebuild b/dev-util/pkgconfig-openbsd/pkgconfig-openbsd-20120710.ebuild
new file mode 100644
index 000000000000..e9148e68840b
--- /dev/null
+++ b/dev-util/pkgconfig-openbsd/pkgconfig-openbsd-20120710.ebuild
@@ -0,0 +1,59 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-util/pkgconfig-openbsd/pkgconfig-openbsd-20120710.ebuild,v 1.1 2012/07/10 16:40:04 ssuominen Exp $
+
+# cvs -d anoncvs@anoncvs.openbsd.org:/cvs get src/usr.bin/pkg-config
+
+EAPI=4
+
+PKG_M4_VERSION=0.26
+
+DESCRIPTION="A perl based version of pkg-config from OpenBSD"
+HOMEPAGE="http://www.openbsd.org/cgi-bin/cvsweb/src/usr.bin/pkg-config/"
+SRC_URI="http://dev.gentoo.org/~ssuominen/${P}.tar.xz
+ pkg-config? ( http://pkgconfig.freedesktop.org/releases/pkg-config-${PKG_M4_VERSION}.tar.gz )"
+
+LICENSE="ISC"
+SLOT="0"
+KEYWORDS=""
+IUSE="pkg-config"
+
+DEPEND="
+ pkg-config? (
+ !dev-util/pkgconfig
+ !dev-util/pkg-config-lite
+ !dev-util/pkgconf[pkg-config]
+ )"
+RDEPEND="${DEPEND}
+ dev-lang/perl
+ virtual/perl-Getopt-Long"
+
+S=${WORKDIR}/${P}/src
+
+src_prepare() {
+ # Config.pm from dev-lang/perl doesn't set ARCH, only archname
+ sed -i -e '/Config/s:ARCH:archname:' usr.bin/pkg-config/pkg-config || die
+}
+
+src_install() {
+ if use pkg-config; then
+ dobin usr.bin/pkg-config/pkg-config
+ doman usr.bin/pkg-config/pkg-config.1
+
+ insinto /usr/share/aclocal
+ doins "${WORKDIR}"/pkg-config-*/pkg.m4
+ else
+ newbin usr.bin/pkg-config/pkg-config pkg-config-openbsd
+ newman usr.bin/pkg-config/pkg-config.1 pkg-config-openbsd.1
+ fi
+
+ insinto /usr/share/${PN}
+ doins -r usr.bin/pkg-config/OpenBSD
+
+ cat <<-EOF > "${T}"/99${PN}
+ COLON_SEPARATED=PERL5LIB
+ PERL5LIB=/usr/share/${PN}
+ EOF
+
+ doenvd "${T}"/99${PN}
+}